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1 INTRODUCTION

1.1 PREREQUISITES

This manual is not a general introduction to weaving. If you have no idea on how fabrics are manufactured, it is

unlikely that you will learn it from here. You should study a textile textbook to learn the textile basics.

The user  guide assumes  you have  a working knowledge of your computer  and its  operating conventions,
including how to use a mouse and standard menus  and commands. It also assumes you know how to load,
save, and locate fles.

Some paragraphs will be completely in italic. This means that it is technically; skip it if you are not an expert.

You can read this manual wherever you want, but it will be benefcial if you have ArahWeave system up and
running on your computer, so you can immediately try out the things you learn.

1.2 THANKS & WARNING

Thank you for having chosen Arahne's product. Arahne is weaving its programs day and night, so that it would

be easier for you to make quality fabrics. Therefore it can happen that this manual and the program you will be

using  are  inconsistent.  This  means  that  you  will  fnd  some  more  features,  or  some  functions  will  be

implemented in a diferent (we hopee better) way. We are trying to make our programs as simple as possible

and also provide on-line help, so these changes should not disturb you too much. If they do, we apologize and

we will get better in the next version.

We also appreciate comments and suggestions from our users, as well as reports of malfunctions. The sooner

you fax / email them to us, the sooner your suggestions will be implemented or bugs removed. Sometimes we

will not be able to implement all your suggestions, but we will be able to make good decisions on what to do

next, based on your feedback.

1.3 OVERVIEW OF WEAVING CAD/CAM
If you are new to CAD, you may fnd it difcult at the beginning. Still, the basic operations are similar to using a

word processor. You run the program, enter some data, control it on screen so that it looks correct, you print it

out and save it to disk for future reference or reuse.

ArahWeave distinguishes  itself  from  the  competition  by the  fact,  that  it  was  written  from  scratch for the

multitasking windowing platform. Because of this, it fully exploits the windowing possibilitiese

• Most windows can be resized to provide a bigger view of data, if necessary.

• Windows can be freely moved on the desktop.

• Printing will not block your work.

• You can work with many tools at once.

• Program will always try to give you a coherent view of your data, no matter which part you perform the

change.

The fact that you can have more tools on the screen may be confusing at the beginning, but it permits you to

have a personal style of work. You can close down the tools, which you do not need at the moment, or keep

them open, make changes and immediately observe the efect on the fabric.

There is no general Undo function in ArahWeave, but most functions have their own Undo.

It is relatively easy to construct a fabric. The whole art is to combine these elementse

• Weave (the way the threads interlace) – dobby weaves are mostly small and can be drawn by hand, 

while jacquard weaves are big, and are constructed from a color image, where each color is replaced by

one weave.

• Warp and weft sequences.

• Yarn, count and structure.

• Colors.

• Density of weaving.

Still, sometimes you will be surprised by what a simple interplay of these factors will produce. This is the very 

reason why you should use ArahWeavee

• To play with these settings without constraints and with minimal expenses.

• To communicate the result of your creative work to non-textile people, by printing out the simulation.

• To provide your production departments with printouts of production ticket or CAM data for 

production.



2    C h a p t e r  1  

 I nt r o d u c t i o n
www.arahne.si   

In this way, expensive design errors will be avoided, and CAD system will  soon pay itself back. You will also

gain a lot in response time, since you will be able to give an answer to customer inquiry in just a few minutes.

As worldwide digital  communication  is  a  reality  available  to everyone,  you can send to the client  a  fabric

simulation via electronic mail. It is also possible to construct a your own World Wide Web home page with your

current collection, images of fabrics, pricing, availability etc. Or your design system can be confgured as an

Intranet web server, which delivers technical data sheets to anyone in the company, using any computer or any

operating system, as long as it is networked and it has an Internet browser.

Now we must also tell what ArahWeave will not do for youe It does not do decomposition. Some users expect

that they will simply scan a fabric in a computer, and they will get a printout of the production ticket out of the

computer. This is not possible, because the current level of automatic image recognition does not (yet) enable

us to distinguish the weave from diferent yarn colors used in the fabric. Still,  ArahWeave is a great tool in

decomposition; you can enter data as you decompose the fabric, and verify it on the fy. You will be able to

enter the data both as number of threads and as length in millimeters. The simulation view also enables you to

match  fabric  against  screen  fabric  simulation,  since  they  should  be of  the  same  size  if  data  was  entered

correctly. The program will also help you with automatic adaptation to diferent “qualities”, that is diferent

density settings without changing the overall size of the pattern.

For jacquard users, ArahWeave can also be useful to change / adapt a jacquard card fle prepared for weaving in

one format / loom layout into another format / loom layout.

The majority of the readers of this manual will only be interested in the dobby capability of ArahWeave, since

they greatly outnumber jacquard weavers. The chapters or sections, which are useful almost  exclusively to

jacquard or dobby weavers, will be marked by word jacquard or dobby in the title. We want to avoid confusion

of readers with additional information, which they do not need.

And fnally, we must  tell  you what the logic behind the organization of this manual  is. We have decided to

group chapters and sections in logical problem groups. For each group of functions, we frst try to explain why

are  they  needed,  and  then  how  and  why  do  they  work  in  this  way.  So  we  have  avoided  the  classical

programmer’s manual, which just lists the menu entries from left to right and from top to bottom. We have

also included some tips for weaving, which we have learned thanks to our customers. Unfortunately, weaving

itself is a tightly interwoven topic, so if you read the manual from beginning to the end, you will fnd references

to topics that  will  be fully  explained in later  sections.  So you should really  read it  in a forward /  backward

manner,  or maybe re-read a previous section once you learn new topics that  were mentioned before.  The

negative  side of our  approach is,  that  it  may be difcult  to fnd just  an  explanation  of a  certain  function.

Fortunately, PDF viewers have the search function, so it is easy to fnd all places which mention certain topic.

1.4 HOW TO GET ARAHWEAVE UP AND RUNNING

You  know,  press  the  power  button  on  your  computer.  Wait  until  the  computer  fnishes  its  power-on

diagnostics. If you have several operating systems installed in your computer, you will be prompted by a list of

installed systems. Select by highlighting it with up / down arrows on the list of available systems. If you will

wait too long, it will automatically boot the one that was last loaded, or the default one. If you have installed

only one operating system, it will boot automatically without asking any questions.

On modern Linux desktops ArahWeave is available as one of the program icons  on the Desktop. 
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Figure 1: ArahWeave on OpenSUSE Linux using KDE Desktop

1.5 PROGRAM INSTALLATION

• Insert ArahWeave CD-ROM into a CD-ROM drive. The contents of the CD

should open automatically in a new window.

• If it does not open automatically, click the My Computer icon on the KDE

Desktop, and click on CD or DVD icon.

• Select  the  fles  aw1.tar.bz2,  aw2.tar.bz2,  aw3.tar.bz2  and  INSTAL_AW

from the CD and copy them to the desktop. If you are installing ArahWeave

Personal  Edition the  fles  are  callede  awpe1.tar.bz2  awpe2.tar.bz2

awpe3.tar.bz2 and INSTALL_PE

• Click on the fle INSTALL_AW (or INSTALL_PE)

This will launch the installation utility (Figure 2). Click the OK button, to start

the installation.

Installation will take about 30 seconds to complete, since we give you

a  lot  of  weaves  and  sample  fles.  When  installation  is  fnished,  a

message  indicating  successful  completion  will  appear.  Click on the

Exit button. After that, you can delete program’s installation fles.

1.6 RUNNING THE PROGRAM FOR THE FIRST TIME

There are some user settings, which you should set through  Help > Save setup to make  ArahWeave really

usable. These settings aree

Figure 3: Message after successful
installation

Figure 2: ArahWeave
installation
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• Program activation

• Language

• Measurement system

• Screen size

Click  Arahweave’s icon   on  the  desktop.

Because you are running it for the frst time, and it

is  not  activated,  the  program  opens  the  Save

setup window automatically.

1.6.1 SETTING THE LANGUAGE

English is the default language. The Save setup window is accessible from

the main  ArahWeave window through the  Help > Save  setup.  You can

choose one of nine languages. In languages other than English, the menu

entry Save setup is written in English and in the current language, so it will

be easier to change the language back, if you make a mistake. Language

change is immediate for ArahWeave, but you must restart other programs

(ArahPaint4, ArahDrape), if they are already running.

1.6.2 PROGRAM ACTIVATION

The  Owner feld contains  text  Arahne  DEMO.  In this

feld type the owner name, which was assigned to you.

After clicking OK, the Information window with your

personal registration code pops up.

Send the registration code to Arahne’s e-mail address arahne@arahne.si

We will send you back the activation code. Type your activation code into

the red feld. The program will give notice of successful activation.

Figure 7: Registration code

Figure 6: Activation code feld

Figure 4: Save setup window

Figure 8: Information about
activation

Figure 5: Language selection

mailto:arahne@arahne.si
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1.6.3 USER INTERFACE PROFILES

Arahne makes the program simple for beginners, with all  the basic functions without much distraction, but

also ofers all the advanced functions for customers, who can handle them.

The Mode menu ofers you the choice between Simplifed, Normal, Expert and Server mode.

• Simplifed  mode  is  for  beginners,  it  is  the  default  mode  in  the  demo  version  of  the

program.  It  will  hide most  of the  complex,  hard to  understand  features,  and keep the

essential. For example, beginner probably won’t make fabric with dual weft insertion, two

warp beams, and does not care about the fabric price calculation. A weaving course in

school should use simplifed mode.

• Normal mode is the default for ArahWeave Personal Edition or Pro versions. It shows all

functions, options, buttons and menus.

• Expert mode ofers some exotic, potentially dangerous functions, and should be used for

those, who know what they are doing. One such function in this mode allows users to convert jacquard

cards into fabric fles by using loom layout. Or converting all the weaves from BMP, TIFF, GIF... to Arahne

weave fle format.

• In Server mode, the program’s GUI functions are blocked, and its functionality is triggered by XML fles,

created by the ERP system.

1.6.4 MEASUREMENT SYSTEM

Click  the  Measurement  system in  the  Save  setup

window.  You  can  choose  between  Metric (m,  cm,  kg),

Imperial (yards, inches, pounds), or Mixed.

The  Mixed system  enables  you  to  set  imperial  or

metric system for ffteen diferent parameters, if you

live  in  a  country  where  you  use  both  systems

contemporary. If you need to use both imperial and

metric system, but one at the time, and you wish to

quickly  switch  between  the  two,  you  can  press

keyboard  shortcut  U to  toggle  unit  from  metric  to

imperial and back.

1.6.5 SCREEN SIZE

The next important setting is the picture size of your monitor

in  mm  (width  and  height).  Based  on  this  information,  the

program can show you the fabric simulation in 1e1 size,  and

the  ruler  display  will  match  the  actual  ruler.  On  newer

versions of Linux and with properly confgured monitor and graphics cards, the program will detect the correct

values automatically. In case you change monitor, the old values are wrong – to get new values, click the bulb

icon   next to the unit button (mm or dpi). If the system reports the wrong screen size, you can change it

manually.

1.6.6 DEFAULT WINDOW SIZE

When you save the setup, the current size of the windows is also saved. When you open ArahWeave the next

time, the size of following windows - Weave editor, Decomposed weave editor, Print preview, Main window,

Figure 12: Screen size

Figure 11: Mixed measurement system

Figure 10: Measurement system

Figure 9: The
Mode menu
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Multi-image jacquard conversion,  Multi-fabric  print  setup, Weave browser,  Image browser,  Fabric browser,

Image area of the jacquard conversion window, Consumption calculation HTML area, Warp sections HTML,

will  be as it was, when you have saved the setup. The position of program’s windows on the desktop is not

saved.

2 WORKING WITH FILES

2.1 DIRECTORIES AND FILE TYPES

Since ArahWeave is a versatile program, it needs to read and write many fles for diferent purposes. So before

going into  details  of  the  many capabilities  of  this  program,  we  should  have  a  clear  idea,  about  what  can

ArahWeave read and write, and where should the necessary fles be located.

All  the  user  data  fles  are  stored  in  directory  /home/user_name/data  and  it  contains  the  following

subdirectoriese

• img (color images for jacquard conversion; standard formats), sufxe .PNG, .GIF, .PCX, .JPG, .TIF, .BMP

• textures (fabric simulation images for usage with ArahDrape; standard image formats)

• models (model images for usage with ArahDrape; standard image formats)

• colors (color database with color specifcation in CIE Lab space, Arahne’s custom format), sufx .col (color

measurement for CIE Lab data read with spectrophotometer, ASCII, Arahne’s custom format) sufx .cm

• fabrics (contains all information relevant to fabrice colors, yarns, weave, density and other technical details;

Arahne’s custom format), no sufx

• demo (100 samples so you see what you can do ones you learn the program)

• tartans (300 samples of Scottish tartans)

• yarns (yarn containing yarn colors, count, twist, etc., Arahne’s custom format) no sufx

• weaves (weave containing drafting and card; can also be a full jacquard weave up to 65520x65520, Arahne’s

custom format) no sufx

• demo (100 sample weaves with English names)

• Fressinet (2900 weaves from an old weave library/book)

• Gunetti (1700 weaves from an old weave library/book)

• Poma (2200 weaves from an old weave library/book)

• Posselt (1900 weaves from an old weave library/book)

• Serrure (3200 weaves from an old weave library/book)

• selvedges (place where you should put your weaves for selvedges)

• shading (some satin and serge weaves, which are suitable for gray scale jacquard shading)

• cards (jacquard fles ready for weaving; in loom specifc jacquard formats, for example Staübli JC5, Grosse,

Bonas)

• conversion (jacquard conversion, contains association of a color to a weave, and the selected conversion

type; Arahne’s custom format), no sufx

• loom (loom layout, weft layout;  machine specifc allocation of hooks and weft change; Arahne’s custom

format), no sufx. This directory also contains the .looms fle, used for jacquard loom networking.

• warp pattern (warp patterns in Arahne’s custom format)

• weft pattern (weft patterns in Arahne’s custom format)

• drafting (drafting data in Arahne’s custom format)

• denting (denting data in Arahne’s custom format)

• HTML (fabric technical calculations in HMTL format)

• XML (fabric technical data exported in XML format), also location of XML import fles

• drape (drape projects; Arahne’s custom format), sufx .drape.

The above division  of  directories  is  Arahne’s  suggestion;  you  are  free  to  make  your  own  or to create  sub

directories, wherever necessary – make them by clients, years of collection or whatever you are comfortable

with. To create directories use fle manager.

Whenever you try to load an image, the program will try to guess the correct image data type from among the

supported ones, including all jacquard fle formats and Arahne weave format. The same is valid when you try

to load a weave, images in GIF or TIFF format can be loaded directly and interpreted as weaves; they will be

automatically converted into black and white images if they contain any colors. A notable exception to this is a

weave browser, which works only on weaves in Arahne’s format and WIF. Arahne’s weave format has been
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optimized for speed, and ArahWeave could not load that many thousands of weaves in a second, if it would be

checking them for the fle type from among many supported formats.

2.1.1 FABRIC FILE FORMAT

When you save a fabric fle, it is saved in own Arahne format.  It contains all  information relevant to fabrice

colors, yarns, weave, density and other technical details. If you generate a fabric with replacing colors in the

image with weaves (Jacquard conversion), then also the image and corresponding weaves are saved in the fle.

By default, ArahWeave saves only yarns, which are used in the fabric, in a fabric fle. Next time, when you load

that fle, only saved (used) yarns are loaded, the other yarns in the Edit warp and weft pattern dialog (25 yarns

for each) are default yarns. But if you enable the Save unused warp/weft in the Weaving option of the Save

setup dialog, then all currently yarns from the Edit warp and weft pattern dialog are saved in fabric fle, and

thus loaded when you open the fabric fle next time.

2.2 SETTING A DEFAULT FABRIC

When you open ArahWeave, it displays the default fabric. If you want that another

fabric becomes a default one, load it into program, and choose Help > Set current

fabric as default from the main menu bar. 

2.3 CHANGING DEFAULT DIRECTORIES (FILES)
To change the default location, from where

the  fles  are  loaded or  saved,  you  have  to

load the desired fle from a specifc location

into  ArahWeave (a  fabric  fle  in  the  main

ArahWeave window,  a  weave  fle  in  the

Weave editor,  a yarn fle in the  Edit yarns

window,  an  image  fle  in  the  Jacquard

conversion window,  a  loom  layout  fle  in

the  Save  cards  from  production window,

etc...).  Then choose  Help  >  Save  setup.

Check  the  Set  default  directories button,

and click the  OK button in the  Save setup

window. 

2.4 CHANGING THE DEFAULT LOCATION OF THE ARAHNE DATA FOLDER

Another  way  to  change  the  default

location is to change and save it in a one

step. The default location of data folder is

/home/user_name/data  (in  case  of

ArahWeave  Personal  Edition  it  is

/home/user_name/arahne/data). If  you

want  to  change  location,  open  the  Save

setup  window  and  click  the  Set  default

path button. Type the desired path to a

location in the dialog and click OK.
Figure 15: Set default path dialog

Figure 14: Currently active folders are displayed in the Save setup
window. If you save the setup now, these folders will became the

default folders for loading or saving fles.

Figure 13: Setting current
fabric as default
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2.5 HOW TO SOLVE PROBLEMS WITH PERMISSIONS

When several users are working on the same data fles, and fles are shared via the network, it can happen that

one user  cannot modify or read fles  written  by another  user.  By default,  all  the fles  written  by Arahne’s

programs are saved with read/write permissions to everybody, so that this problem would not occur. If you

don’t like this behavior, you can switch it of in the Expert section of Save setup. But in the case you copy the

fles  from  an  external  source,  for  example  from  e-mail  attachment,  CD-ROM,  or  USB  memory  key,  the

permissions will be set to system defaults. This usually means that others cannot modify your fles. You should

remember  to  use  right  mouse  button  on  the  newly  copied  fles,  and  change  access  permissions,  so  that

everybody can read and modify them. If you forgot to do this, and you get a lot of permission errors, you can

use one command to get all the permissions right.

Open a terminal and typee

su root

---enter your password---

chmod -R a+rw /home/capdam/data

exit

3 FABRIC FILES

Fabric fles related menus are under the File menu in the main ArahWeave

window.

3.1 LOADING FILES FROM FABRIC BROWSER

To load a fabric fle  using  Fabric Browser choose  File  > Load fabric (keyboard shortcut  B).  Thumbnails  of

fabrics are displayed to identify each fabric.

Do one of the following to open the fabric in ArahWeavee double click a fabric icon, or select a fabric icon and

then click OK or press Enter.

If you have set to have both, File selection dialog and Fabric browser available, then use File > Browse to open the

fabric browser.

Figure 16: Fabric fle menu
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Figure 17: Icon fabric browser

The meaning of icons in the toolbar is described in the table below.

one directory up

back

forward

reload

default directory

switch to detailed view; switch to icon view

sort order

fnd fabric

create new directory

rename fabric

delete fabric

open selected fabric with  ArahWeave in a new window (middle-click on a fabric icon does the

same)

The options icon menu and flter options are positioned at the bottom of the window.

• Filters (icon  )allows you to narrow down the number of displayed fabric icons by entering the limits of

weave  size  x,  weave  size  y,  date  of  creation,  number  of  shafts,  warp  and weft  yarns,  number  of

threads in fabric width, warp and weft density, denting and regulator, and fle name. If you use the fle

name flter, the program will interactively change the display to show you only the fabrics, which match the

search flter. In this way you will fnd your fabric very quickly.
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• The sort drop-down option button allows you to choose a criterion, by which you

want to sort the fabric fles. The default criteria  is name, followed by fle size,

date, weave size in horizontal direction, weave size in vertical direction, weave

size in both directions, number of shafts, number of diferent yarns used in warp,

number of diferent yarns used in weft, size of warp pattern repeat (number of

threats), size of weft pattern repeat (number of threats), number of threads in

fabric width, warp density, weft density, number of reed dents in fabric width,

and number of advances (regulator) in weave repeat.

• The Repeat option is enabled by default. It means that the fabric

icon is displayed in continuous repeat; if disabled, then only one

repeat of the fabric is shown.

• Then there are some options to change what is shown in the information below fabric icone  Name,  Size

(repeat size of warp and number of yarns in warp; repeat size of weft and number of yarns in weft; the

weave size), Density (warp density; weft density; number of threads in fabric width), Image (  it displays

the size of the image used in Jacquard conversion and used number of colors), File size, Date.

• If  you  want  to  check  the  number  of  fles  and  sub-

directories in the directories  displayed in the Browse

window, do enable the  Show number of fles option

. The number of fles in the directory is displayed

below  the  directory  icon,  the  number  of  sub-

directories is displayed next to directory icon.

3.1.1 FILTERING BY FABRIC FEATURES

You can narrow down the number of displayed fabric icons by selecting multiple fabric features, temporarily

hiding any fabrics that don't match the criteria. These features aree

•  Fringe

Figure 19: Same icon with a repeat option
enabled (left), and disabled.

Figure 18: Menu of
sorting criteria

Figure 20: The number of fles in directory and the
number of sub-directories
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•  Variants

•  Overprint

•  Variable density

•  Regulator

•  Fil coupe

•  Shading

• Wrinkle

• Weft blanket

•  Jacquard conversion

To change the state of the feature icon, you want to flter by, click on it. Icons can have three statese

•  Inactive (grayed out)e as a gray checkbox indicates, the icon in this state does nothing.

•  Uncheckede fabrics which don’t contain the feature will be displayed in the fabric browser.

•  Checkede fabrics which  contain the feature will be displayed in the fabric browser.

Figure 21: Available flter by feature options. An option may be inactive (grayed out), unchecked
or checked.

3.1.2 SIMILAR FILTER OPTION

The similar option enables searching for fabrics with similar characteristics as the currently loaded fabric in

ArahWeave has. To use this function, load a fabric, to which you want to fnd similar fabrics, mark the Similar

check box, and set the “degree of similarity”. You can search for fabrics, which have same Weave size, Warp

density, Weft density, Number of threads in fabric width, Number of shafts, Warp pattern repeat, Weft pattern

repeat, or Everything (so you don’t need to mark all options).

Figure 22 shows, that there are six fabrics in the directory, which have same weave size in x direction and the

same number of threads in fabric width as fabric loaded in the main ArahWeave window.

Figure 22: The Similar flter option
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3.1.3 USING TOOL TIPS

Position the pointer over an icon, and pause. A tool tip appears, showing Name,

Date  of  modifcation,  Weave  size  warp,  Weave  size  weft,  Number  of  shafts,

Density  warp,  Density  weft,  Number  of  threads  in  fabric  width,  Warp  repeat,

Number of diferent yarns in the warp, Weft repeat, Number of diferent yarns in

the weft, Dents in denting repeat, Advances (regulator), and File size.

3.1.4 BROWSING SUB DIRECTORIES

Arahweave’s browsers have a capability of showing fles in subdirectories. It is very useful, when you search for

a  fle,  but  you  don’t  know in  which directory  you have  saved it.  If  there  are  subdirectories  in  your  parent

directory, then the Fabric browser displays the “leafess tree” icon  in the upper-right corner of the window

(in the same line as a directory path). To display all fles from subdirectories, click the tree icon. It changes to

the “tree with leaves and fruits” icon  , which means, that the Fabric browser shows all fles from the parent

directory and its sub directories. If a fabric was found in a subdirectory, then the name of subdirectory appears

in the fabric’s icon.

You should be careful in the use of this option, since it may take a very long time to fnish and display the fabrics, if

you enable it at the start of your disk (/). The program will not crash, but it must read all the fles on your hard disk,

and this takes some time. So only use sub directory browsing on directories which actually contain the fabrics.

3.1.5 RECENTLY USED DIRECTORIES

In  Arahweave’s browsers,  the

program  shows  a  small  arrow

with  a  drop  down  menu  of

recently used directories in the

editable  location  bar.  You  can

use  this  to quickly  switch from

one directory to another.

3.1.6 BROWSER IN DETAIL VIEW

The detailed fabric fle view shows the main fabrics’ propertiese Name, Date of modifcation, Weave size warp,

Weave size  weft,  Number of shafts,  Density  warp,  Density  weft,  Number of threads in  fabric  width,  Warp

repeat, Number of diferent yarns in warp, Weft repeat, Number of diferent yarns in weft, Dents in denting

repeat,  Advances (regulator),  and File  size.  You  can sort  fabrics by any of these criteria.  A column  of this

property is highlighted in yellow.

Figure 24: Selecting recently used directory

Figure 23: Fabric tool tip
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Figure 25: Detailed fabric browser view

3.1.7 DELETING FILES FROM ARAHWEAVE SYSTEM

If you want to delete a fabric fle, weave fle, or image fle, choose File > Browse from ArahWeave, Edit weave,

or  the  Jacquard  conversion window,  select  a  fle  you  want  to  delete,  and  press  Delete  button  on  your

keyboard, or click  icon in the toolbar. You will be warned before the fle is actually deleted, but once you do

it, there is no way back.

3.1.8 RENAMING FILES

You can also rename fabric fles from the Browse windowe press the left mouse button on the name below the

fabric’s icon, or   icon in the toolbar. A small  window appears and you just type the new name and press

Enter. For the rest of the fles, use the fle manager.

3.2 LOADING RECENTLY USED FABRICS

ArahWeave remembers  recently  used  fles

and directories. To open one of recently used

fles,  choose  File  >  Load  recent.  Set  the

number of recently used fles in the  Number

of  recent  fles feld  in  Save  setup  >

Appearance.  You can also set  the icon size,

and  either  you  want  detailed  fabric

information or not.

Figure 26: Loading recently used fles
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3.3 SAVING THE FABRIC

To save a fabric, select the Save fabric function from the File menu, if you

want to save it under existing name, or Save fabric as function if you want

to make a fabric with a new name. All the data relevant to this fabric will be

saved, including density, weave, warp and weft pattern, colors, etc.

The Save fabric dialog also enables you to create a new directorye click 

and enter the name of the new directory.

To generate  flename  from the information,  that  you have stored in  the

fabric  properties  dialog,  click   icon.  Please  read  more  about  the

automatic flename creation in Chapter 20.3.1.

Figure 27: The Save fabric dialog

3.3.1 HIDING THE SAVE MENU

Some customers work really fast, and sometimes hit  Save instead of  Save

as. There is no way back, when fle is overwritten. But, if you hide the Save

option from the menu list, then this will never happen to you again.

To hide the Save menu, open the Save setup window, click the Appearance

tab, and mark the Hide save menu button.

3.4 RELOAD FROM DISK

Function  Rload from  disk reloads the  current  fabric  from disk and loses all  recent  changes.  The keyboard

accelerator is [Ctrl+U]. It is useful when you are experimenting, mess up a fle beyond undoing, and just want

to quickly get the latest valid state of the fle.

3.5 SAVING A FABRIC IN .WIF FORMAT

The WIF format is a simple plain ASCII fle format intended for the exchange of weaving fles among diferent

programs. To save fabric in a wif format, you have to write .wif extension to the fle name in the Save fabric

as dialog.

Things that WIF lacks (and ArahWeave supports)e

• Fabric background color 

• Colorimetry with CIE Lab specifed colors (only RGB colors are supported, and only one color - no distinction

between screen and print colors) 

• The concept of repeat 

• Denting 

• Regulator 

• Yarn composition 

• Multicolor yarns 

• Mouline / melange / chenille / printed / slub yarns 

• Data necessary for fabric calculation of fabric consumption (total number of ends in the warp, selvedges,

reed width, fnished width, ...) 

• Yarn count

What WIF has (in Arahweave’s implementation) 

• Weave up to 99 shafts 

• Warp and weft pattern 

• Warp and weft colors 

• Warp and weft density (in the form of yarn space) 

• Yarn diameter; each yarn can have its own diameter

Figure 28: Hiding the Save menu
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4 VIEWING THE FABRIC

The main window of ArahWeave program will always display fabric in a particular view mode and zoom factor.

View mode will determine the quality (and speed) of the simulation, while zoom will permit you to work with

more precision or inspect greater detail of a very dense fabric.

The display area of the fabric always matches the total  number of warp threads in the fabric. So it  is quite

important to enter this number correctly. You set the number of threads in the Consumption window (Fabric

> Consumption).

4.1 ZOOM LEVEL

There are fve ways to change zoom level in ArahWeavee

1. Choose the Zoom menu, and click desired zoom level from the list. There are 31 entries from 1:16 to 16:1.

1:8 means 12,5%, 1:1 means 100%, and 1:15 means 1500%.

2. Press key + to zoom in, or press key – to zoom out.

3. Press the Ctrl key on the keyboard and roll the mouse wheel up or down.

4. If you press any number from 0-9 on the keyboard, you will  change zoom directly to that level (1 means

100%, 6 means 600%, 0 means 1000%).

5. If you press any number from 0-9 + CTRL on the keyboard, you will zoom out fabric view (CTRL + 1 means

10%, CTRL + 5 means 50%). This only works in simulation view.

4.2 VIEW MODE

There are four possible view modes, and they are always available from the View menue Weave [w], Integer

[a],  Shaded integer [s], and Simulation [s]  . Simulation comes in several quality levels - from 1 to 7. As you

increase  the  level  of simulation,  the  program  calculates  more  points  for each screen  point  and calculates

average color, and you get more accurate simulations. In this way, you can vary the speed and quality of the

simulation according to your computer speed, type of design, and stage of designing (creative modifcations or

fnal preview).

4.2.1 WEAVE VIEW

This view mode shows the weave in repeat in black and

white.  It  is  useful  when you  are  drawing a  new weave,

since it is easier to see the errors in weave repeat. If you

enable the  Fringe option you can also see the warp and

weft pattern on the bottom and left of the weave.

Figure 29: Weave view of the fabric with fringe
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4.2.2 INTEGER VIEW

This view mode just shows the fabric in repeat. One pixel

(point on the screen) will be used to simulate one thread.

If  you  choose  bigger  zoom  (200%,  300%)  two or more

pixels  will  be  used  for  one  thread.  This  is  the  fastest

mode, and is usually used in the design phase. In all view

modes, the fabric simulation starts  from the bottom, in

full  respect  of textile  tradition.  In the  title  of the  main

ArahWeave  window you will  also  fnd the  name  of the

currently loaded fabric and the size of the repeat in warp

and weft in number of threads. If the sizes of weave and

warp / weft pattern are not divisible, this number will be

the  smallest  common  denominator  of  these  values.

However,  the  upper  limit  of  repeat  size  in  threads  is

65520 × 65520 threads. If you see this value in the title of

the  main  window,  the  size  of  the  weave  and  pattern

repeat are probably wrong, since they do not divide each

other.

4.2.3 SHADED INTEGER VIEW

This mode shows the fabric in repeat, but on zoom levels

higher than 300 % adds shadows to threads, so you can

easier see interlacing and distinguish between warp and

weft.

4.2.4 SIMULATION VIEW – SETTING THE DENSITY

The Simulation mode shows the fabric in real 1e1 density with respect to fnished

fabric. You must enter the density for warp and weft, expressed as the number of

threads per centimeter (or inch). To set density, choose Fabric > Density.

You can set the density as the number of threads per centimeter (inch), or as size

of  repeat  in  cm  (inches),  for  both  warp  and  weft.  Note  that  only  number  of

threads per one cm is saved in fle, repeat size is calculated from the other data.

You can also set Zoom (%) to any value between 5% and 1500%. The Simulation

view  shows  the  fabric  in  real  1e1  size,  including  yarn  diameter  with  holes  (in

background color, which can be defned in the Edit colors window), if the yarns

are thin with respect to density.

If you activate the Density from technical data button in the upper part of the

dialog, then the density is automatically calculated from other data, which you

enter  in  the  Calculation  of  thread  consumption window  (Fabric  >

Consumption; more about setting the technical data in Chapter 14). The density

entry numeric felds are grayed out to indicate, that you cannot change them in

this window. Density from technical data must be activated, if you want to have

a simulation of denting and / or regulator efects. Otherwise, the fabric will be simulated with a single density

across the whole fabric. The reason for this behavior is simplee a big majority of fabrics will be simple, and all

Figure 32: Set weaving
density

Figure 31: Shaded integer view of the fabric with
fringe

Figure 30: Integer view of the fabric with fringe
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you will need is the warp and weft densities. Besides, in the design phase, you will not have all the technical

details necessary for correct automatic calculation of density.

You will be able to see the shades, which are caused by the thread interlace. It is the most accurate and also

the slowest view mode. You have 8 simulation quality levels, each being approximately two times slower than

the previous one. Do not use simulation quality 8, unless you really need it, since it is very slow. Try simulation

quality level 4, and then increase it, until you get a simulation of proper quality.

The accuracy  of colors  must  sometimes  be compromised to get  the  shades,  since the yarn color must  be

darkened and lightened on the edges. This is not possible for completely white and black, since we are blocked

by limits of color reproduction. The white becomes slightly grayish and black will be a little lighter.

Figure 33: Simulation view of the fabric

 

4.2.5 SETTING THE FABRIC DENSITY UNIT

ArahWeave has an option in the  Measurement system section of

the  Save  setup dialog,  to  set  Density  unit.  For  example,  many

customers like to express density per 10 cm, not in 1 cm, which is

Arahweave’s default. Once you set it, the program will display all densities in that unit. The Density unit is also

saved in the .arahne confguration fle.

4.3 RAISED FINISH SIMULATION

If you want to simulate the raised fnish your fabrics, activate function Simulation from the Fabric menu. You

will be able to enter the length of raising in tenths of mm for warp and weft, as well as direction (up / down /

left  /  right)  and intensity  (0-10).  You  should  play  a  little  with  these  parameters  to  fnd values  which best

represent  the  fnishing  that  you  are  actually  using.  The  raised  fnish  window  displays  the  preview  of  the

selected efect. Once you are satisfed, click the OK button, and it will be applied to the whole fabric display

window.

Figure 34: Setting density unit
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Figure 35: Raised fnish simulation
 

4.4 FRINGE VIEW

This option will  enable you to view warp and weft pattern on the left and bottom of the main  ArahWeave

window. The Fringe option is a toggle button in the View menu, but you can also enable it from the keyboard

by pressing f. It works in all views, but you must scroll the fabric to the left edge and to the bottom to see it.

Using this feature, it is easier to graphically see the emerging warp or weft pattern, as you type it in (or draw it

with mouse).

4.5 RULER

When visible, ruler appears along the top and left side of the main window. Markers on the ruler display the

pointer’s  position  when  you  move  it.  To show  or  hide ruler,  choose  View > Ruler  or press  Ctrl+R on the

keyboard. It displays the length and position in threads or in centimeters. To switch between the two units,

click on the ruler unit indication (points, cm) (see Figure 36). If you want to have the ruler in inches instead of

centimeters,  you must  change the measurement  unit from metric to imperial  in  ArahWeave’s  Help > Save

setup. The ruler has also two functions which help you fnd position in warp or weft pattern ( right click on

ruler positions cursor on that place in  thread pattern editor) and denting or regulator (middle click on ruler

position cursor in weave editor in denting or regulator feld on that place).

Figure 36: Ruler with unit in threads and centimeters

 

If there is  an image loaded in the Jacquard conversion  window, then the ruler has additional, third mode: the
image preview, which is displayed instead of a ruler. Using this function, it is easy to copy warp/weft patterns from
scanned samples.
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Figure 37: Image (scanned fabric) displayed in ruler  

4.6 ONE REPEAT

One  repeat fabric  view  is  available  from  the  View menu  of  the  main

window. It is most useful, when you are making a blanket, shawl, napkin,

or any other one piece type of fabric. You will clearly see where does the

repeat end. One repeat means a repeat of all fabric parameterse weave

size, warp and weft pattern, and denting/regulator. If one of them will not

divide the other, the repeat may be larger than you expect. One repeat is

both a view mode and a fabric property. It is saved in the fabric fle. This

feature  is  usually  used  for  one  piece  designs,  like  picture  weaving,

blankets, shawls,  napkins and tablecloths. You can also choose to view

one repeat only in the warp, or in weft direction. This is useful for narrow

designs, where you want them to be repeated in one direction, but not in

the other.

Figure 38: One repeat view

4.7 PAN TOOL

To pan the fabric move it while holding the left mouse button down. During

moving the cursor pointer changes from an open hand   to closed hand

 .  You  can  modify  the  color  of  the  hand  in  Save  setup  >  Colors by

changing the RGB values (click the Edit button to open the Color Editor to

specify a color). The pan tool is not working, when warp/weft editor, yarn editor or color editor are open. In

that case, the mouse pointer will be used to draw warp or weft pattern. If you still  want to use pan tool with

those windows open, select background color (#) at the end of the warp/weft letters in those editors.

Figure 39: Changing the mouse
pointer color
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4.8 MODIFIED FILE STATUS

The  color  of  the  square  in  the  bottom  right

corner  of  the  main  ArahWeave window

indicates  the  modifed  fabric  fle  status.  The

square  turns to red from green after applying

some changes in the fabric (yarn, color, weave,

technical  data)  to  the  fabric.  When  you  save

the fabric, the square becomes green again.

Figure 40: After change, the square turns to red

4.9 CLOSING ALL POP-UP WINDOWS

The Close windows function from the View menu closes all pop up windows, so you don’t have to close them

one by one. It serves for quickly cleaning up the desktop if you have too many windows open. You can also do it

by pressing Ctrl+W, or by clicking on the modifed fle status indicator (doesn’t matter if it is red or green).

Figure 41: After clicking the fle status button only the main window remains open

5 EDITING THE WEAVE

The weave is basic element of fabric construction, which controls the way in which threads will  interlace. A

black point means that warp (vertical thread) will be on top, and a white point means weft (horizontal thread)

will be on top.

To design a new weave, select Edit from the Weave menu, and weave editor window will pop-up (right click on

the fabric pops up weave editor as well). While you are editing the weave, you can check at any time what will

the new weave look like in the fabric.

5.1 LOADING AND SAVING WEAVES

You can load and save weaves from the File menu in the Edit weave window.

Please note that a weave must be consistent, if you want to save it. In case of

shaft weaves, this means that weave, drafting and card must all be in place and

correspond to each other. The program will  always check the weave prior to

saving,  but  it  will  make  the  drafting  and  the  card  from  the  weave,  if  any

inconsistencies will  be found. Normally,  this will  give good results.  But if you

draw only a dobby card, while drafting and weave will be empty, it will clear the

card during saving.

Besides Arahne’s proprietary  weave format,  ArahWeave also loads GIF, PNG,

JPG,  PCX,  BMP,  and  TIFF  formats,  as  well  as  electronic  jacquard  formats

(Bonas, Grosse, Schleicher, Stäubli JC3, JC4, JC5, TIS/Actrom). Jacquard foppy

formats are mainly MS-DOS formatted, so you can copy them to Linux using

fle manager. The exceptions are Stäubli JC3 and JC4, so we have implemented

function  Read Jacquard  foppy in  the  Weave menu  of main  window,  which

copies them to Linux (to directory /tmp/floppy). Figure 42: Choosing a weave
format
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You can save the weave in Arahne format, or in WIF, PNG, TIFF, GIF, BMP formats, if you need to export the

weave to some other program. Choose the format of saving in the Save weave window from a drop down

menu.

5.1.1 LOADING RECENTLY USED WEAVES

ArahWeave remembers recently used

fles  and directories.  To open one  of

recently used fles choose File > Load

recent.  Set  the  number  of  recently

used  fles  in  the  Number  of  recent

fles feld  in  Save  setup  >

Appearance.  You  can  also  set  the

icon size, and either you want detailed

weave information or not.

Figure 43: Loading recently used fles

5.2 DEFAULT WEAVES

Some of the most common weaves are accessible trough a list  under  File >

Load  default.  But  function  is  much  more  practical,  if  you  use  keyboard

shortcuts, which are simply the number keys from 1 to 9. For instance, if you

press 2 on a keyboard (and the weave editor window has a focus), the weave

will change to plain weave. The same applies toe

• The Decomposed weave editor.

• The weave entering area in the Jacquard conversion window.

• The  weave  (selvage)  entering  area  in  the  Save  cards  for  production

window.

0 1 2 3 4 5 6 7 8 9

Figure 44: Weaves and corresponding keyboard shortcuts

Here  we  mention  additional  keyboard  shortcut  which  complements  the

weaves keyboard shortcutse the Space key inverts weave in the weave editor

– for instance, if you need the warp efect satin 5 weave – just press 5, and

then the Space key to invert weft efect into warp efect.
Figure 45: Loading default

weaves

5.3 WEAVE BROWSER

You  can  also  graphically  browse  your  weave  database,  and  select/load  the  weave  based  on  its  graphical

appearance. In the Edit weave window, choose File > Browse (keyboard ALT+B). The program will load all the

weaves from the current weave directory. It will show the total number of loaded weaves in window title.
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Figure 46: Weave browser

 

The meaning of icons in the toolbar is described in the table below.

one directory up

back

forward

reload

default directory

fnd weave

create new directory

rename weave

delete weave

The Filter option allows you to search for a particular weave by weave size x, weave size y, number of shafts,

effect (warp or weft), foat x, foat y, total foat, K factor x, K factor y, K factor xy. If you use the fle name

flter, the program will interactively change the display to show you only the weaves, which match the search

flter.

You can toggle the Grid size (number of screen pixels) from 1 to 4. The Size of area reserved for display of one

weave is also modifable – you can choose between 30, 40, 50 and 60 weave points. Your view of weaves can

have an indication of repeat,  can be in  black and white  or in  warp /  weft  colors,  and can have the weave

flename and size in the title (Label). To load a weave just double click on it or click the OK button.

5.3.1 SHRINK OVERSIZED OPTION

When weave is big the icon display area becomes too small for clear

weave presentation. Weave browser has an additional display modee

the Shrink oversized mode. In this mode, browser scales big weaves,

so  you  get  a  clearer  idea  about  the  weave.  To enable  the  Shrink

oversized mode, switch on  icon. Figure 47 shows the icon of the

same weave in the default  view mode, and in the  Shrink oversized

view mode. Figure 47: Shrink oversized view
disabled and enabled on a large weave
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5.3.2 BROWSING SUBDIRECTORIES

Arahweave’s browsers have a capability of showing fles in subdirectories. It is very useful, when you search for

a fle, but you don’t know in which directory it is. If there are subdirectories in your parent directory, then the

Weave browser displays the “leafess tree” icon  in the upper right corner of the window (in the same line

as a directory path). To display all  fles from subdirectories, click the tree icon. It changes to the “tree with

leaves and fruits” icon  , which means, that the Weave browser shows all fles from the parent directory

and its  subdirectories.  If the weave is from the subdirectory, then the name of subdirectory appears in the

weave icon.

You should be careful in the use of this option, since it may take a very long time to fnish and display the weaves,

if you enable it at the start of your disk (/). The program will not crash, but it must read all the fles on your hard

disk,  and this  takes some time. So only  use a subdirectory browsing on directories  which actually contain the

weaves.

5.3.3 RECENTLY USED DIRECTORIES

In Arahweave’s browsers,  in directory entry text  feld, the program shows a small  arrow with a drop down

menu of recently used directories. You can use this to quickly switch from one directory to another.

Figure 48: Weave browser's recently used directories list  

5.3.4 DATABASE OF WEAVES

A huge database of about 35.000 weaves in the directories Ashenhurst, Donat, Serrure, Gunetti, Fressinet and

Poma is included in the standard ArahWeave installation.

5.4 ELEMENTS OF THE WEAVE EDITOR

Figure 49 shows the elements of the Edit weave window (the Dobby view should be enabled – View > Dobby,

otherwise only the weave section of the weave editor is visible – see Chapter 5.6.4).

The weave itself  is  in the lower left  angle.  To draw a black point  (warp over weft),  position the mouse to

desired point and press left mouse button, while with right mouse button you draw white points. It is also

possible to keep the mouse pressed and draw interactively. Starting point of the weave – frst warp thread,

frst weft thread is in the lower left corner.

On top you have the drafting, on the right is the dobby card and in the upper right angle you see tie-up. Tie up

is  fxed,  since  it  cannot  be  changed  on  industrial  dobby  looms.  You  can,  however,  choose  between

confguration of dobby on left and dobby on right of the loom. You can toggle it from the Dobby menu of the

Edit weave window.

On the leftmost part of weave editor you see the weft pattern (starting from bottom) and on the bottom the

warp pattern (starting from left). This can be very useful when the warp and weft patterns must be aligned

with weave.

A denting is displayed on top of the weave and below drafting.

A regulator is displayed to the right of the dobby card. 

The variable weft control functions have a place next to the regulator. You have to enable them in the Density

window, if you want to use them – see Chapter 14.7.1.



2 4    C h a p t e r  5  

 E d i t i n g  t h e  w e a v e
www.arahne.si   

Figure 49: Weave editor

The small triangles (meant to be arrows) indicate the end of repeat. They will be displayed for warp and weft

pattern, denting, and for regulator, if present.

There are three ways to draw a weavee

• Set the size of the weave you want to use, draw the weave, apply the function Check weave > Optimize

the  number  of shafts  > Left  from the Dobby  menu  in the  Edit weave window. The dobby card and

drafting will be drawn automatically.

• Just draw the dobby card followed by drafting, while the weave will be drawn automatically.

• You can also draw the weave (or load it from a database), set the number of desired shafts, and draw the

drafting with middle mouse button yourself – the card is drawn automatically. This case is most common

in industrial set-ups (and small weaves), when users want to have certain non-optimal drafting with bigger

number of shafts, which is more suitable for weaving (for example, step 2 or step 3 instead of straight

draft).

When you insert  a  drafting point,  the program automatically  translates  the points  drawn anywhere in the

pattern draft across other elements. In this way, pattern draft stays consistent. This can be disturbing, if you

want to freely draw the weave, while you have a drafting, which you plan to change. To avoid this efect, clear

drafting by Dobby > Drafting > Clear  (keyboard shortcut is  x). You can also make a transition from “left” to

“right” dobby by Dobby > Dobby on right.

On the drafting area, left mouse button will draw a black point, copying from card to the weave on that warp.

Middle mouse button will draw a black point, copying from weave to the card on that warp. The right mouse

button will clear the drafting on that point.

The Edit weave window title displays some additional informatione weave flename, weave repeat size in warp

and weft, the number for shafts used in this weave (if it is a dobby weave), and the number of warp / weft

threads system (if diferent from 1).
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Figure 50: Edit weave window for a weave with regulator (extra wefts)

 

If number of shafts is not minimal, it will display them as 8/6, which means 8 shafts, but only 6 are really 

needed. Bigger number of shafts is often used in weaving to balance weight of shafts.

Weave editor supports very big weaves; actually - full jacquard weave can be loaded in  ArahWeave. In such

case, the program does not show dobby card and drafting. It stops displaying these data when the number of

shafts is superior to 99. Actually, nobody uses more than 36 shafts, but having up to 99 shafts can be useful for

editing purposes.

5.5 WEAVE EDITOR TOOLBAR

The toolbox is in the upper left corner of the weave editor. It contains 24 icons, most

of them are self-explanatory. When you make any change to the weave, either by

drawing, or by using these tools, the result will  be immediately visible on fabric in

the main window, if you are in integer view. If you are in simulation view, you will

have to apply the changes in the weave (click  icon on the bottom right) to see

the result. If there is a selection in the weave, tools work only on the selection.

Clear weave Tilt right (transforms vertical line to right diagonal)

Horizontal mirror Tilt left (transforms vertical line to left diagonal)

Vertical mirror Tilt up

Rotate 90 degrees Tilt down

Shift left by 8 Shift right by 8

Shift up by 8 Shift down by 8

Shift down by 1 Shift right by 1

Shift up by 1 Shift left by 1

Add warp (black) points Apply weave to fabric simulation

Remove warp (black) points Invert (shortcut is the Space key)

Match weave size to warp pattern Undo

Figure 51: Tools for
weave editor
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Match weave size to weft pattern Redo

Zoom out Deactivate selection

Zoom in Edit decomposed

Draw twill (diagonal)

5.5.1 SHIFTING THE WEAVE

As the name indicates, click on one of the shifting icons shifts weave to the desired directions for one (single

arrow) or eight pixels (double arrow).

Shift left by 8 Shift right by 8

Shift up by 8 Shift down by 8

Shift down by 1 Shift right by 1

Shift up  by 1 Shift left by 1

5.5.2 TILTING THE WEAVE

The tilt tool shifts every next line (or column) of the weave for one thread to the desired direction. The most

common use is for fast creation of satin weaves.

Tilt right (transforms vertical line to right diagonal)

Tilt left (transforms vertical line to left diagonal)

Tilt up

Tilt down

5.5.3 ADDING AND REMOVING POINTS

The add tool ads one point to the right of already black point. You can press it more times to achieve desired

result. The Remove tool works similarly; it removes black (warp) point to the left of white point. Both tools are

useful for a fast conversion of warp weaves into the weft weaves, and opposite.

Figure 54: Adding or removing points
 

5.5.4 DRAWING DIAGONAL LINE (TWILL)

This tool enables you to draw a twill weave with one click. Actually, it negates the color of points, which form a

diagonal line. If the initial weave size is not a square, it continues to draw diagonal line till it reaches the edge

(last  thread)  of the  weave.  The tool  works  best  in  the combination  with the  adding and removing points,

described in previous chapter.

Figure 52: Original weave,
and weave shifted by two to

the right

Figure 53: Original image, tilting one time, and
tilting three times to the right
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Figure 55: Drawing a diagonal

5.6 WEAVE EDITOR VIEW MODES

5.6.1 YARN 

If  you  enable  the  Yarn  colors toggle

button  from  the  View menu,  the weave

will be displayed in warp / weft colors. On

the  card,  weft  points  are  drawn  in  weft

colors,  while  warp  points  remain  black.

Other  elements  of  weave  remain

unchanged.

Figure 56: Yarn colors view mode

5.6.2 JACQUARD 

Jacquard colors is  an additional  view of weave in weave editor.  You can access it  from the  View menu of

weave editor. It is intended for use in jacquard design, when you are fxing the long foats, and want to be able

to precisely see the transition between the two colors efect. If you only see the weave in black and white, you

cannot see the exact transition from one weave efect to another, since weaves are sometimes similar. This

view is enabled only if jacquard weave size in jacquard conversion matches the weave size. This view mode

also works on a decomposed weave view.
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Figure 57: Jacquard colors view mode; you can see the weave of each color

5.6.3 REGULATOR VIEW

The Regulator  view helps you to distinguish between “normal”  and regulator  wefts.  It  is  useful  on a large

Jacquard weaves, especially if you want to draw some regulator controls manually (with mouse). Warp points

of the extra weft are drawn in blue, weft points are drawn in yellow.

Figure 58: Normal weave view and regulator view mode

5.6.4 DOBBY VIEW

The  dobby view enables you to switch dobby card on or of,

since sometimes  you do not wish to be disturbed by it.  For

examples,  customers  who  only  have  jacquard  looms,  don’t

need to look at the dobby card and drafting. 

5.6.5 CROSS SECTION VIEW

You can also enable the display of horizontal  and vertical  cross section. The cross section is interactive - it

shows you the cut at  the current  mouse position.  You can draw over the cross section with the mouse to

change the position of threads, and weave will be modifed accordingly.

Figure 59: Dobby view on and of
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Figure 60: Cross section in the weave editor
 

To control a number of threads in the cross section at a time, set the System parameter in the Change weave

dimension window (Figure 61).

5.6.6 DECOMPOSED COLORS VIEW

The Decomposed colors view mode is the great tool for composing multilayer weaves, especially for placing

the stitching points between the fabric layers. Each layer has a diferent color pair for presenting warp and

weft points, which enables faster and more accurate placement of stitching points.

Figure 62: Normal and Decomposed colors view

5.7 THE EDIT MENU

The edit menu contains some usual commands like Undo, Redo, Select all,

Crop,  and some  nonstandard commands relating to  the  manipulation  of

weaves, like functions which change size or repeat of weave, or fx foats.

Figure 63: The Edit menu

Figure 61: Setting the
weave System
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5.7.1 SETTING THE WEAVE SIZE

To change the size of the weave, choose Change > Dimension. You will be able to 

changee

• Repeat – size for warp and weft (maximum 65520 by 65520, minimum 1x1)

• Grid –  how many pixels should be used for one weave point (on screen only,

proper value depends on your eyesight, monitor size and chosen resolution of

the graphics card

• Thicken – every how many lines one should be thickened to facilitate counting

(on screen and in print)

• System –  the number of threads in the warp and weft (leave it at 1 for single

layer  fabrics).  They  are  meant  only  for  documentation.  It  shows  the  user’s

intent for this weave, and does not refect the real efect of the weave on the

fabric.

• Shafts –  how many shafts do you intend to use (do not be disturbed by large

value on jacquard weaves, just leave it as it is)

Figure 64: Setting the
dimensions of the weave

You can freely change these values; you will not lose the previously entered data if you diminish the weave to

something smaller than what you have previously drawn. Just enlarge it again, and it will be where you have

left it. The size of the weave will interactively change, if you will use the arrow buttons. Otherwise, you have to

click the OK button to apply the new settings.

5.7.2 SETTING THE WEAVE SIZE WITH MOUSE

You  can  change  the  weave  size  using  the

middle mouse button by clicking on the weave

control row and column at the desired position.

For instance, if you want to set the size of the

weave repeat to 16 by 8, just click with middle

button the 16th point of the weave control row

and the 8th point of the weave control column

(in  the  Figure  65,  arrows  indicate  the  weave

control row and column; 8th and 16th points are

marked with X).

5.7.3 EXTENDING THE WEAVE

To repeat  (extend)  the  whole  weave,  choose  Edit  >  Extend  weave.  In  the  Extend  weave  dialog,  set  the

number of repeats, that you want to have in a new weave. As you change the number of repeats, the program

extends the weave. You can observe the fnal repeat size in the title bar of the weave editor.

Figure 66: Extending the weave in a quick way  

Figure 65: Setting the weave size with mouse
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5.7.4 DOUBLING THE WEAVE SIZE IN WARP / WEFT

The  Double  weave  size  in

warp (or  weft)  function  is

another  way  to  increase  the

size  of  the  repeat.  Each  time

you call it, the size will double

the  previous  value.  Keyboard

accelerator for  Double weave

size  in  warp is  ( ;  keyboard

accelerator  for  Double  weave

size in weft is ).

The down size of doubling the weave size is, that it probably won’t give you exactly the size you want, so you

must frst make a bigger one, and then reduce it to the desired one.

5.7.5 PASTING A WEAVE ACROSS WEAVE EDITOR AREA

This function enables you to extend the weave, that you have just draw in the part of the weave editor, across

the whole area of the weave editor. To do this, press the Ctrl button and click with the left mouse button in the

left upper point of the area, that you want to copy across section.

Figure 68: Extending the weave with Ctrl+left click on the  left upper point of the area, that you
want to copy

 

This function also works in the Edit decomposed weave editor.

5.8 LONG FLOATS – STATISTICS AND CORRECTION (JACQUARD)
One of the most important properties of the weave is the maximal length of foats – that is over how many

warp (weft) threads does one weft (warp) thread pass without interruption (stitch point). There are no golden

rules for these – it all depends on your density and the purpose of the fabric. 

Usually you will only remove long foats in jacquard fabrics; dobby weaves are relatively simple, so that long

foats are not an issue. In any case, it can be quite informative to look at the report of long foats. Why do we

have problem with a long foats  in jacquard,  and not in dobby? In jacquard,  we are putting together many

weaves, each of them will be OK, but on their junctions (point where one weave will change into another), long

foats are almost certain to pop-up.

The quality of weave selection, and resulting number of long foats, depends a lot on the experience of the

designer. You can use the long foat report as an early warning – something could be wrong with your weave

selection, if you have many long foats. You can also use the automatic foat correction, but do not over exploit

it. If you have over 1000 long foats, you should reconsider your design and weaves. Spelling checker can hide

Figure 67: The Double weave size in warp and Double weave size in weft menu 
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your language incompetence to some extent, but bad writing will remain bad, even if all the words are correct.

Same goes for the automatic foat correction.

To enable long foat report, choose Float from the Edit menu. You will see a window with a separate graphical

report of foat length for warp, weft, face and back of the fabric. You may need to resize the window to see all

the data. If there is enough space, the program will display the exact number of foats of length 1, length 2,

length 3, etc. To see how many foats of warp are longer than 5, just click on column 5 or set the number 5 in

the Warp Face feld, and the program will sum up the total number of long foats and display them in red in the

relative  upper  right  corner.  Besides,  it  will  also  display  what  is  the  length  of  foat  over  5  threads  in  mm,

according to the current density setting.

Figure 69: Correcting long foats  

By clicking the foat report, you set the length of acceptable foat. To see the location of errors, click on the

Mark long foats toggle button, and weft long foats will be marked in magenta, while warp foat errors will be

marked in red. The program shows only the errors on the face of the fabric both in the Edit weave window, as

in the main fabric display window, if the view mode is  Weave or  Integer. To see the long foats on the back

side, negate the weave   , or  Reverse the fabric. You can intervene directly on the weave and correct the

long foats as if you were drawing a weave, or in the fabric main window, using the middle mouse button. The

statistics of the long foats is updated interactively. Do not keep the foat errors marked or foat report window

mapped, when you do not need it,  since it  will  signifcantly slow down some interactive operations on big

designs.

If the weave is very big and you cannot fnd the location of foat error(s), just click on the Find button. It will

scroll the weave window to the location of the frst foat error on the bottom left. To go to next foat error,

correct the frst one and click Find again.

Float report can be mapped, even if weave window is not mapped.

Float  report  can be made  in  three  variations (for both warp and weft)e  total,  by threads and by denting /

regulator. This enables you to treat separately foats of diferent thread types. For example, you have some

ground efect threads and some extra fguring wefts. You can allow longer foats for fguring wefts, and short

foats for ground weave.

To automatically remove long foats, click the  Remove button. This function will work only if long foats are

marked, and it will correct only errors on the face of the fabric. To correct them on the back of the fabric, you

can reverse  the fabric,  or choose  Fix foat face  and back from the  Edit menu in the  Edit weave window.

Sometimes, it will not correct all the errors, since by correcting the error on the warp, it would create an error

in the weft.

How does foat correction work? Automatic foat correction can operate in two wayse
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1. If you have a weave, which was not just converted from color image and weaves, it will put the stitch point

somewhere in the middle, or periodically at permitted foat length, if several stitch points are necessary to

correct a single long foat.

2. Another way will be automatically used, if you have just inserted the weaves in a color image, and you are

correcting the resulting jacquard weave. The program will frst try to put the stitch point at the change of

color efect; this would be considered more accurate according to most weavers. Of course, to do this, we

need the original color image. So we suggest that you do the long foat correction immediately after the

insertion of weaves.

By default, the jacquard image is saved in the fabric fle. So you will  be able to use the second type of foat

removal even on the following day, if you, by any chance, forgot to remove the long foats. If the image was

deleted from the fabric (using File > Free image in the  Jacquard conversion window), then the frst type of

foat removal will be used.

Last, but not least, if you make a mistake by clicking Remove when you did not mean it, click the Undo icon in

weave tools.

5.8.1 CORRECTING LONG FLOATS IN FIL COUPÉ FABRICS

Fil Coupé literally means "cut threads" in French. This weaving technique produces an interesting fringe efect

on the surface of the fabric.

Extra weft yarns are foated between motifs and will be latter cut of. If we apply long foat correction to these

wefts, the foated yarns will be connected to the ground fabric and this would prevent cutting of the threads

from woven fabric. So we have to tell  the program, that this is a fl coupe fabric, and that these long foats

between motifs shouldn’t be tied to the ground fabric. How to do this? Open Fabric > Simulation and tick the

Fil coupe checkbox. Set the Coupe length. The foats which are longer than the Coupe length number will not

be corrected.

Figure 70: Setting the coupe length; wefts foats,
foating over 70 warp threads will not be corrected.  

5.9 DRAFTING

The drafting determines which shaft controls which warp threads, and the number of shafts used depends on

the complexity of the weave.

To repeat, what is said in the Chapter’s introduction, in  ArahWeave there are two ways of drawing drafting

pointse

• Left  mouse button click draws a draft  point  and copies corresponding “shaft  points”  from the card into

weave.

• Middle mouse button click draws a draft point and copies corresponding “warp points” from the weave into

card.

• You can access to the drafting functions through the Dobby menu of the Weave editor.
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5.9.1 OPTIMIZING THE NUMBER OF SHAFTS

After you have drawn a weave, the fastest way to draw a draft is using  Change > Optimize the number of

shafts > Left (or Right). Left means that the program starts to draw shafts from left, right means that it starts

to draw from the right side of the weave.

If  you  intend  to  save  the  weave  with  the  least  possible  number  of  shafts,  then  you  don’t  need  to  apply

Optimize  the  number  of  shafts—program  does  it  automatically  prior  saving,  if  there  is  no  draft  in  the

weaving plan.

5.9.2 HEAVY SHAFTS FIRST (DOBBY)

This function is available from Dobby > Check weave menu. It puts the heavy shafts to frst shafts. In this way,

the  selvedge  shafts,  if  entered  in  the  design  manually,  will  appear  last,  as  usual.  On  normal  weave

optimization, they would appear frst, since they are at the left edge.

5.9.3 LOADING AND SAVING DRAFTS

You can save or load any draft from the File menu in the Edit weave window. It is useful, when you want to

apply a complex draft from one weave to another.

5.9.4 REDUCE SHAFT JUMPS (DOBBY)

This function is available from  Dobby >Check  weave menu. It will  try  to rearrange the order of shafts, to

reduce the longest jumps (for example from frst to last shaft) without changing the design.

5.9.5 BALANCING THE WEIGHT OF SHAFTS

In practice it is sometimes better to use more shafts than the least possible number, mainly because of the

high number of warp threads.

Figure  71 shows  weave  with  6-shaft  draft.  The  information  in  the  Consumption window  (Fabric  >

Consumption) tells us that frst two shafts carry 1600 threads each. We think that this is too many, so we have

to divide threads from frst two shafts to two additional shafts. Choose Check weave > Balance the weight of

shafts. Change Desired number of shafts to 8. The program draws new draft, and calculates new number of

heddles per shaft.

Figure 71: Changing from 6 shaft draft to 8 shaft draft

5.9.6 POINTED DRAFTING

If your weave will  be vertically mirrored, you can draw just half of the weave and apply function  Drafting >

Pointed > Add from the Dobby menu. ArahWeave automatically expands and mirrors the weave in horizontal

direction. The program will also draw the drafting, while the number of shafts remains unchanged. Note that

frst and last warps are not mirrored, to avoid two adjacent warps with equal weave. If the width of your weave
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is  10  prior to calling this  function,  it  will  become 18.  If you change your mind, click  Drafting > Pointed >

Remove.

Figure 72: Before and after applying Add pointed drafting

 

This function is located in the  Dobby menu, but can be of great use in a jacquard. To overcome the limited

number of jacquard hooks, weavers will often use pointed harness arrangement, to efectively double the size

the weave. To produce such a fabric, only half of the weave is necessary, and it is a good practice to draw only

half of the color image, to reduce its size. But if we want to make a simulation of the fabric, we would like to

see it mirrored in repeat, as it will be really woven. Using this function, it is a snap to switch between the two

view modes for such fabrics.

5.9.7 DIVIDED DRAFT (DOBBY)

Automatic  step  2,3,4,5  drafting  is  available  from  the  Dobby  >  Drafting  >  Step menu.  Step  2  would  be

normally called divided draft, and step 3 or 4 would be satin draft, depending on the size of the weave.

5.9.8 REDUCING THE NUMBER OF SHAFTS (DOBBY)

If the number of shafts in the particular draft

exceeds the number of shafts on your loom,

you  have  one  more  possibility—you  can

make a small change in the weave, which will

enable further reduction of number of shafts.

First  you  should  optimize  the  number  of

shafts,  and  then  choose  Dobby  >  Check

weave  >  Suggest  shaft  merge.  Program

fnds  the  two  shafts  that  are  the  most

similar,  and  draws  a  red  rectangle  around

these two shafts, and indicates the points of

diference in the weave. If the changes which

are necessary, to make the two shafts equal,

are acceptable for you, just  click them, and

optimize  the number of shafts again.  If you

have reached the desired number of shafts,

you  have  solved  the  problem,  otherwise

repeat these two steps.

Figure 73: Suggestion to merge two shafts
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5.9.9 NUMERIC DRAFTING

Choose  Dobby  >  Numeric  drafting to  enter

drafting as a numbers, and after pressing the OK

button, the program draws drafting as you wrote

it.  The  weave  in  Figure  74 has  eight  repeats  of

shafts 1, 2, 3, 4, then fve repeats of shafts 5, 6, 7,

8 and again six repeats of shafts 1, 2, 3, 4.

Figure 74: Numeric drafting

5.10 DENTING

Both the wires and the slots in the reed are known as dents (namely, teeth). The warp threads pass through

the  dents  after  going  through  the  heddles  and  before  becoming  woven  cloth.  The  number  of  dents  per

centimeter or inch determines the fneness of the reed. The number of warp threads that go through each dent

depends on the warp. Usually there is same number of threads in each dent, and denting is simply written 2 or

3 or 4 or 5..., where number means the number of threads per dent. 

There are some types of fabrics, however, which require an irregular order of denting to emphasize certain

design feature. Irregular means that the number of threads in each dent is not constant for a whole warp. In

such cases the order of arrangement of the ends in the reed becomes an essential part of the design and must

be indicated carefully and in the correct relationship in respect of the weave and the draft.

To determine the denting data, enter them either in the Denting (dents/cm) feld of the Weave Editor (Weave

> Edit), or in the feld of same name, located in the Calculation of the thread consumption window (Fabric >

Consumption). You can use parenthesis in the denting pattern likee 2 2 10(3) which will expand toe 2 2 3 3 3 3 3 3

3 3 3 3. You can have several diferent dents within repeat section, like 2 2 7(1 2 3). ArahWeave supports up to

125 threads in one dent.

Figure 75: Entering denting in the Calculation of thread consumption window or in the Edit weave window

5.10.1 EMPTY DENTS

To mark an empty dent enter 0 in the denting pattern. A green line and a number in the Weave editor indicate

a position of empty dent(s) (see Figure 76). Important note: a fabric in ArahWeave cannot start on empty

dent.
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Figure 76: Empty dents in the denting pattern

A weave with empty dents in the denting pattern looks slightly diferent on a printout as it does in the Weave

editor. Empty space in the weave area and dents in a green color indicate empty dents (Figure 77).

Figure 77: Printout of a weave with empty dents

 

To get a proper fabric simulation of fabric with empty dents, you need to set technical data (Threads in fabric

width,  Reed  width,  Finished  width,  Denting,  Weft  density)  in  the  Calculation  of  thread  consumption

window  (Fabric  >  Consumption),  and  mark  the  Density  from  technical  data check  box.  For  detailed

explanation about Consumption and setting the technical data see Chapter 14.

Figure 78: Simulation of fabric with empty dents 

Denting and regulator are handled in a diferent way in weave editor, in spite of the fact that they can be both

entered in the  Edit weave window in the same way. The reason is, that a regulator is directly linked to the

weave, since it must be present on the dobby (or jacquard) card or machine fle.

The denting, on the other hand, is not directly linked to the weave. Its repeat can be longer, as demonstrated

in Figure 79, where weave repeat is 8 threads and the denting repeat is 50 threads in 30 dents.
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Figure 79: Fabric with denting
 

5.10.2 DRAWING DENTING WITH A MOUSE

You can draw denting with mouse in the Edit weave window. As you draw, the denting in the Denting feld is

automatically rewritten.

To add a thread in a dent, click on the dent with the left mouse button, to reduce number of threads in the dent

click on it with the right mouse button (Figure 80).

Figure 80: Adding or deleting threads from dent: left click on a dent adds one thread in it (center image),
right click takes out one thread (right image)

 

To add a dent (actually duplicate existing one) in a denting pattern, left click below it with the left button. To

remove a dent from denting, right click below it (Figure 81).

Figure 81: Adding or deleting dents: left click below dent (red area) duplicates dent (center image), right
click deletes dent (right image)

 

5.10.3 MATCHING DENTING TO NUMBER OF WARP THREADS

Click the scissor icon   on the right  side of the feld,  if  the number of threads in  the fabric  width is  not

divisible by denting. Examplee let's say that there are 1400 threads in the fabric width, and the denting is set to

3. Because 1400 is not divisible by 3, by pressing  program matches the denting to number of warp threads.

New denting is written as 466(3) 2, which means 446 threads by 3 is 1398, plus 2 threads in the last dent.
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Figure 82: Matching the denting pattern with number of threads in fabric width  

5.10.4 DOBBY AND JACQUARD

Some looms have both lifting mechanisms, dobby and jacquard. Dobby threads pass through heddles, which

are hold and lifted by shafts, Jacquard part of warp ends are lifted by hooks. To distinguish between threads,

which are lifted by dobby (shafts), and threads, lifted by jacquard (hooks), mark the dents, where the jacquard

warp ends are, with negative number. “Jacquard dents” are indicated by gray color in the Weave editor (see

Figure 78).

Figure 83: "Dobby" and "Jacquard" dents
 

5.11 REGULATOR

Looms advance (take-up) the fabric after each weft insertion. Sometimes we need to stop automatic advance

on certain wefts, so that two or more weft threads can be inserted during one advance. When we do this, we

use regulator. Regulator is also called “dead pick” in USA. It makes sense, since on weft with regulator on, the

fabric does not advance. In England, it is sometimes called cramming, since we cram two or more threads in

the same space.

In ArahWeave, regulator has the same format of entry as denting. If you do not use regulator, just leave it at 1,

or even empty. You can use parenthesis in the regulator likee 2 2 10(3) which will expand toe 2 2 3 3 3 3 3 3 3 3 3 3.

In the regulator we don’t use 0 for marking weaving without weft (fringe). Instead we use y in the weft pattern.

The weave is extended on the y. Fabric cannot start with active regulator on the frst weft thread . Maximal

number consecutive wefts with regulator active is 125 (that is 1 normal thread plus 124 crammed, or in other

words, 1 advance of warp beam and 124 wefts without advance).

Denting and regulator are handled in diferent way in spite of the fact that they can be both entered in the Edit

weave window in the same way. The reason is, that a regulator is directly linked to the weave, since it must be

present on the card.

The repeat size of the regulator should not be bigger than the weave heihgt; if it is longer than weave

height,  then the weave  height  must  be enlarged accordingly . The program gives you a warning if  your

regulator pattern does not divide the height of the weave – it draws the regulator feld in red. If it divides, the

regulator feld is green. Figure 84 shows weave, which has 24 weft threads repeat, but regulator repeat is 22
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threads (sixteen plus six (16(1) 3(2)). The sizes are not

the  same,  so  the  regulator  feld  is  displayed  in  red

color.

5.11.1 DRAWING REGULATOR WITH A MOUSE

You can also draw regulator with mouse in the regulator

column in the weave editor (see Figure  85). Every time

you  draw  a  point  in  regulator,  the  program  writes  the

regulator pattern for the full height of the weave. If you

have written the regulator pattern which does not divide

the height of the weave, just draw one point of regulator

in  the  weave,  and then  delete  it  again.  This  will  make

your regulator same height as your weave.

5.12 THE TOOLS MENU

In  the  Tools menu  you  can  fnd advanced weave  editing functions,  which can  be used  both on dobby or

jacquard fabrics.

5.12.1 EDITING DECOMPOSED

5.12.1.1 BASICS

ArahWeave has a special function for constructing multiple layer (double) weaves; you specify basic weave for

each warp against each weft and the program automatically constructs the composite weave. This function is

available as a special pop-up window on in the weave editor. To open it, choose Tools > Edit decomposed.

In the Edit decomposed window you have to specify the number of warps (Warp layout), and number of wefts

(Weft layout). Default mode for both Warp and weft layout is the Custom mode, where you simply enter the

number of warp and weft layers. The weave area is split into “weave table”, where the number of columns is

number of warps, and the number of rows is number of wefts. The table on the right side of the tool bar is just

smaller presentation of the “weave table”, and serves as a tool for selecting and copying weaves (very useful

when the weave is bigger than screen size), and also indicates with red color, which weave is selected. Tools in

the  tool  bar  works  on  the  selected  weave.  Same  as  in  Weave  editor  you  can  load  weaves  to  the  Edit

decomposed windowe choose File > Browse, double click on the weave, you want to use, and it will load into

selected area. To copy a weave into another area, select it with the left button, and click with the right button

in the area, where you want to copy it.

Figure 84: Repeat size of regulator is diferent than size
of weave - red feld warning

Figure  85: Regulator column
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Figure 86 shows a weave with fve warps

and  three  wefts.  Selected  weave  is  a

combination of frst warp and frst weft.

Figure 87 shows a weave with 1 warp and

3 wefts,  with 5-satin  on top and 5-satin

on  back  for  attachment  of  the  second

weft,  and  10-satin  for  attachment  of

third weft.

5.12.1.2 ADVANCED WARP AND WEFT LAYOUTS

Custom

You can edit even more complicated composed weaves, for instance those with diferent densities of top and

bottom fabrics. Figure 88 shows a special double fabric with uneven top and bottom density, plus an extra weft

which is hidden in the middle and just  links the two fabrics together.  The warp layout is  simplee  112 - this

means that frst two warp ends go in frst block, and third warp end goes into second block. In this way we have

two times higher density in warp. Weft is similar, just that we need to repeat the layout until the end, so we

can  add the  third  block for extra  hidden threade  1121121121121121121121123;  can  also  be written  as

8(2a1b)1c.

We enter elongated twill for the top fabric, and regular 2/2 twill for back fabric. The middle weft thread (shown

in red) has just two points which link it to the top and to the bottom fabric. Note that the fabric simulation in

the lower left angle does not show any threads from the back (gray) or middle (red), since they are completely

covered by the top fabric (black weft and dark blue warp).

Figure 86: Edit decomposed window

Figure 87: Edit decomposed window and the resulting weave in the
Weave editor
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Figure 88: Edit decomposed - diferent density in layers

 

Warp layout as a denting; weft layout as a regulator

Sometimes you want to change (or simply check) extra warp weave, extra weft weave or the ground weave.

The task can be difcult since the extra weave is discontinued by ground weave (and vice verse). But if you

choose  Denting instead of  Custom in the  Warp layout (or  Regulator in the  Weft layout feld) the program

divides weave on the ground weave and extra threads weave.

Layout as a Thread pattern

In many fabrics the warp and weft layout is equal to thread pattern. If this is your

case instead of typing custom layout, just select Yarns from drop down menu.

Using more than 9 blocks in weave construction

In decomposed weave editor, some advanced users want to work with more than 9 weave blocks. This is not

possible if you are using numbers 1-9 as a layer indication.

But there are two ways to enter more than nine layerse

• Using the layout by yarns, instead of custom. Then, you can use more than 9 yarns and in this way you

achieve more than 9 weave blocks

• Writing the custom layout as a pattern (for example  2a2b2c), instead of with numbers (112233). If you

use the pattern, you can again use more than 9 letters and thus get a bigger layout.

5.12.1.3 RESIZE TO DIVISIBLE

If you make the combinations of weaves, which have diferent repeat size, and you use diferent densities in

layers, it is quite complicated to calculate the correct repeat size of the composed weave. Function Resize to

divisible in Tools menu calculates correct weave. Figure 90 shows a double weave with twill on face and plain

weave on back. For two threads on the face there is only one on the back (layout is  112). Set the size of the

fnal weave to 12 by 12, to be sure that we have enough space for twill and plain weave. Then draw or load the

weaves into decomposed weave  editor.  The area  for twill  weave is  8 by 8 pointse  this  is  obviously  wrong,

because the repeat size of twill is 3 by 3, and 8 is not divisible by 3.

Figure 89: Layout as a thread
pattern
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Figure 90: Editing compound weave with twill on face and plain weave on back:
notice the mistake in weave repeat in background

 

At this point choose  Tools > Resize to divisible. Program resizes and extends the weave automatically. We

get new total repeat size 18 by 18 points; selected twill area is now 12 by 12 points. If smaller repeat would be

adequate, the program would also shrink the weave.

Figure 91: Same weave as above, but now it is divisible; the weave in the
background is now correct

 

5.12.1.4 EXTENDING WEAVES WITH CTRL+LEFT CLICK (OR MIDDLE MOUSE BUTTON CLICK)

In decomposed weave editor, you cannot select and copy area with middle mouse button (or Shift+left click)

like in the main weave editor. But there is a function on a middle mouse button (or Ctrl+left click), which helps

you copy (extend) the weave across the whole sub-section. Just draw one repeat of the weave, and click with

middle mouse button (or Ctrl+left click) on the upper right point of the drawn weave repeat, and this repeat

will be copied across the whole weave sub-section in decomposed weave editor.

Figures from 92 to 94 show how to draw a combination of satin-16 and twill-4, one warp and two wefts. Since

the satin repeat is 16x16, and twill is 4x4, the composed size is 16x32. Set the size in weave editor to 16 by 32,

open the Edit decomposed editor, set the  Weft layout to 2 (or if you have two colors in weft you can select

Yarns as a type of Weft layout). Draw the twill repeat in upper section, and just one point in the lower section.

Press Ctrl and click with the left mouse button in the left upper point of the area, that you want to copy across

section.
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Figure 92: Extending weaves wit middle mouse button click (or Ctrl+left click)

 

Now you need to press  icon three times to tilt each point of the straight line for one point to the left to get

satin 16 weave.

Figure 93: Extended weaves

 

Figure 94 shows compound weave with satin on the face, and twill on the back of the fabric.

Figure 94: Final weave
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5.12.2 SELECT/COPY AREA

Often we want to limit  the area of the operation to a specifc part  of the weave. By selecting a particular

rectangular region, you set the boundaries of the operation. You can also save a selection as a weave, just use

File > Save weave, and the saved weave will be the selection, and not the whole weave. It is very useful, when

you want to get all the weaves from a complex Jacquard weave.

You can make selection in a two diferent wayse

• Press Shift+left mouse button (or only the middle mouse button) and move the mouse until the desired 

area is selected. As you drag a mouse, a grid color is changing to red

Figure 95: Selecting with mouse  

• Choose Tools > Select/copy area. In the Select/copy area window enter the starting and ending points of

the selections. Instead of ending points you can set Size.

The grid of selected area is drawn in red. All tool operations work now only on a selected area.

Figure 96: Weave selection

 

You can copy and multiply this selection again in two diferent wayse

• Press left mouse button and drag it to draw the repeated area. The mouse pointer turns color to red, if you

have a selection.

• In the Copy to part of the Select/copy window enter the coordinates of the starting point (From, To) and

the size of the area, where you want to copy the selection

If you want that the copied area has the same weave ofset as the selection, mark the Copy in repeat toggle

button in the Edit menu. The program copies the selected weave with ofset from bottom left of the jacquard

weave, not from the selected weave area. In this way, weave will start correctly.

To disable selection, click with middle button somewhere in the weave area, or click the deselect icon ( ) in

the Weave editor toolbar. The icon changes color to black.

Please check httpe//www.arahne.si/tutorial16.html

This page contains animations, which show the advanced functions of weave editor.

Copy area operations in weave editor, and editing in decomposed weave editor on dobby weave will leave drafting

intact and will modify dobby card. This is important for users who want to design new weaves on a fxed drafting
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(so you can tie-up to the same warp). So if you don’t want this efect, delete drafting by Dobby > Drafting > Clear

drafting.

5.12.2.1 LOADING A WEAVE (PART OF WEAVE) INTO SELECTION

You can load any weave into a selection, using the weave browser or the Load weave dialog.

If the selected area  is  bigger than the repeat  of a loaded weave, then the weave is  repeated until  it  flls  a

selection.

If the weave, which you want to load into selection, is bigger than selection, then ArahWeave takes just part of

the weave big enough to fll a selection.

The Offset option in the Select/Copy area window enables you to set the starting point of area in the weave,

which you want to load into selection. It is mostly useful, when you copy a part of jacquard weave into another

jacquard weave.

Figure 97 shows two jacquard weaves. We want to copy the logo and numbers from one weave to another.

Figure 97: We want to copy the logo and numbers from one weave to another

Make a selection in the frst weave. Set the ofset parametere logo starts on point 1056 (warp), 6 (weft). Load

the second weave from weave browser. Logo is placed exactly into selection in the frst weave (Figure 98).

Figure 98: Setting the ofset option; weave after copying another weave into selection

5.12.2.2 WEAVE PEN

Weave pen function enables freehand drawing with selection across the weave editor. To use it you must have

a selection in the weave; then click with right mouse button and drag a mouse. The program will draw with

selection under mouse pointer. The size of drawing area is 3 by 3 points.  If you keep the Shift  key pressed

during drawing, the size of drawing area is 5 by 5 points.

5.12.2.3 FINDING REPEAT IN SELECTION

The function is very useful, when you want to get the single weaves from complex Jacquard weaves.

First  make  a  selection,  which covers  the  area  of  only  one  weave.  Then  choose  Change  > Find repeat  in

selection. The program reduces the size of selection to one repeat of weave.
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Figure 99: Selection, and fnding a repeat in selection

 

To save a selection as a weave, just use File > Save weave, and the saved weave will be the selection, and not 

the whole weave.

5.12.2.4 REPLACING WEAVE (JACQUARD)

Replace weave enables you to replace a single weave in a fnished jacquard card design, or reconstruct the

original  color image (which we obviously don't have anymore) from a jacquard card. This function is mainly

intended for jacquard mills with old designs in jacquard formats, which they would like to modify and re-use, to

create new designs with diferent weaves inserted.

First, draw a selection in the weave using middle mouse button (or use parametric mode Tools > Select/copy

area), which you want to replace. Selection must include at least one complete weave repeat. Then choose

Jacquard > Replace selected weave.

The program will  try to fnd all  areas,  which are covered by the selected weave, and mark it  with magenta

color. If the resulting mask includes undesired weave areas, modify the Thin parameters. If the resulting mask

does  not  include  all  the  weave  areas,  modify  the  Grow parameters.  Times means  the  number  of  times

thinning or growing is repeated. Neighbors means the minimum number of neighboring points (maximum is

8), which should be the equal to the selected weave for the operation to take place. You can use left mouse

button  (adding  points  to  masked  area)  and  right  mouse  buttons  (deleting  points  from  masked  area)  for

drawing the masked area, if the parametric guessing does not give the desired results.

Figure 100: Selection and masked area
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The masked area is also indicated in the main window (the view mode should be set to Integer).

Figure 101: The masked area in the main window

Then simply load a diferent weave into the masked area (File > Load weave).

Figure 102: Load a diferent weave into the masked area

In some cases program fnds portions of the selected weave in the areas, where you do not want it. Figure 103

shows a sample, where program masks additional area to selected plain weave. To prevent this, apply the Thin

parameter, and increase the Neighbors parameter, and click the OK button. Program recalculates the masked

area.

Figure 103: Explanation of the Thin parameter

The meaning of the function  Get image from weave, accessible from the Replaced selected weave window is

described in the Jacquard conversion chapter (9.12.3). You do not need it for simple weave replacement.
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5.12.3 INSERTING AND DELETING WARPS OR WEFTS IN WEAVE

You can insert a warp thread or weft thread at any point of the weave. You can do it in two diferent wayse

• Left mouse click on the gray area to the left or below the weave (in Figure 49e weave control row, weave

control column) duplicates (add identical) weave thread at the selected point, and right mouse click deletes

it. To add empty space in the weave area, press Shift while inserting the warp/weft with mouse, and added

area will be empty. Weave, card and drafting are shifted and resized accordingly. It is also possible to add /

remove shafts in the same way - just click on the gray area below the shaft. These functions can also be used

to fast weave resize without opening the Dimensions window. There is a slight diference in the functioning

of the two resize wayse normal resizing will not change anything in the weave, so it is easy to go back to

previous value. But if you delete many warps / wefts, it will not be possible to get them back, because weave

is shifted / copied all the time. Notee Regulator and denting are not changed with this function.

• Choose Tools > Insert/delete warps/wefts. The window in Figure 104 pops up. You have to choose mode

(insert or delete) and directions (warp or weft). Then enter position of inserting/deleting in the From feld

and number of inserted/deleted threads in the  Size feld. Program will draw magenta line to indicate the

starting point of insertion. Note that area is always inserted to the right or above that line. Similarly, if you

are deleting warps/wefts, the area selected for erasure will be crossed out in magenta lines.

When you click on the  OK button,  ArahWeave turns the inserted area into a selection, so you can load a

weave into it.

Figure 104: Insert warps/wefts: set From and Size, then click on the OK

 

5.12.3.1 INSERTING WARPS OR WEFTS BOTH IN WEAVE AND THREAD PATTERN

If the warp / weft pattern toggle button in the Insert/delete warps/wefts window is on, then the program will

also insert  the thread pattern,  which you write  in the feld on the right of toggle button, into main thread

pattern. Figure  105 shows example, where we insert four threads in the weave, and the pattern of inserted

threads is 1a1b (one orange thread, one blue thread).
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Figure 105: Inserting warp in weave and thread pattern simultaneously

 

5.12.3.2 INSERTING WARP THREADS BOTH IN WEAVE AND IN THREAD PATTERN WITH MOUSE

This feature helps you add extra warp. Warp pattern repeat and denting should have same length as weave

size in warp direction. If the weave is 84 points wide, and you have alternating one thread color A, one thread

color B,  you should write pattern as  42(1a1b). Same is with dentinge if you have 2 threads per dent, you

should write denting as 42(2).

Select a yarn, that you want to insert, in the Edit warp and weft pattern window. Hold down the Shift key,

while you draw the warp pattern with mouse in thread pattern. The program will add an empty space in the

weave area to the right of the clicked area, and insert the currently selected warp thread, and increase the

number of threads in dent, all at once, with single click. So it is very easy to add threads to the ground fabric.

New threads are added to the right, so that the ground threads stay at the beginning of the dent. This may be

handy, if you will  later divide the warp pattern or the weave according to the number of thread in dent. To

delete a thread in this coordinated way, you can also press shift and right mouse button. But it will delete the

thread to which you will click, not the one to the right.

Figure 106: Inserting warp in weave and thread pattern simultaneously with mouse

5.12.3.3 REPEATING PART OF THE WEAVE

You can repeat a part of the weave. Mark the Repeat button, and select part of the weave, which you want to

repeat by setting From and Size number. Program draws two lines to show the area which will be repeated. If
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they are in green color, it means that size of the area is not divisible by denting repeat; if the size is divisible by

denting repeat lines are in magenta color. Then set the number of repeats (Times). In Figure  107, we repeat

three threads four times, so we increased the size of repeat for twelve threads.

Figure 107: Repeating part of the weave

5.12.3.4 MULTIPLYING PART OF THE WEAVE

Sometimes  you need to multiply  part  of the  weave.  In Figure  108, we choose 6 threads,  which should be

multiplied 3 times. 

Figure 108: Multiplying part of the weave

5.12.4 DELETING WARP/WEFT BY YARN

Sometimes we just have to delete some extra warp or weft threads. This can be achieved by using function

from previous chapter (Inserting/deleting warps/wefts),  but this one has simpler and cleaner user interface,

and allows faster, one-click solution. To use it, select Tools > Delete warp/weft by yarn.

Figure 109 shows the extra weft design. We want to remove a green part of design (weft thread c). In the Yarns

feld  of  the  Delete  warp/weft  by yarn  window,  enter  c  as  a  yarn,  which should  be deleted,  and  click OK.

Program removes the green yarn.

Figure 109: Deleting warp/weft by yarn
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5.12.5 GENERATING CREPE (SABLE) WEAVES

Weave editor has a tool for generating crepe (sable) weaves. To use it, in the

Edit weave window choose  Change > Make  crepe weave.  The tool works

both on selection, as on the full weave, but it has more options if it works over

a  full  weave.  The  tool  is  more  appropriate  for  jacquard,  since  it  does  not

handle shafts in any way. If it works on selection, then long foat controls are

not applied. The frst feld you must enter is Effect 1 - its values go from 1 to

254. If you are closer to 1, the resulting weave will have warp efect, if you are

closer  to  254,  it  will  be more  of weft  efect.  The value  of  128  will  make  a

balanced efect. Next is the control of Long foats, which can be disabled. You

specify the desired maximum foat for the warp and for the weft. It is difcult

to make a repeating weave which is repeating in all dimensions and respects

this. So it is more like a suggestion to the program, so most of the foats will be like that, but some will not be.

You can check this in the long foats control window, from  Change > Floats. If you do not want to do this

manually, then enable the Fix foats face and back. As program cannot satisfy the foat request 100%, it sets

the permitted foat to one point more than what you asked for. For example, if you set the foat of 3 in warp,

the program will set maximum permitted foat to 4.

The program is fully interactive, so you can use the wheel mouse and observe the efects.

The images in Figure 111 shows the two generated weaves – the only diference in the setting is the Effect 1

parameter (15 and 135).

Figure 111: Making crepe weave

5.12.5.1 SHADED CREPE WEAVE

On  the  top  of  the  Make  crepe  weave window,  you  can

enable  the  Shaded toggle  button,  which  allows  you  to

specify two values for efect. Program will make a horizontal

shade from one efect to the other.

Figure 112: Shaded crepe weave

Figure 110: Make crepe weave
dialog
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5.12.5.2 BIDIRECTIONAL SHADED CREPE WEAVE

If you turn on the Bidirectional button, the program makes

smooth transition  between  dark and light  (warp and weft

efect) areas.

Figure 113: Bidirectional shaded crepe weave

5.12.5.3 SHADED CREPE WEAVE WITH ANGLE

You  can  set  the  angle  of  the  shaded  efect  through  the

Angle option.  It  works  both  for  normal  and  bidirectional

shading.

5.12.6 USING IMAGE FOR CREATING CREPE WEAVE

You can use image as a base for crepe fabric. Both Shaded and Image check boxes should be on. Then load the

image into Jacquard conversion window (Weave > Jacquard conversion). Click the OK button, and program

creates crepe weave based on the image.

Figure 115: Using image as a base for crepe

 

Figure 114: Setting the angle of crepe shading
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5.12.7 ADDING REGULATOR OR FRINGE FUNCTION TO A THREAD

The Add to yarn Regulator/Fringe function enables you to modify a regulator pattern in a fast way. It adds a

regulator or fringe to defned weft, and automatically generates new regulator pattern, so you don't need to

draw it or write it. It is very useful if you already have regulator pattern (for instance extra weft design), and

you want to add regulator to some of the ground wefts.

To use this function, choose Tools > Add to yarn, and select either you want to use regulator or fringe. In the

Yarns feld enter the yarn, to which you want to add the regulator.

Figure 116: Adding regulator to yarn

5.13 WEAVE INFORMATION (JACQUARD)
Weave information window, available from the View menu, will display owner of the weave, when was it last

saved, and some other interesting statistics.

Lifting gives you a graphical view of how many hooks are lifted on the average. On jacquard, you would choose

to reverse the fabric and weave it  with back on top, so that  fewer hooks would be lifted on average, thus

prolonging machine life by reducing its wear and tear.

Figure 117: Weave information - lifting

Consumption will display the relative consumption of each thread according to the weavee it will count the

number of passages from back to forward for each warp thread. If the fabric will have warp threads with very

diferent consumption, the ones that consume more will begin to pull after a few meters are woven. They will

cause warp to break or errors will be formed on the fabric (so called nests), since jacquard will not be able to

pull up the hook due to high tension of the thread. In such cases, you can either use two separate warp beams,

or change the weaves, so that they will have more similar consumption, or change the design, so that it will not

contain vertical stripes of single weave.



  www.arahne.si  A r a h W e a v e  

User Guide 

  5 5

Figure 118: Weave information - Consumption

Both Lifting and Consumption display issue a warning when the values are out of bounds, but the limits are

not really strict, so it is up to you to decide, if you want to resolve the problem or you leave as it is. The warning

for lifting is above 50%, and the warning for consumption is above 30%. You can display these reports in black

and white or in color; press Shift+c to switch color display on or of.

5.14 PRINTING THE WEAVE

To print  a  weave, choose  File  > Print weave.  Figure  119

shows the  Print weave window, where you set  diferent

printing properties.

Figure 119: Print weave window

5.14.1 PRINTER SETUP

If you have not save printer settings in  Save setup, or

you want to print to diferent printer or fle, you should

select  Printer setup to change printer settings.  In this

window  (Figure  120),  you  have  to  choose  the  desired

printer or graphics fle format,  print mode and density

(in dpi - dots per inch). For higher quality printouts use

1440 dpi, but in most cases 720 dpi is sufcient.

5.14.2 PRINT SIZE

To control size and position of the printout size enter felds in the Print size area. The borders are measured

from left and top including the non-printable white space. To check the maximum printable area, press the

Full page button. If you insert an area out of range it will be trimmed and you will be warned with a beep.

Figure 120: Printer set-up
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5.14.3 GRID

Here you set the grid size (mesh). Default value is 1.5 millimeter.

5.14.4 PRINTING OPTIONS

The printing option toggle buttons are below the  Print size text felds. Simply, by marking the check box in

front of the option, you include that in the printout.

• Title; you will get extended title with date, user name, customer name (your company) and version of the

program at the top of the page.

• Denting 

• Selvedges; program prints selvedges on the left of the weave, if you have load the weave for selvedge in

the Save cards for production window.

• One repeat; program prints only the weave, even if there is space for printing more weave repeats 

• Yarns; you get the warp and weft pattern on the top and right side of the weave.

• Compress; if the weave consists of many repeating elements, you can use this function to reduce printout

size.

Figure 121: The same weave in "normal", and compressed mode

• Card; normally, you want to print the dobby card, but if you don't, there is the option to skip it.

• 123;  Program  will  print  the  number  of  shaft

instead of black square in the drafting pattern,

and in the dobby card. Mesh size should be at

least  3,  so  there  will  be enough space  for the

number to be readable.

5.14.5 PRINT PREVIEW

When the settings are correct, check the  Print

preview. It displays weave exactly as it will  be

placed on a paper (left and top ofset). If every

thing  is  on  proper  place,  close  print  preview,

and click OK.

5.15 EXTRACTING THE WEAVE FROM CARDS

ArahWeave enables you to adapt / change / correct old designs prepared for weaving. Load a card into Weave

Editor  (if  you are  loading a  card from  foppy, choose  Weave  > Read Jacquard  foppy,  and wait  until  the

program reads the foppy, and then load the desired fle.) To work within the logic of  ArahWeave, you must

extract only the weave information, deleting the felds for empty hooks, selvedges, control information, etc.

Figure 122: Weave draft marked with numbers

Figure 123: Print preview of the weave; compress option is on
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Once you have only the weave, you can correct the long foats, if any, and save the jacquard fle in a diferent

format or layout. The following paragraphs explain the functions needed to extract this information.

In the Jacquard menu of weave editor you can fnd function for guessing the regulator from specifed weave

point, and for guessing weft change from specifed weave point and length of weave area that presumably

contains this information. For example, you have the complete jacquard card or dobby card with all  control

information. To make a weave out of it, you will have to cut of the control information, but we can also use it

before that  phase. In weave editor in the Jacquard menu, select  Guess weft change  or  Guess  regulator,

move the mouse in the  Edit weave window to read the number of hook of weave point, which contains the

information,  and type in  this number.  Click on the  OK button, and program  will  try  to make sense of this

information. Obviously, it will lose the previous weft change or regulator. Regulator cannot start with active

regulator  (black point)  on frst  weft.  If  it  does,  it  is  probably  not  regulator.  If you  insist,  move  the  weave

vertically until it starts with white point. You cannot have more than 8 consecutive black points (regulator on).

For weft change, the program will  try to fgure out if you have binary weft change or normal weft change.

Normal weft change can be up to 25 weave points wide, and it will have exactly one black point on every weft.

Binary weft change can contain anything, and can be up to 5 points wide (2 to the power of 5 is 32). Program

will use only up to 25 diferent wefts, since this is the current limit in ArahWeave.

The  Jacquard menu of weave editor also contains function  Remove selvedges and  Remove extra warps /

wefts.  The frst  function removes selvedges -  tries  to fnd out if  there is  a  complete  vertical  repeat  in  the

weave, identifes it as selvedge, and removes it. It will search for repeats with length of up to 40 points. The

second function is useful for removing empty spaces (areas of complete foat in either warp or weft).  Both

these functions are useful for getting only the weave out of a jacquard design prepared for weaving.

If there are some warps that cannot be removed automatically with the above functions, you can remove them

manually by deleting theme right mouse button in the weave on the gray area below the warp selected for

removal.

6 YARNS

To edit yarns, choose Fabric > Yarns.

On top of the Yarns window, you will see warp (A...Y) and weft (a...y) colors. To edit a particular yarn, click to

the desired entry. The selected yarn color and code will be displayed below. The most important property of

yarn is its Count, and it can be entered in any of the units selected in unit toggle button area. The yarn count

will  govern the diameter of the yarn in fabric simulation, according to the formula that involves  Dimension

factore

Diameter=
√count tex

Dimension Factor
The default dimension factor is 18.0.  Diferent factors are suggested for diferent yarn types (carded cotton

18.7, combed cotton 22.5, combed wool 25.3, wool 16.7, linen 27.1, etc.), but there are many more variables

comprised in this dimension factor than just raw material type. It is better to measure the diameter of yarn in

laboratory, and then try changing the dimension factor until you get the measured diameter for the measured

yarn count.
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Figure 124: Yarn editor

 

When  you  enter  a  diferent  yarn  count  or  dimension  factor  and  press  Enter,  you  will  see  the  changed

theoretical yarn diameter at the bottom of the window. This diameter is the basis for fabric simulation in the

Simulation view.

The yarn editor also permits you to do automatic yarn unit conversion. You simply click the desired unit, and all

the values will be converted to this unit. Internally, the program will save units in Nm, so it may happen that

you will get some conversion rounding error, the next time you load the fabric. Supported yarn count units aree

• Tex The ISO standard

• Nm Metric

• NeC Cotton (English)

• NeW Worsted

• Np Woolen (Prato)

• Ny Woolen (Yorkshire)

• NeL Linen

• NeS Silk

• Td International Denier

• Run American woolen unit

• dTex equals 0,1 tex

• YPP yards per pound

Luster determines  luminosity  value  of contrast  between  the  light  shading and dark shading color  in  yarn

simulation.  Default  value  is  10.  You  can vary  this  value  from 0 to 30,  where  higher  value  means stronger

shading efect. Figure 125 shows same yarn at three diferent luster settings. Yarn images are taken from yarn

preview part of the Yarns window; preview works only in the Simulation view of fabric.
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Figure 125: Same yarn color at Luster 5, Luster 10, and Luster 20

 

The  Name parameter  represents  the  code  of  the  yarn  according  to  weaving  mill’s  or  producer’s  naming

scheme.  The  Price means  cost  of  1  kg  of  yarn  in  some  currency.  The  currency  is  set  in  the  ArahWeave

confguration fle (Help > Save setup).

Twist contraction is inserted as %, and it increases the weight of yarn and yarn diameter by given percentage.

Twist sense has S (left) or Z (right) directions, or you can set the number of twist to 0, if you do not want the

simulation of twist (Figure 126).

Twists per meter determines yarn twist angle.

Figure 126: Yarn with twist sense S, Z, and without twist

 

The parameter  Variation % (the upper right  corner of the  Yarns

window)  permits  you  to  introduce  variation  in  yarn  diameter,  to

make it look more fabric-like. Use 10 to 20% for wool-like fabrics,

and less (default 0) for more regular yarns. Up to +-50% variation is

possible. The yarn variation is random within given limits, but it one

particular yarn will have only one diameter, unlike real yarns, which

will  change diameter  after for example  50 cm, depending on the

yarn properties. 

Figure 127: Variation set to 15%

If you use semitransparent yarns, you can adjust the level of Transparency from 0 to 9, where 9 means that

90% of pixels in yarn are transparent.

6.1 YARN COMPOSITION

You can set the fber composition for every yarn. First enter number of Components, then enter relative part

of every fber, and its  Code. If you don’t remember correct code, choose Help in the  Yarns window, and you

can  fnd  code  in  the  Help window  (Figure  128).  You  can  customize  the  code  table  by  editing

/common/fbre.codes  fle.  ArahWeave will  calculate  the  fabric  composition  in  the  Consumption window

(Figure 130), if you set composition for every yarn in the fabric.
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Figure 128: Fiber codes

6.2 YARN MODEL

You  can  choose  type  of  yarn  from  the  Model option  menu  (Figure  131).

Simple is default model. It means regular, solid color yarn. Other models are

Mouliné, Mélange, Multicolor, and Custom.

Figure 131: Yarn model menu

6.2.1 COMPLEX YARNS (MOULINÉ, MÉLANGE, MULTICOLOR)

When you choose  one of the  complex  yarns  (mouline,  melange,  multicolor),  the  number of colors  in  yarn

change to two. You can change it to have up to six component colors.

The right part of yarn color display window contains the yarn sub-colors. Click

the color to select it. In the Edit color window, you can then copy, exchange

or modify colors as you do if you have a single color yarn. In the Integer view,

only the frst yarn color is used to simulate the whole yarn. In the Simulation

view, the yarn is correctly simulated with all the components. For each yarn

color, you can enter the relative size of a component yarn in the fnal yarn.

Yarn color values are relative to total of all  yarn colors. As you enter them,

and  press  Enter,  the  computer  will  automatically  recalculate  the  relative

percentage of each yarn color. You can also enter values as %, if you like, but

since values are relative, there is no checking to make sum of all colors 100%.

The Correlation parameter (Figure 133) is used for mouline and melange yarns. As you increase the correlation

parameter from 0 to 8, the program will introduce stronger and longer variations in relative sizes of the two (or

more)  mouline  yarns.  If  correlation  is  0  (default),  then  each point  is  random  within  given  proportions,  as

before. But if you increase the value of correlation, the melange will look as it was not mixed very well. You can

set the intensity according to your pleasure up to maximum of 8.

Figure 133: Melange yarn at Correlation 0, 3, and 8

 

Figure 132: Setting the number
of colors in yarn

Figure 130: Fabric
composition, calculated from

yarn composition

Figure 129: Composition
entry
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Multicolor model simulates a yarn composed of diferent stripes of a single color. They appear as “random”

color stripes, while the probability of their appearance is controlled by the value you enter for each color. Use

the Length feld to control the length of color segments. To create a smooth transition between colors, set the

Smooth option.  It  can  be  any  value  from  0  (no  transition)  to  30  (highest  dither).  Figure  134 shows  the

multicolor yarn.

Figure 134: Multicolor yarn without smooth (top), and with the smooth option set to 15

 

When you have just one color per yarn, the boxes and arrows for entering relative size of component color are

unmapped, they appear as you increase the number of colors. The yarn Model buttons are also not mapped on

single color yarns.

Chenille yarnse for each yarn, you can specify the hair length and hair probability. Hair length is expressed as

tenth of yarn diameter. So length of 10 means a hair as long as yarn diameter. Maximum hair length is 50, that

is 5 times the yarn width. The hairs will go in all directions randomly with equal probability. 16 directions are

supported. You must also specify hair probability. Maximum probability is 20. You can use any value between

0 and 20 (inclusive) for your desired efect. The nice thing about simulation of chenille yarns is that you can use

it on all yarn types supported within ArahWeavee single color, mouline, melange, multicolor, and drawn yarns.

Chenille is fundamentally diferent from other yarns, since its hair will cover other yarns close to it, in spite of

the fact that those other yarns would be on the top according to the weave. For this reason, it is not possible to

simulate chenille simply by increasing yarn count (thickness). It is also good to know that chenille yarns are

very open, so the yarn count with respect to diameter as calculated by default dimension factor of 18.0 will

probably not be correct. You will need to adjust it to higher or lower value.

6.2.2 MAKING CHENILLE YARN 

Some yarns, especially chenille types, appear like they are made from many light shades of one color. If you

want to make a realistic looking chenille yarn, you have to make a multicolor yarn with sections of diferent,

but similar color. There is a function in the Yarns editor, which helps you to create this type of yarn in a quick

way.

First, choose a color for yarn in the  Edit colors window. In the  Yarns window choose Multicolor as a type of

yarn, select number of shades in yarn (up to six), and choose Tools > Make yarn color shades. You can also

increase the  Length and Smoothen parameters. In the  Make color shades window you set the Luminosity

parameter, which determines the  L (luminosity) diferences between color shades. If you have 5 colors, and

luminosity diference should be -+5, the program will keep the base color, and then make a diferent variation

of it which will be +5, -5, +10, -10 as Luminosity in Lab values. Usually 3-5 gives good result.
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Figure 135: Making yarn color shades for chenille  

6.2.3 CUSTOM—DRAW YARN

You can draw your own yarns using paint tools. The initial yarn will always be based on the previously selected

yarn. So if you want to save some time, it is a good idea to set all the yarn parameters (count) for the yarn

which is most similar to the yarn you want to draw (like for example, melange), and then switch to the Custom

yarn model.  Then increase  number of colors (if  you want  to have more than one),  click on the  Draw yarn

button, and the Draw yarn window pops up (Figure 136).

Figure 136: The Draw yarn window

The Draw yarn editor is composed of several areas. On top, you have the drawing area. The yarn is drawn in

grid, and you can change the zoom level by pressing + and – on the keyboard, or by Ctrl+mouse wheel. The top

of the yarn also displays the ruler, so you know in real size how long will certain efect be. Below the yarn draw

Menu bar

Ruler

Drawing area

Preview

Color in fve shades

Yarn size

Tool bar
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area  you have the  same  yarn repeated 5 times,  so you have some  idea how will  the  yarn  look when  it  is

repeated several times. Each yarn has its own random starting ofset.

The colors used in the yarn, are displayed at the bottom, together with the actual yarn dimensions, both in

pixels (points) as in real length. If you want longer yarn, you can increase the Length value in the lower right

corner. Note that you will not get new empty space, since program will automatically copy the existing yarn to

the new area. The length of yarn is not arbitrary - it must always be power of two. A length of 11 thus means

length of 2 to the power of 11, that is 2048. The Stretch value gives you possibility to match desired length of

the yarn repeat. 

It can be painful to draw very long yarns, so we have some tools which make it easiere you can scroll across the

yarn with wheel mouse, and program supports auto-scrolling for drawing long areas. This means that, if you

draw  out  of  the  window area  horizontally,  the  program  will  scroll  the  yarn  until  you return  back into the

drawing area.

The  available  colors  for  drawing  are  below  the  yarn.  Each  yarn  color  allows  5

variations of the basic color. The basic color is in the middle, labeled 0. Then you have

two  lighter  colors  labeled  -1  and -2,  and two darker  colors  with  labels  +1  and +2

(Figure 137).

You have an option menu to choose the thickness of your draw pen - it can go from 1 to 9.

There are several icons or menus to choose from at the bottom of the Draw yarn window. The frst one on the

left  allows you to apply the yarn to the fabric, to observe the yarn changes in the real fabric simulation.

Next comes the Draw tool – freehand  , rectangle  , spray  , mix  . Left mouse

button draws with selected color, right mouse button draws with background color (that

is hole in the yarn).

After that you have the choice of the Draw modee frst is normal, indicated by a pen  . Then

you have the  Recolor tool  . The recolor tool will keep the shades of the yarn image, and

just recolor it into diferent yarn color. In this way, it will be easy to keep the yarn twists in the

image, and make a complex printed yarn with colors changing across the yarn. The last mode

is lighten/darken . It allows you to draw the area into a darker color (left mouse button) or

lighter color (right  mouse button).  It does this without afecting the actual  color. So if you

draw across a yellow, it makes a yellow darker, but if you draw across green, it makes a darker

green. In this way, it should be easier to draw yarn twist, or shade the yarn illumination from top to bottom.

After these main operations, you also have other tools, most of these should be easy to understand, if you

know ArahPaint or weave editor. There are two icons to mirror the yarn horizontally  and vertically  . The

scissors  will move the beginning of the yarn to the middle (so you can fx the repeat at the beginning and

the end).

Figure 138: Yarn
pen size

Figure 140:
Draw yarn

mode

Figure 139: Draw
yarn tool

Figure 137: Yarn colors
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The next tool   is intended for yarn thinning. It will thin the yarn for the number of points of the currently

selected pen size. If pen size is 3, it will take 3 pixels from the top and from the bottom. This function serves for

making space for the boucle or fame yarn. You frst  need to thin the yarn, so you can later draw the thick

efects.

After that you have two icons for tilting the yarn to the left  and right  . You can use it to adjust the twist

angle.

You also have one level undo  for your drawing operations.

To adjust the zoom level of the yarn editor, change the zoom factor, or roll the mouse wheel up or down while

holding down the Ctrl key.

6.2.3.1 EDIT MENU

The Edit menu of the  Draw yarn window contains additional tools / functions for faster yarn drawing.  Clear

shades changes the fve-shades color into one solid color (middle tone), which makes drawing much easier and

faster. To revert the shades, use Edit > Add top/bottom shades, and then Edit > Add twist. Program draws

twists automatically.

Figure 141: Add shades and twist

Once you have fnished drawing your yarn, you can save it, so you can use it in diferent fabric. The yarn colors

are saved in the yarn fle; you can change colors as for any other “normal” yarn in the Edit colors window. So

you don’t need a couple of fame yarns, you can use one for all the diferent colors and yarn counts.

6.2.3.2 LOADING YARN SHAPE

Load yarn shape  overdraws the shape and twists of the existing yarn in the Draw yarn window with the shape

and twist of a loaded yarn, but preserves the colors. It is useful, if you want to change melange, multicolor, or

mouline template yarn into already prepared bouclé, famme (slub), or similar yarn.

Figure 142: Melange yarn before and after loading boucle yarn shape

6.3 SAVING AND LOADING YARNS

Saving and loading of a single yarn is supported from the File menu on top of Yarns window. Yarn is loaded to,

or saved from the currently selected yarn. Colors are also saved in the yarn defnition. If you do not want to

load the color of the yarn, load it to an unused yarn and then copy the yarn defnition across the desired yarns

with the right mouse button in the Yarns window.
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6.4 YARN BROWSER

To open the Yarn browser, select  File > Browse yarns  from the Yarns dialog. The window is split  into two

parts. The left part displays all yarns from the default yarn directory. On the right side there is a list of colors

associated with currently selected yarn.

Figure 143: Yarn browser

It shows all  the yarns, and you can order the list  by yarn code, count,  ply,  twist,  composition or name. To

change the sort key, click on the title of the list. Once you click on the yarn, the program will show all the yarn

colors of that yarn, together with stock quantity and price. If you double click on the yarn, it will load these

values into the yarn. In most cases, you only want to transfer the codes, yarn count and composition. So the

Load only codes toggle button is enabled by default. If it would not be enabled, the program would load all

the yarns properties, like the actual color values (not just color codes), yarn image, melange / mouline settings

etc. When you load a yarn using File > Load yarn, the program loads all the yarn properties.

The yarn color section can also be sorted by code, name, weight and price. This can be useful, when a single

yarn is available in many colors.

The browser has some tools for yarn selection, for example you have a flter to select only yarns which match

certain code, name, or were defned in certain season. The yarn season cannot be defned in ArahWeave; it is

specifed in the XML import fle. More on that in Chapter 19.2. 

If you want to refresh the yarn availability, select Tools > Import yarn availability  from the Yarn window. This

reloads yarn stock XML fle and refreshes the data.

6.5 USING SCANNED YARNS IN ARAHWEAVE

6.5.1 SCANNING A YARN

Most consumer grade fatbed scanners are designed for Letter and A4 paper. So the usable length of scan is

not more than 30 cm. This is a major shortcoming of yarn scanning because a repeat size of many fancy yarns

exceeds this length. So we don't get full repeat, or we have to use rather complex image manipulation to get

our fnal yarn image.

A yarn image should meet three requirements in order to allow ArahWeave to use ite

1. The image widthe the yarn image should be exactly 15 pixels. 

2. The image heighte it should be any power of two; in practice it means numbers like 512, 1024.. but

since the width of the yarn is relatively small comparing to the length of yarn, number would be more

likely 8196 or 16384.

3. The number of colors in the image should not exceeds 31. The frst color in the palette is determined

as a color of background. It will be invisible (transparent) in the Yarn editor, and also in a fabric. You

can use ArahPaint to determine, which color will be the frst one in the palette.

6.5.2 GETTING A YARN SCAN

The yarn should be as straight as possible during scanning. The image in Figure 144 is almost useless, because

it would require too much time for editing yarn images.
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Figure 144: Various fancy yarns scan

In  our  example,  we  have  fxed  a  yarn  to  a  paperboard.  We  choose  a  paperboard  based  on  a  yarn  color.

Obliviously, lighter or mid-tone yarns require darker paperboard, and darker yarns are better visible on a white

paperboard.

Figure 145: To prepare a yarn for scanning, cut a notch at each side of a paperboard, and anchor a
thread in the notches.

6.5.3 EDITING A YARN IMAGE IN ARAHPAINT5

Load an image into ArahPaint. Check whether a yarn is aligned horizontally (or vertically). If not, you should

rotate the whole image to achieve alignment. To do this, choose Edit > Rotate Image. Draw a line along the

edge of a yarn that should have been straight.

Figure 146: Aligning a yarn after scanning

ArahPaint  will  automatically  rotate the image by the right  amount,  resize  the image, and show you a live

preview of what the fnal image will look like.
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Figure 147: Applying rotation

Then create a selection around yarn in the image, and crop to selection (Image > Crop to selection), and save

the fle.

Figure 148: Selecting a yarn in the image

From one yarn, you can get more color variations, if you modify it in some photo editing software. In example

below, we are using black-and-white fancy yarn.

Before loading it into ArahWeave, change (scale) the size of the yarn in pixels, so that it will meet ArahWeave's

requirements. At this stage the size should be 15 pixels by n2. pixels (or n2 x 15 if you work on horizontal image

like we do.).

In our example, the image size is 3461 by 29 pixels.

Figure 149: The resize image dialog

We  are  working  on  horizontal  oriented  yarn;  frst  change  the  Height  to  15.  The  Width will  auto  adjust

according to the aspect ratio (proportion).
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Figure 150: Setting the yarn size

Now break the chain by clicking on it ( ). It changes to the broken chain icon ( ). Now you can set the width

independently  from Height.  The closest  power of two number to 1790 is  2048,  so set  the height to 2048.

Before clicking the OK button to apply the changes, set the scaling flter (algorithm) to Bicubic.

Figure 151: Setting the yarn width

The yarn is stretched a little bit now, but you can control this latter in ArahWeave's yarn editor.

Figure 152: The yarn image after resizing

Now we have to reduce the number of used colors in the yarn image. Choose Colors > Set number of colors,

and set the number of colors, that you want to have in the image. You can start with higher  number than the

actual number would be.



  www.arahne.si  A r a h W e a v e  

User Guide 

  6 9

Figure 153: Reducing the number of colors

We have reduced the number of colors to 35. You can see that many of them are almost identical. You can

merge  these  colors  into one color  in  the  ArahPaint's  color palette.  First  select  one of the  colors  from  the

almost-identical  group (left-click selects a color);  then paste it  into other colors from the group (right-click

pastes selected color into clicked color). After that,  you just  need to merge equal  colors – click the merge

identical colors icon .

Figure 154: Merging colors in the Color palette

Obviously the white, color No. 6, is the background color in the yarn image. To enable ArahWeave to recognize

it  as a  background color, it  should be on the position 1 in the Color palette.  To change the position in the

palette, frst click it to select it, and then click the color on the position 1, while holding the CTRL key on the

keyboard.

Figure 155: Positioning the background color to No. 1
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You can change the color of

the  background  to

something  which  will  be

more  distinguishable  from

other parts of the yarn. This

background  color  will  be

invisible  in  ArahWeave

anyway.

And  now  the  fnal  step  –  if  you  work  with

horizontally  oriented image,  you should put  it  in

vertical position.

Figure 157: Rotating the image

Figure 156: Changing the color No. 1
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6.5.4 LOADING A SCANNED YARN IMAGE IN ARAHWEAVE

Open  ArahWeave,  Fabric  >  Yarns.

Choose Scanned as the yarn model, and

click  the  Draw  yarn button.  This  will

open the Draw yarn dialog.

Choose  File > Load yarn image from the

Draw  yarn  window's  menu,  and  load  an

image  from  the  fle  selection  box.  Click

the OK icon ( ) to confrm the new yarn.

Figure 159: Loading a yarn image

Figure 158: Opening the Draw yarn dialog
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Set the yarn count in in the main Yarns window.

From here, you can also save a yarn, and use it in

other fabrics,  or  just  use  its  shape  (File  > Load

yarn shape…) while constructing diferent fancy

yarns.

Figure 160: Preview of the yarn in the Yarns window

After you have saved a scan-based yarn, you can use it in any ArahWeave fabric fle.

Figure 161: Using scan-based yarn in a fabric

7 EDITING WARP AND WEFT PATTERN

Figure 162 shows a window for entering the warp and weft patter. The main parts are e

1. The menu bar.

2. The option  menu  for choosing between  entry  as  threads or as  length in  millimeters,  and option  menu

containing the preferred type of parenthesis in warp and weft description, either ( ) or [ ].

3. The option button to choose Warp pattern mode (asymmetrical, symmetrical, pivot1, pivot2).

4. The option button to choose 2 warp beams.

5. The icon bar for warp pattern.

6. The multi-line warp entry feld.

7. A color box with warps on top and wefts below. The last color is the background color. Color  Y is mark for

fringe – weaving without weft. On the left there are arrows to copy warp to weft, and weft to warp, and

arrow on the right for exchanging warp and weft pattern.

8. The multi-line weft entry feld.

9. The option button to choose Weft pattern mode (asymmetrical, symmetrical, pivot1, pivot2).

10.  The option button to choose Double weft insertion.
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11.  The icon bar for weft pattern.

12.  OK, Exit, Help buttons.

ArahWeave uses a very simple way for entry of warp and weft pattern. You just enter the number of equal

threads followed by identifer  of the thread. In this  way,  warp pattern  2A 3B 1C will  expand to  AABBBC|

AABBBC|AA...The vertical bar ( | ) is meant just to indicate the end of repeat.

Figure 162: Warp and weft pattern editor

You must use thread identifers from  A to  Y; you can see the actual thread colors below warp or above weft

pattern entry feld. Warp ends are identifed by capital letters, but they are not required, when you enter the

pattern. You can also enter [Space] characters to format your entry; they will be ignored. The actual size of the

warp and weft repeat is displayed at the end of window title. The letters of warps / wefts, which are used in the

pattern, are marked by an asterisk (*). The last color in the yarn bar (in Figure 162 it is white, labeled with #) is

the background color. If the fabric it is transparent, like curtain, you can see the background color through the

fabric.

Currently selected Yarn (D in warp in Figure 162) is highlighted in the pattern, so you can easily fnd it.

There are special provisions intended to help you in the entry of complicated and repeating patterns. Round

parenthesis will  repeat the whole sequence for the number of written before the parenthesis,  while square

parenthesis will repeat the sequence until the number of threads before the parenthesis is consumed.

Sequence 2a 3(1b 1c) 2d will expand to aabcbcbcdd|aabc...

Sequence 2a 5[1b 1c] 2d will expand to aabcbcbdd|aabc...

The program will also check for syntax errors like parenthesis mismatch and other forms of errors. It will warn

you about the error refusing to process the illegal sequence, and position you to the feld and character, where

it found the error.

Nesting of parenthesis like 5(1a 20(1b1c)) is permitted.

You may mix square and round parenthesis in your pattern entry, while computer will use just one of the two,

depending on the state of the option button in the upper right angle of the entry window.

7.1 WARP AND WEFT PATTERN MODES

ArahWeave also  implements  special  symmetry  tools.  The  patterns  we  have  explained  so  far  are  all

asymmetrical, but if you select the option menu labeled asymmetrical in warp or weft pattern, you will also

see options symmetrical, pivot1, and pivot2.

A symmetrical pattern 1a1b1f2c3d will expand to abfccddddddccfba|abfccddddddcc...

Note that frst and last entries in the pattern are efectively doubled in the expanded sequence. This is correct,

but may not be desired.

To avoid this you can use pivot1 type of symmetry. This symmetry mirrors the pattern without repeating the

frst and last entry in sequence. It is used in almost all Scottish tartans. The same pattern from above would

expand toe

abfccdddccfb|abfccdddccfb|ab...

Symmetry pivot2 does the same as pivot1, just that it does not mirror frst two and last two entries. Therefore 

the above sequence would expand toe

abfccdddf|abfccdddf|abfcc...
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7.2 LOADING AND SAVING THREAD PATTERNS

Loading and saving thread patterns  is  possible through the  File menu of the  Edit warp and weft pattern

window.

To save warp pattern choose File > Save warp pattern

To load warp pattern choose File > Load warp pattern

To save weft pattern choose File > Save weft pattern

To load weft pattern choose File > Load weft pattern

7.3 BROWSING WARP / WEFT PATTERNS

To open the warp browser, choose  File

>  Browse  warp  patterns.  Browser

displays  warp  pattern  name  (code),

pattern,  repeat,  the  number  of  used

yarns,  and  date  of  creation.  You  can

sort  the  warps  order  by  any  of  these

criteria. Below list of warps is graphical

presentation of warp in current fabric’s

colors.

Figure 163: Browse warp pattern

Weft  pattern  browser  is
similar to warp browser, but it
displays  weft pattern
vertically.

Figure 164: Browse weft patterns

7.4 TOOLBAR

The Edit warp and weft pattern window has its own toolbar—actually there are two, one for warp and one for

weft.

 move warp to the left by 8 threads

 move warp to the left by 1 thread

 mirror warp pattern

 move warp to the right by 1 thread

 move warp to the right by 8 threads

 match warp pattern to weave size (if the weave size is already equal to the warp size, then the icon is

grayed out )

 undo for thread pattern operations

 redo for thread pattern operations
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 clear warp/weft pattern

To copy warp to weft, or weft to warp, or exchanging them use arrows next to the color bar.  The operations

copy (exchange) both pattern and the yarns.

 copy warp to weft

 copy weft to warp

 exchange warp and weft

There are three more icons which are not strictly related to changing the appearance of fabrice

 Remove or add spaces in pattern (instead of 1a1b1c1d it writes 1a 1b 1c 1d, which is easier for reading).

 Sort pattern - rewrites the pattern so that it starts with yarn A, followed by B, C...

7.5 DRAWING WARP AND WEFT PATTERN IN FABRIC WITH MOUSE

Beside the numeric way of entering the warp and weft pattern, you can draw it by mouse.

First,  set  the size  of repeat,  either  as  number of threads,  or as  length in  mm, depending on your  current

settings. Select the yarn (warp or weft), that you want to use. You can do it in yarn editor, color editor or warp

and weft entry window. As you click it, you will see that the pointer color and shape will change (to either cone

 for warp, or shuttle  for weft yarn selection), and currently selected yarn will be outlined in with a black

and white rectangle.

To enable drawing warp / weft pattern with mouse, the Edit warp and weft pattern window, or Edit colors

window, or Yarns window should be opened, and the warp or weft pattern repeat should be at least 10. On

very short patterns, drawing by mouse does not make much sense, and we prefer to have the pan (hand) tool.

There are two diferent modes of drawing warp and weft pattern with mousee replacing and inserting / deleting

yarns.

7.5.1 REPLACING YARNS IN THREAD PATTERN

Click in the fabric on the yarn, that you want to replace. If you keep it pressed, it continues to draw. The fabric

changes in real time and the “complicated” warp or weft pattern is written automatically. You can use it to

draw completely new patterns, or just to change yarns in existing patterns.

The function also works on symmetrical patterns.

Figure 165: Drawing warp and weft pattern with mouse

 

7.5.2 INSERTING OR DELETING YARNS FROM THREAD PATTERN

To insert yarn into thread pattern with mouse use  Shift + left click. It will insert a thread left of the clicked

thread.

To delete yarn from thread pattern press Shift + right click on a thread, which you want to delete.

7.5.3 PROTECTED YARNS

In drawing warp or weft pattern with mouse, you can now protect yarn colors for easier editing of complex

patterns. In the warp/weft pattern bar, where you usually select the yarn color with which to draw, you can

double click a yarn, and it will become protected (shown by crossing out the yarn letter). Then you can draw

thread pattern in the design with a diferent yarn, and the protected yarns will remain unchanged. This is most

useful if you have an  extra weft or  fl coupé design, and you want to modify the ground pattern to make it
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more interesting. Simply protect the yarns which you use as “extra wefts”, and freely draw the weft pattern

and only the ground yarns will be changed. The settings of protected yarns is purely for editing purposes, and it

is not saved in the fabric fle. Yarn protection is cleared upon every loading of a new design. Yarn protection

only afects drawing the pattern with mouse; you can still type a diferent pattern in the warp/weft editor.

In Figure 166 we want to change weft c with weft d just in one short segment. Normally we should select weft

d, and then click with mouse on every weft c, that we want to change.

Figure 166: Before drawing over protected yarns

 

But with protected yarns the task is much easier. Just double click wefts  a and b , select weft  d, and drag a

mouse on the part, where you want to change weft c to weft d. It will change, protected a and b will remain

unchanged.

Figure 167: After drawing over protected yarns

 

Protected yarns have another useful function: they protect area in weave editor also – so you can draw, copy,

weave in the Weave editor, but weaving points “under” protected yarns remain unchanged. In case that you have

selection in the weave, protected yarns actually create a protected area (mask) in selection. If you load another

weave into selection, area covered by protected yarns remains unchanged.

7.6 ENTERING THREAD PATTERN AS SERIES OF LENGTHS OF DIFFERENT THREAD COLORS

Usually, you enter a colorful thread pattern as series of numbers and yarn letters., each number representing

the number of repeating threads of particular color, like 3 threads of color a, 5 threads of color b, and so on. But

instead of number of threads, you can use the length of particular color (millimeters or inches), followed by

another  length  of  diferent  color  and  so  on.  When  you  fnish,  you  can  change  the  “pattern  unit”  from

millimeters back to threads by choosing Threads from the option menu (see Figure 168).
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Figure 168: Warp pattern, expressed in the number of threads per each color section, and same pattern written in
lengths of each color section in millimeters 

7.7 SPLITTING OR MERGING WEFT THREADS

This function can help against streaking, if you have uneven yarn in weft, and

you  want  to  split  one  weft  yarn  across  several  cones.  Choose  Tools  >

Split/merge warp/weft from menu in the Edit warp and weft pattern window.

If you enter  aef and only yarn  a is used in the pattern, then weft pattern is

rewritten, so that yarn a is split evenly among yarns a, e, f. If, on the contrary,

yarns a, e, and f are all used in the pattern, they merge into yarn a.
Figure 169: Split/merge

warp/weft window

7.7.1 RANDOM

It is more advanced method to prevent streaking because of irregularity weft yarn then normal split method.

First you need to enter the whole weft repeat, which you want to split (120a in Figure 170). Then choose Tools

> Split/merge warp/wefts. In new window enter wefts, which you will use instead of single weft a (wefts abcd

in Figure  170). Click on the  OK button. Program randomly splits weft  a among wefts  a,  b,  c,  d and changes

yarns  b,  c,  d into yarn  a;  the repeat  of the pattern  is  120.  However,  you can use same  function in  design

purpose – just check the  Keep yarns button, and program doesn’t change the color of used yarns – you get

random stripe design with repeat of 120 threads.
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Figure 170: Split weft in the Random mode with the Keep yarns option of and on

7.8 SORTING

The Sort option will rewrite the pattern so that it starts with yarn A, followed by B, etc., as this is required by

production department of many mills. To use it, click  icon.

Figure 171: Using Sort function

7.9 REMAPPING YARNS

The yarn remapping function helps to change yarn letters in the complex patterns (if the pattern is simple, you

can just retype it). For instance, if you want to change yarn a to yarn c, but there are one hundred entries with

letter a, retyping would be a time consuming task. But with Remap yarns, you can do it in one single step. To

use the yarn remapping function choose Tools > Remap yarns. In the Remap yarns window select either you

want to remap warp or weft yarns. With mouse click change the position of the yarn letter. The example in the

Figure 172 shows remapping of weft yarns. Yarn a will remap to c, b will remap to a, c will remap to e, d will

remap to e, e will remap to b.
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Figure 172: Remap yarn table

7.10 TWO WARP BEAMS

In the entry of warp and weft pattern window, you can specify two warp beams, and the way in which the warp

is splite

• By number of shafts.

• By thread in dent.

• By yarn.

• In half.

Some of the choices have a corresponding parameter, for example the thread in dent which goes into second

warp beam, or number of shaft which goes to second warp beam.

Figure 173: Two warp beams

7.11 ADJUSTING WARP SYMMETRY

It is desirable to have warp symmetric with respect to fabric width, since this gives more freedom, when one

wants to cut the fabric. The leftover in cutting can be much smaller if the warp is symmetric. To achieve warp

symmetry,  you must  frst  enter warp and weft  sequence, and the number of threads in fabric width in the

Fabric > Consumption window. Then choose Fabric > Center (keyboard shortcut F7).

On the top of the window, there are four buttons (Warp, Weft, Warp blanket, Weft blanket) to select which

pattern will you center. Usually it is a warp; the other three are rarely used.

The fabric preview in the Center window consist from three sectionse the left side of the fabric, the right side of

the fabric, and a gray jagged mark in the middle, which delineates both areas.

The slider serves as a tool for manual  shifting of the patterne as you slide it,  you see what happens on the

fabric’s edges.

The automatic mode works in two wayse a simple Automatic shifts the pattern without taking care about the

weave, while Automatic without moving the weave  shifts the pattern only for a multiple of the weave width

(it means that the weave is not shifted).
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The warp repeat of a fabric sample displayed in Figure 174 is 224 ends, so this is the maximal number for which

we can shift the warp. The numbers on extreme edge on left and right tell you how much equal threads do we

have on left or right. 

Figure 174: Adjusting the warp symmetry

When you press the Automatic button, program fnds symmetry on its own, if it exists, moves the slider, and 

redraws a fabric preview, using new shift number. If you don’t like the result, you can modify it with slider.

When you click the OK button, the pattern is rewritten and fabric simulation refreshed. 

Symmetry can also be adjusted for warp blanket or weft blanket, so that the pattern motif is nicely centered in

the space available within the blanket. Centering using weft blanket can also be useful for shawls and bed

covers (blankets in normal sense of the word), when your design needs to be vertically centered on certain

number of wefts. Just set the desired number of threads in the blanket’s weft, and proceed with centering as

described above. 

7.12 EDITING DECOMPOSED

The purpose of this function is to enable designers to easily enter complex warp and weft patterns with one

pattern on the face, and another on the back of the fabric, or to enter complex ground patterns in the extra

warp/weft fabric. In the Edit warp and weft pattern window, choose Tools > Edit decomposed. In the Edit

decomposed window  you  need  to  select  whether  you  want  to  edit  warp  or  weft,  and  the  type  of

decomposition.  You  can  choose  Custom (default),  Denting (warp),  Two  warp  beams (warp),  Regulator

(weft).

7.12.1 CUSTOM

The principle of editing in the Custom mode is the same for both warp and weft, so we will describe it only for

warp.

Figure 175: Automatic centering of warp pattern
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You have to specify the layout in the same way as in decomposed weave editore enter 112 (it is not number

one hundred twelve; it is firstr firstr second) to have frst two threads in frst warp, and third warp in second

warp. Or enter 3 to have three warps evenly divided (that would be the same as 123). The program will take

the existing warp pattern and will decompose it, using the given division, and display you the editable divided

warps. Up to 9 warps/wefts are supported.

Figure 176 shows warp pattern, consist of 96 threads. For two threads on the face we want to have one on the

back. In the  Edit warp and weft pattern window enter  96a as a  warp pattern.  Then choose  Tools  > Edit

decomposed in  the  Edit decomposed window. Type the warp layout,  which should be  112.  The program

divides 96 threads into two layerse 64 threads in the frst one, and 32 in the second one.

Now you can modify both layers. The pattern in the  Edit warp and weft pattern window is written as the

combination of both layers.

Figure 176: Warp pattern decomposed

Once the program writes the decomposed warp, it also adds the number of threads in that warp besides the

number of warp.  If  you  choose  to  modify the  warp pattern,  and press  return,  the  program  will  write  two

numbers - frst is the number of threads, which this warp has at disposal, using current layout and number of

warp threads, and the second will be the warp length of current divided warp. If the two numbers will not be

divisible, the program will warn you with an exclamation mark besides the two numbers. If you want to change

the length of warp pattern, you may edit the total number of warp threads.

7.12.2 DENTING

The second way of warp pattern division is by the number of thread in dent. Click the Custom button in the

Edit decomposed window, and select Denting from the list.

7.12.3 TWO WARP BEAMS

If you have the warp pattern split over two warp beams, you can use the Two warp beams option in the Edit

decomposed window.

7.12.4 REGULATOR

Dividing by the regulator as a criterion is one of the most used function in the  Edit decomposed window. It

allows you to edit the ground weft pattern (which is in a solid color after Jacquard conversion in  ArahWeave)

separated from extra weft pattern.

Figure 177 shows the extra weft design with two extra wefts. We want to change the ground pattern from solid

color to 2a1d repeat. Instead of color b in the frst extra weft we want to have color b and e; in the second one

we want to have colors c and f instead of c only. In the Edit decomposed window, click the Weft button, and

select  Regulator as a dividing factor. Program divides weft pattern into three weftse the ground is 300a, the

frst extra is 159b, and the second extra is 22c.

Figure 177: Weft pattern divided by regulator
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Now to the modifying of weft patterne instead of  300a type  300[2a1d], instead of  159b type  159[1b1e],

and instead of 22c write 22[1c1f]. After clicking OK, the new weft pattern is also displayed in the Edit warp

and weft pattern window. It would be quite time consuming to write it without the Edit decomposed tool.

Figure 178: “Complicated” extra weft pattern

 

7.13 DOUBLE WEFT INSERTION

If you need to insert two wefts at a same time

through  the  shed,  mark  the  Double  weft

insertion box  in  the  Edit  warp  and  weft

pattern window. It should be supported by the

CAM  format  (dobby  and  Jacquard)  and  the

loom.  The  weft  pattern  has  to  be  written  in

diferent waye the number of repeats should be

followed by two weft letters. In Figure  179 the

pattern  4ab  3cd means,  that  the  loom  will

insert 4 times a and b wefts, and then 3 times c

and d wefts. 

Figure 179: Double weft insertion

7.14 FRINGE (WEAVING WITHOUT WEFT)

To  achieve  similar  efect  in  weft  as  it  is  empty

dentin  a  warp  pattern,  use  Fringe (weaving

without  thread  insertion).  It  is  used  as  a  design

tool, or to mark the end of “one piece design”, or

for  easier  cutting  between  two  fabric,  or  to  get

fringes in blanket etc. To specify “weaving without

weft”, use yarn letter y in the weft pattern.

Figure 180: Yarn letter “y” marks weaving without weft

To get a proper fabric simulation of fabric with fringe, you need to set technical data (Threads in fabric width,

Reed width,  Finished width,  Denting,  Weft  density)  in  the  Calculation of  thread  consumption window

(Fabric  > Consumption),  and mark the  Density  from  technical  data button.  See  Chapter  14 for detailed

explanation about Consumption and setting the technical data.
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Figure 181: Fabric simulation with fringe

 

7.15 RESIZING WARP OR WEFT PATTERN

To scale warp or weft pattern to a new pattern size, choose Tools > Resize warp/weft pattern. In the Resize

warp/weft  pattern  window  select  either  you  want  to  resize  warp  pattern  or  weft  pattern.  In  the  Repeat

(threads) feld enter a new pattern size (number of threads). Program scales pattern proportionally.

If you roll  the mouse wheel  up or down, and the mouse cursor is in the  Repeat  (threads) feld. the repeat

number is changing as you roll the mouse wheel. Program displays the fabric is interactively.

Figure  182 shows fabric before (warp repeat is 94 threads) and after warp pattern resizing (new repeat is 32

threads).

Figure 182: Resizing warp pattern

7.16 PATTERN GENERATOR

Pattern generator creates random (or partially random, partially controlled) patterns, usually very complex,

from the given set of parameters. To use parametric creation of warp/weft pattern choose  Tools > Pattern

Generator in the Edit thread pattern window. The window has several buttons and felds, many of which are

exclusive. The felds, which do not have any efect in the current setting, are grayed out. The window may

appear to have many settings, but only about half can be active at a time, so it is not so complicated as it looks.

But we can combine them in various ways, so it is quite powerful.
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In  the  Pattern  generator  window  select

whether  you  want  to  create  warp  or  weft

pattern. Program takes the size of the repeat

from  the  Edit  warp  and  weft  pattern

window,  so  you  should  set  the  repeat  to

something which is big enough, that it makes

sense  for  parametric  creation,  instead  of

numeric  writing.  In  the  most  simple  way  of

using this function, you combine two thingse

the  yarns  to  be  inserted  (yarns  a,b,c,d  in

Figure  183),  and the  lengths  to  be  inserted.

You can specify the Minimum and Maximum

length,  and  program  will  randomly  insert

yarns  sections  with  the  number  of  repeat

threads among the limits,  until  it flls  up the

repeat.

Figure 183: Pattern Generator

When you set the parameters, click the OK button, and the program generates a pattern. If you click OK again,

it will generate a new one.

Figure 184: Random weft pattern
 

You  can control  the  amount  of each yarn  insertede  if  you enter  aaaabc (or  4abc)  in  the  Yarn feld,  then

program will insert the yarn a four times more likely than b or c.
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Figure 185: Random warp pattern

 

The  Yarns parameter  has  two  options.  Allow  equal  consecutive means  that  is  possible  that  one  color

sequence is followed by the same color sequence based on the statistic probability. If this option is of, then the

program  prevents  following  of  one  color  sequence  by  same  color  sequence.  So the  lengths  will  never  be

prolonged, since two consecutive yarn sequences will never merge in the same yarn letter. 

If the Follow yarn sequence option is on, then the program writes the pattern always following the yarn order,

which you have entered in the feld, regardless the statistic probability. 

Instead of setting the Minimum / Maximum length range, you can enable  Specify lengths and the program

will allow you to specify the lengths of repeat of a single yarn which will be inserted. In Figure 186, the allowed

lengths are 2, 4 and 6.

Figure 186: Follow yarn sequence and Specify lengths options

 

As with yarn order, you can also enable  Follow length sequence. It means that the numbers of yarns in the

pattern will be ordered as written in the Specify lengths feld.

7.16.1 COMPLEX SHADING PATTERNS—OMBRÉ PATTERNS

If you enable both Follow yarn sequence and Follow length sequence, then the pattern becomes completely

deterministic. It is very useful  for long and complex shading patterns, where you repeat the same numeric

pattern over a sequence of diferent yarns. In this case, it can be difcult to fnd out the fnal repeat length, so

you have the Fix repeat option, which allows ArahWeave to overwrite previous repeat size with the new one.

You can use parenthesis in both the Yarns and Specify lengths felds. 



8 6    C h a p t e r  7  

 E d i t i n g  w a r p  a n d  w e f t  p a t t e r n
www.arahne.si   

Suggested order of steps ise 

Mark both Specify lengths and Follow yarn sequence. Enter the length sequences. The sample in Figure 187

below starts with length 15 threads, then 1 thread, followed by 4 times 5 threads and 1 thread, and so on (the

whole length pattern is 15 1 4(5 1) 6(3 1) 8(2 1)  12 (1 1)  8(1 2) 6(1 3) 4(1 5)  ). Then

click the OK button, so the program calculates the number of color sequences - there are 98 sequences, and

the number of threads is 184. If we need more or less threads, just change some numbers of the lengths, and

press OK again. 

Then go to the Yarns section. Since there are 98 sequences, which should be split between two neighboring

colors,  just  type  49(ab),  and continue  depending on  the  number  of  colors  which you  want  to  use.  In  this

example we use four yarn colors, so we entere  49(ab) 49(bc) 49(cd) 49(da). The end result is quite a

complex repeat of 736 threads.

Figure 187: Completely controlled pattern

 

7.16.2 STRETCH PATTERN FUNCTION

If you enter yarns in the  Yarns feld (in Figure  188e  aabcb), and enable  Follow yarn sequence and  Stretch

pattern, you are free to set the length of the repeat to whatever you want (on the sample we use value of 500).

The Stretch function will cause the program to stretch the pattern in the full width of the specifed repeat. This

makes a pattern of 200A 100B 100C 100B.

Figure 188: Stretch pattern

 

Obviously, this is not the purpose of this function. But you can set the length to 1, and Randomize to, let’s say

150, and program will not only predictably choose the next thread, but will make a random shading transition

between the two color segments. The higher the value of Randomize, the more random the transition.
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Figure 189: Stretch with the Randomize option

 

7.16.2.1 RESIZING A PATTERN WITH THE STRETCH FUNCTION

We can also use the Stretch function to resize an existing pattern to a new repeat size. For example, you can

have the pattern of 356 threads, which you want to proportionally resize to 220 threads. You should enable

Follow yarn sequence  frst,  then  Stretch, then use the  Copy pattern button, which will  copy the existing

pattern of 356 threads in the Yarns feld.

Figure 190: Fabric before stretching the pattern

 

Then set the Repeat number to 220 and click OK. This will proportionally resize the pattern. If you wish, you

may still  use the  Randomize option with this function, or instruct  the program to rewrite the pattern with

specifc lengths, for example by two threads, instead of one thread.

Figure 191: Fabric after stretching the pattern
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7.16.3 PATTERN GENERATOR AND PROTECTED YARNS 

An important feature of the Pattern generator is,  that it  doesn’t overwrite the protected yarns, if you have

them in the pattern. Figure  192 shows a fabric with extra wefts, where we want to modify the ground weft.

Normally, this is quite difcult, since ground pattern is all interlaced with the extra weft, in an irregular way,

depending whether the extra wefts are present at certain area or not.

Figure 192: Extra weft fabric with solid ground weft

 

Use double mouse click in the Edit warp and weft pattern window to protect the extra weft yarns (these aree

b, c, d, e, f). Once protected, they will be marked with an X.

Figure 193: Protected yarns

 

In  the  Pattern  generator window  you  may  now  set  the  toggle  button  Skip  protected  yarns,  which  will

continue the sequence as if the protected yarns were not there. This will cause the ground pattern to have the

same statistic properties in areas with and without extra wefts. Otherwise, the ground will look diferent on

areas with extra wefts.

Figure 194: Skip protected yarns option
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After clicking OK, you get a new extra weft fabric...

Figure 195: New ground weft pattern

...with a complex weft pattern (Figure 196).

Figure 196: A complex pattern after splitting the ground weft

7.17 GETTING WARP/WEFT PATTERN FROM IMAGE

ArahWeave has a function to get the warp/weft pattern from an image.  ArahPaint has some great tools for

drawing random  line  patterns,  so maybe  it  is  easier  for some  designers  to  draw  the  image  than  to write

parametric pattern in ArahWeave. The number of used yarns in the pattern is equal to number of used colors in

the image. The program takes the frst pixel column from the left to generate a weft pattern, and frst pixel

row from the top of the image to generate a warp pattern.

To use the function,  load the image in the jacquard conversion (Weave  > Jacquard conversion),  and then

choose  Tools > Get warp/weft pattern from image. Select  warp or  weft, and the length of the fnal repeat

(number of threads in the repeat). If you enable toggle button Yarn colors, the colors from the image will also

be copied into yarn colors, for easier orientation.
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Figure 197: Getting warp/weft pattern from image  

After clicking OK, the thread pattern is applied to the fabric.

Figure 198: After applying Get warp/weft pattern from image – the yarn colors are taken
from the image

 

You can use same image to generate warp pattern. Click  icon from the Images menu to fip the image for

90 degrees. Select Warp, set the repeat size, and click OK.

Figure 199: Getting warp pattern from same image as weft pattern

 

7.18 SQUARE DESIGNS WITH DIFFERENT WARP AND WEFT DENSITIES

First enter the warp pattern in any way you like. Then set the warp and weft density. Convert the pattern from

Threads to millimeters ( mm), and click  icon to copy warp to weft. Then convert mm back to Threads.
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7.19 EXCHANGING WARP AND WEFT (ROTATION BY 90°)
In the Fabric menu, there is a function Warp<->weft which swaps warp and weft. It also exchanges all colors,

yarn parameters, densities, denting / regulator pattern and rotates the weave by 90 degrees. The function is

reversible, which means that applying it twice will give you the initial position. You will not lose any data if you

apply it. Unfortunately, for fabrics with denting / regulator, it is not possible to exchange densities for warp and

weft in automatic way, since we have weft density on one side, and raw width, fnal width, reed number, etc.

on the other side. So in these cases, some manual editing is necessary to put things in a sensible relationship, if

you would really want to exchange warp and weft.

7.20 BLANKETS (DOBBY)
Blankets are a textile way for making color variations of a single fabric, or a way to produce several trial fabrics

within one fabric. The full fabric width is divided in several sections, normally of equal width. Then, diferent

yarns are assigned to replace the original pattern in the frst section. Same goes for the weft, just that weft is

not limited by fabric width, so we can make sections longer, or use bigger number of sections.

In the top-level menu Blankets you have the possibility of viewing several color combinations of a single fabric

within ArahWeave, and editing the blankets. In blanket editor, you can set the number of diferent warps and

number of diferent wefts, from 1 up to 30, and the width of the band from 10 to 3000 threads. The weave

continues regardless of the bands, so it is a good idea to set the width of one band to a multiple of the weave

repeat. If you enable the Reset button, then the warp pattern or weft pattern will be restarted on each section,

otherwise it will just continue with the changed yarns for that section. The blanket editor shows the selected

yarn color, along with codes and names of all colors in that yarn.

As you select a yarn, all the positions containing this yarn are highlighted. In this way, you can easily identify

equal yarns in spite of having very similar colors. To set the yarn colors in other color variations, use the usual

way in  ArahWeave – left mouse button to select a yarn (position), right mouse button to copy. You cannot

exchange yarns with middle button. Note that you can only copy warp yarns to warp variations, and weft yarns

to weft variations. You cannot alter the frst variation, since doing so would change yarn letter, warp / weft

pattern and only confuse you. We suggest that you make blankets only at the fnal stage of work. First make

your fabric right, then copy / load / exchange / modify all the yarn colors (A...T), that you intend to use. If your

yarn letter codes of the initial fabric are not all ordered on the left, press the Sort button in warp / weft editor,

so that it will be easier to add additional yarns for blankets. Only at this stage start making a blanket. If you will

change / exchange / copy yarn colors or yarns (A...T) after your blanket color variations will be assigned to their

positions, you will probably ruin what you have just constructed. You can only modify yarns that are unused in

the blanket, if you do not want to afect the blanket in unexpected way. There are three modes for viewing the

blanketse  View all will show all of them contemporary,  View selected will just show the selected warps and

wefts, and  View 1/1 (default)  will  show the basic fabric. This last mode will  be used as default when a new

fabric is loaded.
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Figure 200: Blanket editor
 

There is so much data on the screen, that  we have implemented additional  feedback functions.  When you

move the mouse over the fabrics in normal mode, it will show you the number warp / weft thread in the help

menu on top right edge. When you will be viewing blankets, it will show you the blanket combination that you

are  viewing at  the  moment,  like 2/7  (second warp by seventh weft).  In the  window title,  you  will  see  the

numbers of blanket sections that you are currently viewing, like [1-7/1-5] or [2,4,5,7/1,3,5], depending on your

viewing selection. To select particular blanket section, click with the mouse on the number above the section.

Selected sections are indicated by *. Clicking it again will deselect it. At least one section must be selected, so

program will prevent you from deselecting the last selected section. If you want to have exactly one selected

section, but diferent from the current one, frst  select that other section, and then deselect the unwanted

section. If you will reduce the number of sections (shades), so that previously selected sections would become

invisible,  the  frst  section  will  automatically  become  selected.  The arrows  in  Warp  /  weft  edit  window for

copying warp to weft and vice verse also copy the blanket information. Yarns codes (A-Y) used in main design

are marked by  *,  yarns  used in  blankets are  marked by -,  and yarns  used in  selected blanket sections are

marked by +. In this way, you can immediately see which yarns are used, and which are free.

All blanket related information is saved to flee additional  yarns used in blankets, width of blanket sections,

choice of resetting the pattern on new section, and the actual yarn to blanket mapping. Selected / unselected

blanket sections are not saved, since they represent the blanket view mode, not the blanket itself.

We had to choose what to print as yarns below the fabric, because we cannot print all of them due to lack of

space. So we only print the frst warp / weft combination, whatever that might be. If you print them all, it will

give you the original yarns; if you only print one of them, like 3/4, it will again print the correct ones. But if you

print 2,5,7/4,5,6 it will print colors of warp 2 and weft 4.

8 COLORS

ArahWeave® uses  three  diferent  color  models  for  displaying  fabricse  RGB (red,  green,  blue),  HSL (hue,

saturation, and lightness), and CIE Lab.
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CIE  L*a*b*  (CIELAB)  is  the  most  complete  color  space  specifed  by  the  International  Commission  on

Illumination  (French Commission  internationale  de l'éclairage,  hence its  CIE initialism).  It  describes  all  the

colors  visible  to the human  eye and was created to serve  as  a  device independent model  to be used as  a

reference. Unlike the RGB and CMYK color models, Lab color is designed to approximate human vision. Its L

component closely matches human perception of lightness

In ArahWeave, screen RGB colors and print RGB values are matched for a particular printer / screen based on

CIE Lab values that provide device independent color matching.

Figure 201: CIE Lab color model

 

The word “match” which is used later in the text, always means match within the limits of a particular color

generation  technology  and  the  parameters  /  capabilities  of  the  device  where  the  color  is  being rendered

(monitor,  printer),  not  a  perfect  match  against  either  PANTONE®-identifed  solid  color  standards  or  a

particular color specifed in the CIE Lab color space.

8.1 THE COLOR EDITOR

Chose Fabric > Colors to open the Color editor. It consist of fve sectionse

• the title bar information (the name of color palette and the number of colors in it)

• the color palette

• the color palette preview area showing all colors from the palette

• warp and weft colors

• the color editing area
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Figure 202: Sections of the Edit colors window

8.1.1 LOADING/SAVING A COLOR PALETTE

When you open the Edit colors window, the default color palette is already loaded in the window. To load a

diferent palette in the Edit colors window, just choose File > Load colors, and select a color palette fle from

the Load colors dialog. Alternatively, you can use Choose, which lists all fles from current directory, and you

just click a fle from the drop down list to load it into Edit color window.

If you make changes in the color palette, you can save it under new (or old) name with File >Save colors.

8.1.2 CHANGING THE NUMBER OF COLORS IN THE PALETTE

The number of colors in the palette is displayed in the window’s title bar. You can

change the number of colors in palette with Number of colors from the Change

menu in the Edit colors window. If you increase the number of colors, new colors

will be added at the end of palette. If you decrease the number of colors, colors

will be deleted from the end of palette.

Figure 203: Changing
number of colors

Warp and weft colors

Color palette

Color palette preview 

Color editing area

Color palette's name

Number of colors in the palette
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8.1.3 ADDING OR DELETING COLOR FROM THE PALETTE

You can add new color next to the selected color in the palette  by

clicking   button  in  the  Edit  colors  window.  To delete  selected

color, click  or press the Delete key on keyboard.

Figure 204: + and – for adding or
deleting color from the palette

8.1.4 CHANGING THE NUMBER OF COLORS IN THE PALETTE DISPLAY AREA

In the Number of colors dialog you can also change the appearance of the color palette—the number of color

tabs in the row, and number of rows in the palette display area. 

8.1.5 COPYING COLORS FROM PALETTE TO THE PATTERN COLOR BAR

If you want  to copy currently  selected color to

another entry (warp,  weft or palette color) just

point to it and press right mouse button. If you

want  to  swap  them,  do  the  same;  just  press

middle mouse button.

Figure 205: Copying color from palette to the yarn color bar
with right button click

8.2 EDITING A COLOR

Select the color that you want to edit (warp, weft or palette color) by pointing to it and pressing left mouse

button. The currently selected color is displayed in the lower right angle of the Edit colors window. 

There are two fundamentally diferent ways of entering colore

1. Select the CIE Lab model and enter CIE Lab values

or set values with sliders for the desired color. Press

Enter  after  entering  the  value  (or  just  click  into

another feld). When the CIE Lab value is entered,

the  most  appropriate  color  is  generated

automatically  based  on  a  specifc  printer  and

screen profle.

If you want to switch back to RGB model, you must put L, a, and b values all to zero, switch to RGB model
and edit RGB values.

Figure 206: Editing Lab values
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2. The color can then be entered in  either  RGB (Red, Green, Blue)  or HSL (Hue, Saturation,  Luminosity)

model.  RGB  model  is  natural  for monitors  and all  three  values  can  be varied  from  0  to  255.  You  will

immediately see the changes you make. The colors are mixed in additive way in RGB model, which means

that all  three components at  maximum  will  produce white. The HSL model is just another view at the

same color, where Hue is the angle of the color on the color wheel from 0 to 359, while Saturation and

Luminance  vary  from 0 to 1000.  Designers  might  be more  at  home  with HSL model,  while  computer

literate people are more familiar with RGB model.

The middle way between visual matching and the use of spectrophotometer, is using PANTONE Textile Color

System® color atlas. It is included in standard ArahWeave distribution.

8.3 COLOR DIFFERENCE 
One  of  the  unique  features  of  ArahWeave  is,  that  program  gives  you  a  feedback on the  screen  and print

accuracy of the selected color. This is indicated with the dE values on the right side of the color edit window. If

it displays a value of dE smaller than 2, it means that you are within color gamut and that color is reasonably

accurate. If you have a dE of 15, you know that you will not get the desired color. In this way you can at least

warn your customer that  this particular color is not correct, and attach a yarn sample to the printed fabric

simulation. Note that  the predicted dE is usually  overly optimistic, since it  represents the diference of the

desired color and the color found by the color matching engine of ArahWeave. We did an experiment and

printed out our simulation of all PANTONE® colors, remeasured them and compared the predicted color with

the actual simulated color. The dE was smaller than 2 for 92% of colors, and smaller than 3 for 99.5% of colors.

There  were  no prediction  errors  bigger  than  dE 4.  So  you  can  be  reasonably  confdent  in  the  program’s

prediction.

8.4 FINDING CLOSEST COLOR

We suggest to use Lab model for your color libraries. But sometimes it is easier to set the color in RGB mode,

or for instance, you fnd an interesting color on your Desktop or in some other application and you have just

RGB values of that color. Enter that values in ArahWeave and use the  Find closest color function from the

Change menu. Program will  fnd closest color in the currently loaded color database. It will  also display dE

value, if both colors are CIE Lab based. Otherwise it will  perform the comparison only based on screen RGB

values.

8.5 MATCHING YARNS TO COLOR ATLAS

Use it (Change > Match yarns to color atlas) when you want to replace colors in all yarns used in currently

loaded fabric with the closest matching colors from the color library. It is useful when you have set the colors in

RGB and you want them replace with colors from your production color library, or your customer’s color library,

or with PANTONE® colors.

8.6 BACKGROUND COLOR

The last  color at  the right  end of warp /  weft  color bar,  labeled #,

represents the color of the background, and is used to render empty

space on transparent fabrics in simulation view. It is saved along with

fabric data.

8.7 SORTING COLORS IN A PALETTE

You can sort colors in the Color fle by following criteriae Code, Name, CIE L (Luminosity), CIE a-redness, CIE b-

yellowness, CIE H-hue, CIE C-chroma, CIE dE-color matching error in print). 

You can also sort colors manually by drag-and-drop.

Figure 207: The color of the background
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8.8 FINDING COLORS

If you have got a color name or code and you

have  loaded  the  color  atlas  that  contains  the

color with  that  code /  name,  you can use  the

Find color  function.  You  can  activate  it  by

pressing the lens icon   at right of the color

name entry box (middle right of the color edit

window),  or  from  the  menu.  Type  in  the

window text of the code or name (or just some

part of it),  and press Enter. If will fnd the frst

occurrence for that color and highlight (select)

it. You can then click on the OK button again to

fnd  other  colors.  Use  forward  or  backward

arrow to search forward and backward. Capital

and small  letters  do not  make  a  diference in

search.

The Color bar at the right side of the Edit colors window is additional help for fast fnding a color in a color fle.

The Color bar shows all  the colors from the  currently  opened fle.  If you click on color in  the Color bar,  it

becomes the selected color in the color display area.

8.9 PRINTING COLOR DATABASES

You  can  print  the  Color  databases  by selecting  function

Print colors from the File menu in the Edit colors window.

You will be prompted by the print window , where you will

be able to select printer type and size of your print, as well

as number of lines that you want to print. The number of

colors per line will be equal to your screen settings (Figure

209),  and  the  starting  line  (row)  of  your  color  database

print will  also correspond to your position on the screen.

To simplify  your  orientation  in  a  big color database,  the

line number of the currently selected color is displayed at

the top right position of the Edit colors window.

By enabling the Title toggle button in the Print colors window you get a color name and code printed below

each color. Then you must decided about the number of printed rowse in Figure 210 the number of printed rows

is 15.

Figure 209: Setting number of colors (rows)

Figure 208: Finding color in the color library
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Figure 210: Print color window and Print preview

PANTONE Textile Color System® palette is standard part of ArahWeave distribution. PANTONE® Computer

Video simulations  or printed  simulations  may  not  match PANTONE®-identifed solid  color  standards.  Use

current PANTONE® Color Reference Manuals for accurate color. Same applies for the printed simulation of

PANTONE®-identifed solid color standards. The sufx CVT is used to indicate screen simulation, while CHT

indicates printed simulation, of the PANTONE Textile Color System©.

8.9.1 UNDERSTANDING COLOR GAMUT

To  avoid  any  misunderstanding  regarding  color  accuracy,  you  should

understand the notion of color gamut.

One common mistake is to link the actual number of displayable colors

with  color  accuracy.  When  we  were  making the  transition  from  8-bits

graphics cards with 256 colors to 24 bits per pixel graphics card, we said

we now have 16 million colors at our disposal—in a sense—we can do any

color we like. Surely, it was a big step forward, but it has nothing to do

with  color  accuracy.  Actually,  we  could  have  16  million  levels  of  gray

between  black  and  white.  We  need  much  more  for  color  accuracy  -

primary colors that have the most extreme values in CIE Lab space, then

a method color mixing and which makes them as predictable and linear

as possible. And fnally, a method of fnding the desired color out of those

we can generate.

ArahWeave will  fnd the best possible color, but it cannot make a color,

which is not within device’s color gamut.  In the following pictures, you

can observe the gamut of two commercial color atlases and one ink-jet

printer. Notice how the areas, which they cover are quite diferent. First

group of colors represent a projection of L versus a, second is L versus b

and third is a versus b. Since we want to reproduce them on the ink-jet

printer, we can indicate out of gamut colors (dE > 5) with a small point.

All measurements were executed using GretagMacbeth Spectrolino, D65

light, 2 degrees angle.

If you observe the color gamut of all  PANTONE Textile Color System®

colors, you will note that PANTONE colors are really a collection of colors

without strict ordering in mathematical sense. In fact, some colors have very extreme out-of-gamut values,

which makes them impossible to reproduce on any ink-jet printer.

Figure 211: PANTONE Textile Color
System®
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The color gamut of all RAL© colors demonstrates that most of its colors

are within gamut  of ink-jet  printer.  Note that  RAL's method is  really

based on  CIE  Lab,  since  you  can  see  the  geometrical  distribution  of

colors, which enables you to specify intermediate colors with RAL.

The picture of color gamut of Epson Stylus Photo 750/1200,  a 6-color

ink-jet  printer,  contains  5832 colors,  which are  basis  for  our  printer’s

color profle. A careful observer will  notice anomalies caused by under

color  removal  and  switch  from  light  Cyan/Magenta  to  dark

Cyan/Magenta. Note that the color gamut of ink-jet printer depends a

lot  on the printer  driver.  We have  developed our own printer drivers,

which aim for large color gamut and linearity in color reproduction. The

supplied drivers,  which we have examined, mainly aim for reasonable

reproduction of screen RGB to printed output, and score poorly both on

linearity and color gamut.

8.10 SAVING COLORS FROM LIBRARY AS IMAGES

To enable this function, you have to switch to  Expert mode (Mode > Expert in main ArahWeave window).

Then open the Edit colors window (Fabric > Colors), and choose File > Save colors as images. When you open

the Textures browser, there will be the folder with same name as the color library fle and all the colors from

library will be in graphical format, so you can load them as textures in ArahDrape.

Figure 213: Epson Stylus Photo
750/1200

Figure 212: RAL Design System©
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Figure 214: Saving colors as images

 

8.11 IMPORTING COLORS FROM A TEXT FILE

If you have a¸ spectrophotometer, which can write measured colors as CIE Lab values to a text fle, you can

import  color measurements  to create  ArahWeave's  color library  fle.  The text  fle  must  have the following

format (you can edit it with any common text editor)e

#COLOR_SAMPLES=4

34.25 -17.32 -3.25 Code1 Name1

64.87 37.01 -14.15 Code2 Long_name2

55.01 12.67 23.55 Long_code3 Name3

42.68 -6.81 -13.87 Code4 Name4

The frst line contains the indicator on how many colors are in this fle. Then we have one color in each line. The

frst three numbers are CIE L, a, and b values, then there are optional color code and name. If you want spaces

in color name or code, use underscore _. It will be transformed to space character when the fle is read. You can

have up to 250000 colors in one fle, which should be sufcient for most cases. The fle name must have the

.cm sufx, so the program will know that this are color measurements.

You must copy the text fle with CIE Lab values to the directory, where the colors are held. Typically, this would
bee 

/home/capdam/data/colors/myYarns.cm

Once you make such a fle, you can load it with the function  Load color measurements from File menu in the

Edit colors window. Before you do this, you should increase the number of colors in Change menu, so you will

have enough space for these newly loaded colors. Colors will be loaded to the position of the selected color in

the color database. In this way, you can easily add new colors to existing databases. Colors will be matched for

screen and printer automatically as you load them, based on current screen and print profle.

To use the newly constructed color database in another work session, save it by selecting  Save colors from the

File menu.

8.12 RANDOM COLORS

You can use this function, if you want to discover new color combinations of your existing design. Load the

color database that contains the yarn colors of your current collection. If you have too many colors, copy the

ones you want to use to the frst places of the color palette, and reduce the number of colors in palette to the

desired value. If you then call function Random colors from the Change menu, the colors from palette will be

copied at random to the warps / wefts which, are used in the pattern. When you fnd something that you like,

just save the fabric.

8.13 COLOR CROSS-REFERENCE

Sometimes  it  is  useful  to compare  two color databases  and map one to another.  You  might  want  to fnd

closest colors from a commercial atlas for your yarns, so you could communicate them to a business partner,

who does not have your yarn database. Just load your yarn color database, select function Cross reference to

from the File menu in the Edit colors window, and select the other color database. Program will fnd closest

colors and replace the names of your colors with the codes of the other database. The original codes will stay in

place, and color values will not change.
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9 CONVERTING IMAGE INTO JACQUARD WEAVE

9.1 ABOUT JACQUARD CONVERSION

The  Jacquard  image  conversion  enables  the  user  to  convert  an  image  into  Jacquard  weave.  To open the

Jacquard conversion window choose  Weave > Jacquard conversion from the main  ArahWeave window. If

there  is  already  image  saved  in  a  fabric  fle,  then  the  image,  its  corresponding  weaves  and  settings  are

displayed in the Jacquard conversion. If there is no image saved in the fabric fle, then the image and weave

sections in the dialog window are empty (Figure 215).

Figure 215: Default Jacquard conversion dialog

The Jacquard conversion window has its own menu bar. To load a picture choose  Images > Load image or

Images > Browse. 

ArahWeave difers from some other CAD programs, since the image does not contain weft control felds, such as

weft selector information,  in  the image. ArahWeave takes this  information  from fabric fle: regulator from the

Weave editor, weft change from the Edit warp and weft pattern window, variable weft density from the Set

weaving density window.

There are four ways to change zoom level in the  Jacquard conversion window (similar to main  ArahWeave

window, and Weave editor)e

• Press the plus key + to zoom in, or press the minus key – to zoom out

• Press Ctrl on the keyboard and roll the mouse wheel up or down

• Use the Zoom menu

• If you press any number from 0-9 on the keyboard you will  change zoom directly to that level (1 means

100%, 6 means 600%, 0 means 1000%).

As usual  in  ArahWeave,  mouse coordinates in the image are displayed on the right  edge of the menu-bar.

Window title displays image flename, number of colors, dimensions and current level of zoom.

Beside Normal Jacquard conversion (default type - you have to select a weave for every color), there are fve

additional ArahWeave types of jacquard conversione shading, extra weft, fl coupé, and weave blanket.

9.2 LOADING AN IMAGE INTO JACQUARD CONVERSION WINDOW

To load an image into Jacquard conversion window, use the Image browser. Open it by Images > Browse from

the Jacquard conversion window. Thumbnails (reduced-size versions of pictures, used to help in recognizing

and organizing them) of image fles are displayed to identify each image. Do one of the following to load the

image into the Jacquard conversion windowe

• double click in the thumbnail of the image.

• select thumbnail of the image and then click OK or press Enter.
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Figure 216: Browsing images

 

The text labels below the image icons have diferent background colors. Currently selected image has text

label in yellow, so you can quickly fnd it. Bi level (black and white) images have light gray background of the

flename area, and true color images have background in the light pink. Color palette (8-bit) images have it in

white. So you can quickly distinguish jacquard cards or weaves (black and white), scanned images (true color)

and cleaned up palette images.

The meaning of icons in the toolbar is described in the table below.

one directory up

back

forward

reload

default directory

switch to detailed view, switch to icon view

sort order

fnd image

create new directory

rename image

delete image

open selected image with ArahPaint4 (same as middle mouse button click on image icon)

Filter option allows you to search for particular images by size x,  size y,  size xy,  number of colors,  date of

creation, and  fle name. If you use the fle name flter, the program will  interactively change the display to

show you only the pictures, which match the search flter. In this way you will fnd your image very quickly.

To preview  an  image,  position  the  pointer  over  a  thumbnail  and  click  with  the  right  mouse  button.  The

Preview window in a full screen mode will appear.
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Figure 217: Full screen preview of selected image  

The arrow keys (    )← ↑ → ↓  move the image in the window in the desired direction. Default view size is set to

100%, the repeat view is on. Press F on the keyboard to ft the image in the window. Use + and – to zoom in or

zoom  out  (or  1,2,3,...  for zoom  100%,  200%,  300%...).  R toggles  between  the  single  image  view  and the

repeating image view. The  Page Down key loads the next image, the  Page Up key loads the previous one.

The Home key loads the frst image in the directory, the End key loads the last one. 

To close the Preview window press the Esc key, or click with the right mouse button in the window.

When you navigate to image directory for the frst time, the image browser has to recognize images and create

image thumbnails from the images. When you scroll up or down, it instantly creates icons for fles which appear in

the visible area. If the fles are big, the thumbnails’ creation time may increase. That might cause some lag while

scrolling. To avoid a lag—press Alt+Q. The browser will create all thumbnails at once, even for fles, which are not

in the related display area. Note, if you have a lot of fles in that folder, you may have to wait some time for the

program to fnish creation of thumbnails. The next time, when you enter that image directory, the image browsing

will be much faster, because the thumbnails were already created.

9.2.1 THE DETAILED VIEW

The image browser also supports the detailed view, which displays each fle or folder on a separate line, as a

fle name followed by information about the imagee Name, Date, File type, Size x, Size y, Colors, dpi X, dpi

Y, File size. You can sort images by any of these criteria. To change the sort key, click in the title of the list. A

column of this property is highlighted in yellow. To switch from icon view to detailed view click  icon, to go

back click  icon.
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Figure 218: Detailed list view of images

 

9.2.2 BROWSING SUBDIRECTORIES

Arahweave’s browsers have a capability of showing fles in sub-directories. This is very useful, when you search

for a fle, and you don’t know in which directory you have saved it. If there are sub-directories in your parent

directory, then the Image browser displays the “leafess tree” icon  in the upper right corner of the window

(in the same line as a directory path). To display all fles from sub-directories, click the tree icon. It changes to

the “tree with leaves and fruits”  icon   ,  which means,  that  the Image browser shows all  fles from the

parent directory and its sub-directories. If the image is in the sub-directory, then the name of sub-directory

appears in the image icon.

You should be careful when using of this option, since it may take a very long time to fnish and display the images.

Especially if you enable it at the start of your disk (/). The program will not crash, but it will read all the fles on your

hard disk, and this can take a lot of time. You should only use sub-directory browsing of directories which actually

contain the images.

9.3 INSERTING WEAVES IN JACQUARD CONVERSION

Color tabs are below the image area. By default, colors are sorted by their relative percentage in the image. If

you want, that ArahWeave sorts colors like they are written (saved) in the image fle, disable the Sort Jacquard

image colors by popularity option in the Weaving section of the Save setup window.

The  Normal conversion is default  setting of the Jacquard conversion dialog. In that  type of conversion you

should load a weave for every color. There are two ways to choose a color, in which you load a weavee

• click a color tab

• click the color pixel in the image in the Jacquard conversion window
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Figure 219: Jacquard conversion window prior loading the weaves

 

To load a weave into selected color, use  Choose weaves > Load weaves. You can also  Browse the weaves

graphically, as in weave editor. The weave browser is accessible through Choose weaves > Browse or you just

double click on the weave area in jacquard conversion, and program pops up the weave browser. If you double

click the weave, it loads into the currently selected image color. If the size of the weave doesn’t divide the size

of fnal jacquard image, its name is displayed in red. So you should choose only weaves which names are drawn

in black, or be really sure of what you are doing.

Weaves, which will replace the particular color in the image, is graphically displayed below the color tab. In the

color tab, there is the number of the color and the percentage of this color in the image. Below that, you have

the weave name, weave repeat and maximum foats of the weave.

Figure 220: Weaves in the Jacquard conversion

 

You can copy or exchange the weave as in other parts of the program: copy with right mouse button, exchange

with the middle button. 

You have a choice of grid size, so they can be displayed bigger or smaller. Weave repeat is marked as red-gray

points combination. If you click on the Color toggle button (Figure 221), you can see the weave in the colors of

warp / weft pattern in the view mode and zoom of the current fabric in the main Arahweave’s window.

Figure 221: Color option in jacquard conversion 

 



1 0 6    C h a p t e r  9  

 C o n v e r t i n g  i m a g e  i n t o  J a c q u a r d  we a v e
www.arahne.si   

The OK button in the lower left corner of the window serves for applying the weaves and generating the full

jacquard weave.

Figure 222: Fabric simulation of the Jacquard fabric after conversion

 

9.3.1 MODIFYING WEAVES IN JACQUARD CONVERSION (TOOLBOX)

On the right edge of the weave selection window, you have the usual weave modifying toolse negative, shift

up, down, left, right, rotate 90 degrees, mirror horizontal, mirror vertical, clear. These functions are same as in

the weave editor. When you use them, you modify selected weave in the Jacquard conversion window.

If you need to apply same type of change to all weaves in the Jacquard conversion

window, enable the All option. For example, you have a selection of 200 weaves in

jacquard  conversion,  but  your  weaves  need  to  be  shifted  by  one,  because  of

diferent warp sequence. Now you can simply enable  All and shift  them by one

thread using a single mouse click.

9.3.2 EDITING WEAVE FROM JACQUARD CONVERSION IN WEAVE EDITOR

Sometimes you want to modify the weave which is already loaded in the Jacquard conversion window with the

powerful tools of the Weave editor, like copying, editing decomposed etc. So you need to move the weave into

weave editor, and to do this, click   icon. Your selected weave is copied to the weave editor and weave

editor pops up. After you fnish with editing, click  icon to put weave back into selected weave position in

jacquard weave selection. In this way, you can quickly change the weave without need for saving it under new

name, and loading it again in weave selection.

9.4 OPTIONS AND SETTINGS IN JACQUARD CONVERSION

9.4.1 TYPE OF JACQUARD CONVERSION

Besides common conversion (Normal), where you replace one color with one weave, there are fve additional

conversion  modes,  accessible  through  the  drop  down  liste  Shading,  Extra wefts,  Fil  coupe,  and  Weave

blanket. 

Figure 224: Choosing type of conversion
 

Figure 223: The All option 
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9.4.2 JACQUARD WEAVE SIZE

Two text felds below the weave area,  one for warp and one for weft, determines the size of the Jacquard

weave. Usually,  the weave size is equal  to the size of image, loaded into the  Jacquard conversion window

(Figure 225). 

Figure 225: Jacquard weave size is same as image size

 

9.4.3 CHANGING THE JACQUARD WEAVE SIZE

You can change the Jacquard weave size in a two wayse

• Choose multiplication factor of the original  image size from the drop down menu  . You have a

possibility to select any multiplication from 1 to 16. In Figure 226, multiplying by two (x2) is used for warp,

and multiplying by three (x3) is used for weft. Blue color of the multiplier factor indicates, that it was used

to determine the weave size. If we change the number manually (Figure 227), then its color turns to black.

Figure 226: Jacquard weave size changed by multiplying
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• Type desired size in the felds.

Figure 227: Jacquard weave size changed manually

 

9.4.4 DENSITY (CHANGING THE WEFT SIZE)

If you click the Density button, the number of wefts (image dimension in vertical directions) is calculated from

the fabric density, which is set in the Set weaving density window (Fabric > Density).

9.4.5 DIVISOR OPTION

This option allows easy multiplication of a single design, when we want to repeat it several times into defned

area. The divisor option menu is available on   button besides the fnal weave size feld in the  Jacquard

conversion window. By default, it contains the value /1, which means you only repeat one picture motif in a

defned area. But you can change it to /2, or /3, or /4... to force several repeats (2 or 3, or 4, ...) of the picture in a

defned area.

This can be handy, when you want to repeat the motif several times by a value, which is not divisible by the

hook number. Figure 228 shows an example, where we want to repeat a motif with size of 200 by 200 pixels

across the width of 1200 hook jacquard 7 times. Since 7 does not divide 1200 without remainder, you would

again have to go in ArahPaint, repeat the motif 7 times, scale the resulting image to 1200, save it, load it in

ArahWeave, and only then do the jacquard conversion. But,  ArahWeave gives direct solutione set the divisor

factor to /7. Program will repeat a motif 7 times in the defned area (1200 by 200).

Figure 228: Using divisor
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This feature is also useful, when you are inserting weaves larger than the original motif. It is a quite common

situation, to have a motif, which you want to repeat several times across the full jacquard width, for example

2400  hooks. It  is  very easy to do, since program  does this  automatically.  But  if  the weave,  which you are

inserting,  has itself  a  larger repeat,  for example the whole 2400,  then it  will  be cut of at  the end of each

smaller repeat, although the small repeats will be repeated correctly. Up to now, you had to go in the paint

program, repeat the image there as many times as you needed it, load it back in ArahWeave, and load the

weaves there. It works both in warp and in weft, and is also saved in a fabric fle.

The design multiplication works both on normal conversion, as on extra weft/fl coupe conversion.

9.4.6 SYSTEM OPTION

Some  multilayer  fabric  construction  requires  multiplying  of  image  pixels  to  get  nice  contours  between

diferent weave efects on both sides of the fabric. Normally you have to take care about image size before

transforming  it  into  Jacquard  weave,  but  if  you  have  not,  here  is  the  System option  in  the  Jacquard

conversion window. Actually, it is some kind of image resizing.

For example, you want to create a design with two layers in the warp, and three layers in the weft. Design

repeat  is  1200  by 900  threads—so  the  image  size  should  be  600  by 300  pixels,  and you  get  fnal  size  by

multiplying width of image by 2 to get 1200, and height of image by 3 to get 900. 

If the image size is not 600×300 pixels, but you still want to have 1200×900 design, there is other waye In the

System section enter 2 for warp, and 3 for weft. Enter 1200 in the Warp feld, and 900 in the Weft feld. Click

OK. Program frst scales the image to 600×300 pixels, and then multiplies it by 2 in warp directions, and by 3 in

weft directions to achieve fnal size of 1200×900 pixels.

Figure 229: System option

 

9.4.7 INSTANT CONVERSION

If the Instant conversion toggle button is on, then the program calculates and redraws the Jacquard weave

after every single change of the weaves in the weave selection area,  so you don't have to click on the  OK

button. You mostly need this feature when you shift weaves for one point for getting nicer or more regular

boundaries between warp and weft satin weaves.

9.4.8 KEEP WEAVE SIZE

If you enable the  Keep weave size  toggle button, then the size of the jacquard weave (written in the  Warp

text box and the Weft text box in the Jacquard conversion window) stays the same after loading a new image.

Otherwise, the size is reset to the size of the loaded image.
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9.4.9 POINT TIE SIMULATION

Instead of simply repeating the pattern side by side, you can, using special harness on a loom, mirror design to

create a symmetrical design, which appears twice as wide. The image is just a half of design, because mirroring

is done on a loom.

If you want to see the simulation of a fabric, as it will be woven, switch the Point tie simulation toggle button

on, and enter the hooks (threads) order in the  Point tie simulation feld. In Figure  230, we have 300 hooks,

which are mirrored into repeat size of 598 hooks. The point tie simulation should be written as 1-300 299-2.

You can have also more complicated settings.

Figure 230: Setting the Point tie simulation

 

Figure 231: Point tie fabric simulation

 

9.4.10 FIX SATIN

Sometimes, using two opposite satin weaves (warp and weft efect) doesn’t give desired resulte boundaries

between two weaves are jagged or uneven. You may try the  Fix satin option, maybe you will  get a better

result.

9.5 GRAYSCALE SHADING

When you are using grayscale shading, you only need to load one weave, even if you have many shades in the

image.  Image  should  be  in  grayscale  mode,  which uses  up  to  256 shades  of  gray.  You  can  convert  both
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indexed-mode (8-bits per pixel) and true color (RGB) images to grayscale, either in ArahPaint or in Jacquard

conversion (Images > Mode > Grayscale).

Figure 232: Converting image to grayscale mode
 

Then load one weave, which must have exactly one black point on each weft and at least on black point on

each warp. Any weft satin weave will do the job. Choose Shading as a type of conversion, choose the direction

of  adding points  ( ),  you  can modify a  brightness,  and click  OK.  Program  transforms  image  into

Jacquard weave.

Figure 233: Grayscale image to weave conversion
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You can adapt the level of brightness in the generated weave with modifying the line  in

the  brightness  tool.  To alter  the  brightness  line,  click  one  of  the  little  squares  that

indicate control points of the line, and drag it to the desired location.

Please note, that the brightness change will not afect the image itself, it will manifest

in  the generated weave. Every time you change the brightness, apply the conversion by

clicking  the  OK  button  (or  just  have  the  Instant  conversion  enabled  –  program  will

recalculated the weave every time you move the control point of the brightness line).

9.5.1 COMBINING GRAYSCALE AND NORMAL JACQUARD CONVERSIONS

You can use grayscale shading in some parts of the image, and normal weave insertion on other areas. Type of

conversion should be Shading. For “gray part” of the image, ArahWeave constructs a weave, based on loaded

weft weave, but for the rest non-gray colors, you have to load a weave for every color.

Figure 234: Grayscale shading, combined with "normal" Jacquard conversion

 

9.5.2 DOUBLE OPTION

The Double option enables creation of two color shading efect on fabrics, which have only weft threads on the

surface. Generally it means blanket fabrics with two weft system. Warp is completely hidden in the middle of

two wefts, and is usually quite thin with respect to the weft; it does not contribute to the color efect at all.

The frst step is to set a warp and weft pattern, with one color in warp, and two colors in weft, using alternating

weft change 1a 1b. The two weft colors should be contrasting, usually light and dark, while the warp color is

unimportant, since it will be invisible in the fnished fabric.

Then select Random shading as the type of conversion and enable the Double toggle button. Load a one layer

weave, which fulflls  the criteria for grayscale shading (one point in each line; satin weave). ArahWeave will

construct  a  double layer Jacquard weave from this input weave. You can set  the  Offset  parameter,  which

determines the number of threads, for which program shifts the backside weave in respect to face weave.
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Figure 235: Random shading for blankets

 

Figure 236: The detail of double shaded fabric
 

Figure 237: Face and back of the shaded fabric
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9.6 COLOR SHADING

During training of designers with experience in textile printing and with little weaving background, we often

get requests likee “I draw a red fower and a green leaf on a blue sky, so how do I get these colors in fabric?”  Then

we know we have a bumpy road ahead. We start all the talk about warp and weft colors, density, multi-layer

weaves,  how  you  can  only  have  colors  which are  present  in  the  warp  or  in  the  weft,  assuming  you  have

constructed the weave in the correct way. We were haunted by this problem for a long time, but there was

always something more important to do. And after 7 years in business, several lucky factors met (a little break

from customers’ requests, a programmer who understood weaving and weaver who twisted the weaves until

his head was spinning) and we came up with a solution.

9.6.1 HOW DOES IT WORK? 

ArahWeave calculates the color efect of every weave, currently loaded in the jacquard conversion window. The

color depends on weave, warp and weft pattern, and yarn colors. Then it shifts every weave in all directions to

generate new weaves – colors. When ArahWeave calculates all possible weave combinations, it examines the

image, and replace color pixels in the image with most appropriate weaves, based on color similarity.

Example in Figure 238 presents the most simple case – just one weave in the Jacquard conversion window.

Figure 238: Color shading conversion

Fabric has 4 diferent yarns in warp, and four diferent yarns in weft. Weave structure will force only one warp

and one weft  thread at  a  time  (out  of four)  is  on the fabric  surface.  Thus sixteen diferent  weaves /  color

combinations are possible (warp1-weft1, warp1-weft2, warp1-weft3....warp4-weft3, warp4-weft4)).

Table  shows  the  basic  weave  (bordered  with  red  line)  and  its  derivatives.  Weave  derivatives  are  created

internally  by  ArahWeave  –  program  shifts  them  left  to  right,  and  up  and  down  to  get  all  possible  color

combinations, and you don’t need to load them into Jacquard conversion window. Then save the fabric, which

now becomes your template fabric for color shading.
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warp1-weft4 warp2-weft4 warp3-weft4 warp4-weft4

warp1-weft3 warp2-weft3 warp3-weft3 warp4-weft3

warp1-weft2 warp2-weft2 warp3-weft2 warp4-weft2

warp1-weft1 warp2-weft1 warp3-weft1 warp4-weft1

Then load the picture, which you want to weave, in the Jacquard conversion window. The picture must be in full

color – 24 bits per pixel, for example in JPEG image format. If you load a palette image in the jacquard conversion

window (also called indexed image or color-mapped image), you loose the weaves which are intended to do color

shading. If you load an indexed image by mistake, just reload the fabric template again.

The next step is to specify the desired weave size,  which usually  depends on the numbers of hooks of your

jacquard. Enter the number in the Warp feld, and click the Density button. The number of wefts is calculated

from  the  fabric  density,  which  has  to  be  set  in  the  Set  weaving  density window  (Fabric  >  Density  and

control).

Diferent options are on the right  side of the image. They determine the transformation of the image into

fabric.

First you have to choose whether the program should use Dithering technique to reduce number of colors in

the image to match the number of weaves,  or not.  Dithering is  a technique used in computer graphics to

create  the  illusion  of color depth in images with  a limited  color palette  (color quantization).  In a  dithered

image, colors not available in the palette are approximated by a difusion of colored pixels from within the

available palette. In Arahweave’s color shading, the number of colors is equal to the number of weaves.

If you decide not to use dithering, there is the Noise option, which makes smoother color transition between

shades. The value goes from 0 to 99 (Figure 239). There is no rule, which technique works better (dithering or

non-dithering), you can try both, check the fabric simulation, and choose which one will go into production.
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Figure 239: Fabric on the left was made with noise option set to 0, on the right noise was set to 40

The other options aree

• Reinforcee with reinforce turned on, the program makes additional weaves from the base ones to achieve

even more color accuracy. This option will only work on some weaves, not all weaves are suitable for use

with this option.

• Flat to fate sometimes you want the text labels or borders in color shading to remain unafected by the

noise, which is usually added to the picture to achieve a smooth shading. If the Flat to fat button is turned

on, the program will search for areas of fat color in the true color image and will not apply any dithering

noise in that area. The fat color areas must have perfectly equal color, not just visually equal with small

diferences inside (as it would result from a JPEG image). This parameter is also saved in conversion and

fabric fle. Note that this option does not yet work together with Dithering option.

• Warp / weft color ratioe you can specify the relative importance of warp and weft efect in the calculation

of color shading weaves, expressed as %. Default value is 50, that means that the importance of warp is

equivalent to that of the weft. If you have colored yarns in warp, and black and white yarns in weft (as you

would in a tapestry), by putting the parameter to 60, the program will calculate more colorful (saturated)

weave  colors,  and  a  normal  image  with  largely  mid  tones  will  be  desaturated  in  the  fnal  shading

rendering. Inversely, if you put the parameter to 40, weft will become more important, the program will

calculate duller (less saturated) weave colors, and in the color shading conversion, the program will pick

stronger weave colors, resulting in a more saturated fnal rendering.

• ,  If you don't want to use shifted weaves in your color shading fabric, uncheck these options.

If you are using tapestry weaves, you normally don't want to shift the weaves vertically (because of the

binder thread), only horizontally (where all warps have the same yarn count).

Then click the  OK button to start  the transformation. You can save a fabric fle and use it  latter as a color

shading template.

The only remaining task is to remove the foat errors and save the Jacquard fle. Figure  240 shows the input

image, and the resulting fabric. Normally  we use more than one basic weave, so the result  should be even

better.
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Figure 240: Image and fabric simulation

 

The algorithm itself is fexible, and is not limited to 4 warp 4 weft systems, or to one particular weave system,

neither to these particular warp and weft colors. In fact, it is a good practice to change warp or weft colors into

colors which are actually  present in the image, and you get  even more accurate  color rendering. To check

which RGB colors are present in the image, move the mouse over the picture and look in the upper right corner

of the window, where they are displayed. Write down the colors you think are most signifcant for your image,

and change your yarn colors into these colors, and click on the OK in the conversion window one more time. Of

course, for a weaver, it s much easier to change the weft colors.

9.6.2 COLOR SHADING WITH TAPESTRY WEAVES

Figure 241 shows color shading with tapestry weaves. We expect better results, since we use more weaves in

the Jacquard conversion. Warp tapestry weaves should be shifted just in horizontal direction (  ), because

normally you have yarns with diferent yarn counts in weft, so shifting them vertically would produce wrong

weaves. 

Figure 241: Image for color shading and the resulting color shaded fabric simulation

9.6.3 LOADING / SAVING ALL WEAVES

Sometimes you need to load more than one hundred weaves in the Jacquard conversion. There is a tool to load

them all  at once. Use  Load all from the  Choose weaves menu, and program will  load all  weaves from the

current weave directory into Jacquard conversion. This means you must navigate the weave browser to the

desired directory, before calling this function.
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From the same menu, you can use  Save all, in order to save all weaves from Jacquard conversion to current

directory.

9.6.4 REVERSE SHADING

The  Reverse  shading function  enables  you  to  check the  internal  picture  of  the  color  shading conversion.

Choose Tools > Reverse shading, and program changes the initial true color image into palette image, which

consists  of colors,  defned by currently  loaded weaves in the jacquard  conversion window. The size  of the

palette image is the size of the jacquard weave, divided by warp repeat and weft repeat. In Figure  242, the

jacquard weave size is 2400 by 1188 points. Program will internally use an image of 400 by 396 pixels, because

the weave system is six threads in warp, and three threads in weft (400x6=2400; 396x3=1188). One pixel in the

image represents six warp threads, and three weft threads, and its color is calculated based on these threads.

Reverse shaded image is easier to understand than fabric simulation, so it is easier to notice any irregularity or

wrong colors. If you fnd color pixel in the image, whose color efect you don't like, or you think is wrong, just

click it. It will select the corresponding color (and weave) in the weave selection area of the window. You can

then modify the weave, or even delete it from Jacquard conversion. If color shading uses less than 256 weaves,

the reverse image is 8 bit palette image, otherwise it will be a true color image (but it will use a palette of more

than 256 colors). 

Figure 242: Reverse shading – a tool to check correctness of color shading
 

To go back to true color image in the Jacquard conversion, click the undo icon  in the window’s toolbox.

9.6.5 SHOW COLOR GAMUT

The Show color gamut function helps to predict the result  of color shading. It has three viewing modese it

shows colors of the image, colors of the weaves, and overlap one over another to easier see how colors from

weaves match (or usually mismatch) colors of the image.

9.6.6 REMAP YARNS - JACQUARD CONVERSION

The Remap yarns function from the Tools menu of the Edit warp and weft pattern window enables you to

change all  weaves in the jacquard conversion by shifting the treads. It is useful if you have a set of weaves

made for particular warp or weft pattern, but then for some reason you change the pattern. So you would need

to change all weaves to follow thread pattern, but it is faster if you do this in the Jacquard conversion window

by using the Remap yarns function.



  www.arahne.si  A r a h W e a v e  

User Guide 

  1 1 9

9.7 EXTRA WEFTS

This means that you will use several wefts, but only on places, where you need them for the color efect. This

technique requires  the use of regulator,  or diferent weft  densities.  When the regulator  is active,  the warp

beam does not advance, and we efectively double the weft density on that point of the fabric. Of course, the

weaves must also be appropriate – we must “force” the picks to go on top of each other by using appropriate

weaves. For example, weft satin for the pick that needs to be at the top, and warp satin for the pick that needs

to be on the back. 

Set Extra wefts as a type of conversion, using a button on the lower left area of the window.

Figure 243: Jacquard conversion; extra weft mode

 

9.7.1 LOADING WEAVES INTO EXTRA WEFT JACQUARD CONVERSION

After you have set all the parameters, you have to load weaves. Every color in the picture requires  System’s

number of weaves. The weave area of the  Jacquard conversion window is divided into Number of colors by

Number of wefts (system) felds. There is also one additional weave row, which shows the combination weave

for every color. Figure 244 shows weave display area from Figure 243; you have to load three weaves (because

we set System (number of layers to 3) for every color in the image – one weave for every weft.

To load a weave into weave area, select it with left mouse click, and load a weave from the fle dialog, or from

the Browse window.
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Figure 244: Extra weft weaves

 

After you load all the weaves, click OK and you will get the full jacquard weave.

Program will multiply the weft size by number of wefts, but will be smart enough not to insert weaves where

they are not necessary. At this point, you arrive at the fnal size of weave. The program automatically writes

the correct weft pattern and puts the regulator (Looms advance (take-up) the fabric after each weft insertion.

on  places  where  we  have  extra  weft(s)  looms  have  to  stop  for  extra  weft  insertion.  This  is  controlled  by

regulator.) on the appropriate positions. To display simulation with correct density on regulator, the Density

from technical  data in the  Density window or in the  Consumption window should be enabled (number of

threads in fabric width, reed number, reed width, and denting should be correct, otherwise the simulation will

be wrong!).

Figure 245: Simulation on face and back of the fabric

Sometimes you change the weft pattern after Jacquard conversion. If you repeat conversion for some reason, for

instance you want to change one of the weaves, the program overwrites your old weft pattern. To get it back just

click two times the undo icon  in the weft section of the Edit warp and weft pattern window. Or use function

explained in Chapter 9.7.3.

9.7.2 PARAMETERS OF EXTRA WEFT CONVERSION

There are ten new parameters on the right side of window, which enable you to control and get desired resulte

1. Systeme means the number of layers – in most cases it is a ground plus number of extra wefts.

colors from image

ground weft weavese 

weft yarn a

frst extra weft weavese 

weft yarn b

second extra weft weavese

weft yarn c

resulting weavee  

combination of all 

three weaves
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2. Always parameter tells the program, how many wefts you want to have in a ground fabric. For instance, if

you you set the Always parameter to 3, program takes the frst, second and third weft to form a ground. So

the second and third weft (which are extra wefts by their function) are used also to form a ground fabric. If

the  Always parameter  is  set  to the same number as the  System parameter,  then the program set  the

regulator to 1 (it means no regulator at all).

3. Minimum works a little diferent than  Always; while Always means the number of wefts used in ground

fabric, the  Minimum option declares number of wefts (ground +extra) in one insertion, so the number of

ground wefts may vary (depends on the number of extra wefts in one insertion).

4. Ground layout is powerful feature for setting diferent densities (number) of wefts in each layer. If the feld

is empty, than program takes simple order of wefts, like ground weft, 1st extra weft, 2nd extra weft, ground

weft, 1st extra weft, 2nd extra weft and so on (as it is a default, you don’t need to write it in the Ground layout

feld; empty feld simply  means the layout  of 1234..).  Figure  246 shows ground and two extra  wefts  in

simple order 123 (ground weft, 1st extra weft, 2nd extra weft), and more complex ground layout, written as

1213, where 1 means ground, 2 and 3 are extra wefts (so order is ground weft, 1st extra weft, ground weft,2nd

extra weft).

Figure 246: Simple ground layer, and two ground wefts per layer (ground weft is yellow)

Ground layout can also be written with repeats and parenthesis (similar as thread pattern), to allow extremely

complex irregular extra weft insertion.

5. Ground patterne by default, program puts the weft yarn a in the weft pattern as a ground weft. But if you

write a custom ground pattern, then the program will use it instead of the default one.

Figure 247: Fabric at the left uses default ground pattern, repeating yellow weft a; fabric on the
right uses 2a2b pattern for the ground weft; in both cases the extra weft is the blue one.

6. Skip facee  you can set  the closest  point  of binding point  at  border of extra  weft  efect  to get  smooth

borders. If you set Skip face to 3, then the closest binding point would be 3 points away from border.

By default, this feature works also on the ground weft on areas, where it is on the face of the fabric. If this is

undesirable, mark with a letter "Z" the weft-efect weave of the ground weft, which makes it leave the weave

as it  is,  without applying any of  the smart extra weft parameters (skip face, skip ground,  …).  For detailed

description with images, see Chapter 9.8.2.
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7. Skip grounde same as skip face, just it works on ground weft. It has additional option Always (it is a button

next to the Skip ground feld)– if it is enabled, then the function works between all wefts; if it is disabled, it

works just between extra wefts.

8. Skip back: same as skip face, just that it works on extra weft backside weaves.

Figure 248: Rectangular motif, made by extra weft conversion; the image at the left shows motif made with all
parameters set to 0; “errors” at the edge are circled in red; the image in the middle uses Skip face set to 2, and one

at the right was made with Skip face 2, Skip back 2

9. Clear facee It doesn’t put any binding point if the length of weft passage is shorter than declared Clear face

value. If it is longer than value, then the program does nothing. 

10. Attach at lengthe to prevent long foats at the back of the fabric, which sometimes occur due to summing

up foats, you can set, what is the maximum long foat of extra weft.

11. Protecte sometimes it is necessary to continue with a few extra threads, even if they are not needed for

motif;  they just  prevent the last  thread in design to slip.  Figure  249 shows same design,  made without

protect threads, and with three protect threads.

Figure 249: Protect function in extra wefts

9.7.3 GETTING A GROUND PATTERN FROM A MODIFIED WEFT PATTERN

When you apply an extra weft jacquard conversion, ArahWeave writes a weft pattern automatically. If you later

modify a weft pattern manually, this change may be lost, if you for some reason, apply a jacquard conversion

again. So it is a good practice to store a modifed ground weft pattern for future use in the fabric in case, you

would apply a jacquard conversion again. To do this, click the bulb icon  next to the Ground pattern title,

which extracts a ground pattern from a complex weft pattern, and writes it  into the  Ground pattern feld.

When you will apply a jacquard conversion on that fabric next time, it will use stored ground pattern, and you

will not need to modify it again.
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Figure 250 shows a fabric, that we got after converting an image into jacquard

weave. The weft pattern consist from two weft threads, a light green yarn a,

and an extra weft – a dark green yarn b. The pattern is quite simple and was

written automatically by jacquard conversion.

Figure 250: After converting
an image into jacquard weave

Now we manually,  or  by drawing or typing, modify the patten.  We got the

fabric, displayed on Figure 251. On some areas, the ground weft a was replaced

with weft c and weft d.

If we need to change a weave for particular color in the image and apply the

jacquard conversion again, we will loose the thread pattern, that we have just

edited, because the jacquard conversion’s automatically generated pattern will

overwrite it. But there is a tool, which prevents this. After you have modifed

the weft pattern, store it in the jacquard conversion windowe click the bulb icon

 next to the  Ground pattern title, which extracts a ground pattern from a

complex weft pattern, and writes it into the  Ground pattern feld. When you

will  apply  a  jacquard  conversion  on that  fabric  next  time,  it  will  use  stored

ground pattern, and you will not need to modify it again.

Figure 251: After manual
modifcation of the weft

pattern

9.8 ADVANCED EXTRA WEFT CONVERSION CONTROL WITH YARN LETTERS

9.8.1 DEFINE YARNS IN JACQUARD CONVERSION WINDOW

By default ArahWeave takes the frst weft yarns from Edit warp and weft pattern to write weft pattern; if your

System is 3, it will use yarns a, b, and c. If you want use diferent yarn, just select extra weft weave feld in the

Jacquard conversion window, and press desired yarn letter on a keyboard. A small rectangle in that particular

yarn color and yarn letter will be drawn in the upper right corner of extra weft weave. The program will use that

yarn instead of default one. If you choose wrong yarn, just press the Escape key on the keyboard, and program

will remove yarn color letter from the weave selection area.

This function has a powerful extension. Let say that you want to have second line of roses in Figure  245 in

diferent colors, and want to achieve this without time consuming editing. You just need to paint that roses in

diferent colors in the image, and defne yarns for these new colors. In Figure  252 the ground weft will be in

default color a, weft for green color will be b, for red color c, and for two new colors, orange and blue, will be

wefts d and e.
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Figure 252: Defning yarn colors in Jacquard conversion window

 

Figure 253: Simulation with two extra wefts in four colors

 

Figure 254: Same jacquard conversion as on Figure 252 but without yarn letters produces fabric with only
two colors in extra weft.

 

9.8.2 DISABLING EXTRA WEFT CONVERSION PARAMETERS

Program applies parameters, which you set for extra wefts (Skip face, Skip ground...) to all weft efect weaves

that  you  use  in  the  jacquard  conversion.  But  sometimes  this  is  undesirable.  To  disable  the  extra  weft
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conversion parameters for particular weft weave, put a letter Z in that weave (select a weave area, and press a

Z key on the keyboard; to remove the letter from the weave area, sellect it, and pres the Escape key on the

keyboard). ArahWeave will leave the weave as it is, without applying any of the extra weft parameters.

Figure 255: Letter Z in the ground weft disables the
extra weft conversion parameters for that weft in

white color region of the image
 

9.8.3 EXTRA WEFT AS A WARP EFFECT WEAVE

ArahWeave writes  extra  weft  pattern  based  on  the  weaves,  that  you  defne  in  the  Jacquard  conversion

windowe the weft efect weave (it  has more than 2/3 of “white” points) on the particular color of the image

means that you want to have extra weft on that color area. If you need to insert an extra weft, which has only

warp efect weave across the whole weft, you have to “tell” to the program, that you want to have it even if it

doesn’t meet Arahweave’s standard for extra weft. To do so, specify the weft yarn letter on the warp efect

weave, and in this way the weave will  be treated as a weave which you want to be present in the jacquard

weave as an extra weft. Areas with that weft will not be removed from the fnal weave. This works both in fl

coupe as in extra weft, and is mostly useful for curtain fabrics.

9.8.4 STITCHING WEAVE AS A WEFT WEAVE

The extra weft is stitched to the ground of fabric in places, where is not required for forming fgure. Normally

the stitching weaves have warp efect so that  extra weft appears on the back of the fabric. If you put weft

efect weave for stitching weave, the program treats it as an extra weft in that color area, and puts the weft

across the whole area, usually the ground of the fabric. But if you want to have it only where it is needed for

designing purpose, mark the stitching extra weft weave in the ground with the letter  Z. Now the program

knows, that you want to have it only where is needed for designing purpose.

9.9 FIL COUPÉ

Literally translated from the French, it means “cut threads”. The technique is similar to extra threads, except

that extra threads in fl coupe fabric, where are not in the function of design, are cut of with a special machine.

Generally it is a design with extra wefts and some modifcations, and back attachment weave is all foats. The

main modifcation is the weave border around the fl coupe weft efect (normally plain weave), which prevents

pulling the threads out of the fabric during cutting process.

Parameters System, Always, Ground layout, Skip face, Skip back, Attach at length have the same meaning

as in the Extra weft chapter. Beside Protection, which has diferent meaning than in Extra weft conversion,

there is new numerical feld  Coupe length, and three option toggle buttonse  Fil coupe on face,  Protection

always, and Double.
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Figure 256: Fil coupé jacquard conversion

 

9.9.1 PROTECTION

Protection has diferent meaning then in the Extra weft conversione it is the number of points of the border

weave, which the program will insert on the left and right side of the extra weft fl coupe efect. Border weave

can be specifed individually for every weft. Program automatically adds new color (gray) for protection weave.

In the weave display area of the Jacquard conversion window the border weave color tab is on the rightmost

position (ffth color in Figure 256).

9.9.2 FIL COUPÉ AND EXTRA WEFT IN SAME FABRIC

If you want to have fl coupe fabric, where some threads are fl coupe, and others are normal extra wefts, put

empty  (full  weft)  weave  on  protection,  and  that  weft  will  be  treated  like  a  normal,  to  the  ground  fabric

attached extra weft thread, not as fl coupe weft.

9.9.3 COUPÉ LENGTH

Coupé length means that areas shorter than this length will be attached to the ground, and longer ones will be

left foating and latter cut of.

9.9.4 FIL COUPÉ ON FACE

Fil coupé on face enables you to have the long foat of the coupé thread on top after jacquard conversion. In

this way, the cut-of threads efect will be on the top, together with the weft efect. This is sometimes used for

the curtains,  or when some funky designers likes fl-coupé efect and wants  it  on top. The side efect of fl

coupé on top is that the Attach at length parameter is ignored, since program would otherwise stitch the fl

coupé threads to the fabric at the middle of the foat. This option is also saved in conversion fle and in the

fabric.
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9.9.5 PROTECTION ALWAYS

It means, that the program will put protection weave on all border, even there, where technically speaking it is

not necessary (on threads, which will not be cut due they are too short and are attached to the ground), but

design will look more regular.

Figure 257: Fil coupé Protection always – of and on

9.9.6 DOUBLE

In the areas, which are too short for cutting, the program automatically inserts attachment weave instead of

the full foat (Figure 258). But on some fabrics, which need to be extra light, or are partially transparent, this is

not desirable, as threads, which are too short to cut, shine through the fabric. In this case, use the  Double

option (to enable this option, the Protection always button should be set to on). Program will divide this weft

into two wefts, putting one part of the fabric on one weft, and other part on another. As a result, all areas are

long enough for cutting, so there is no need to attach weft to the back. Obviously, you need even more wefts

than on normal fl coupé, so your fabric is more expensive.

Figure 258 shows a fl coupe fabric with normal settings - inside the circle, where the foats are too short, the

program stitched the weft threads to the ground weave. But with the Double option, the program divides each

weft thread into two thread – one for left part, and one for right part.

Figure 258: “Normal” fl coupe, and fabric created with the Double option

 

The simulation shows that there is no diference in the shape of motif in fnished design, except that all the

unnecessary threads were cut in the, made with the Double option on.



1 2 8    C h a p t e r  9  

 C o n v e r t i n g  i m a g e  i n t o  J a c q u a r d  we a v e
www.arahne.si   

Figure 259: Fabric simulations of “Normal” fl coupe fabric, and fabric created with the Double option

9.9.7 FIL COUPÉ SIMULATION

ArahWeave  can  simulate  fl  coupé

fabric. In the main ArahWeave window

choose Fabric > Simulation. Select the

Fil coupe tab, and enable the Fil coupe

toggle button. The  Pullout  parameter

determines length of the thread, which

stands  out  of  fabric,  after  the  thread

has been cut.  You  can vary  this  value

between  0  to  60;  the  unit  is  a  weave

point.  The  Cutoff parameter  sets  the

length  (from  0  to  30)  of hairs  coming

out  of  the  fl  coupé  yarn’s  end.  The

Angle parameters  declare  at  which

angle the hairs are coming out of yarn’s

end. The Probability option (0-100) sets

the  amount  of  hairs;  the  higher  the

value is, the hairier look on the edges will be.

In the Consumption window you can check the diference in weight of the fnished (cut-of) fabric with respect to

uncut.

9.10 WEAVE BLANKET

9.10.1 OVERVIEW

Sometimes even experience doesn’t help to predict, what

the  color,  or  texture  efect  of  particular  weave  on

particular  fabric  will  be.  It’s  been  a  long  time  weavers

practice  to  weave  a  sample  fabric,  made  of  diferent

weaves, as a decision making weave selection tool. Each

weave  section  has  a  name  or  number  woven  for  a

reference.

Figure 260: Fil coupé simulation

Figure 261: Weave blanket
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9.10.2 CREATING WEAVE BLANKET

To create a Jacquard weave blanket, load any indexed (8-bits per pixel) image into the Jacquard conversion

window, and choose Weave blanket as a type of conversion.

There are fve general settings in the Weave blanket conversione

• Filename  weaves Program  automatically  includes weave fle name  in the each weave section. So, you

need to choose  a  weave for flename  letters,  and a  weave for the fle  name  background. Both weaves

should be same type as the weaves, which will  be included in the weave blanket. To load weaves, open

Browse from  the  Choose  weaves menu  of  the  Jacquard  conversion window.  In  the  Browse window

navigate to a directory, where the weaves you want to weave, are located. Load a weave for background in

the frst color tab, and a weave for letters in the second one.

• Number of weaves You have to decide how many weaves will be included in the Weave blanket. This is

done by setting the number of columns in the Horizontal feld, and the number of rows in the Vertical feld.

Program takes weaves from the current directory displayed in the Browse weaves window. If the weaves,

which you want to weave, are in separated directories, you have to put them in one directory.

• Title size Choose the number of wefts, which will be used for flename in the Title height feld. 

• Top edge Enabling it, you add some wefts (doubled title height size), woven with the weave for flename

background, creating space for cutting the woven piece of the loom. You can customize this extra space by

company name, batch number, whatever, which you type in the feld below the Top edge box. 

• Weave  blanket size You need to set  the number of warp ends (hooks) in the  Warp feld, and the weft

threads in the Weft feld. 

Figure 262 shows example, which has 2400 warps, and 2160 wefts. The weave blanket will have six columns,

and twelve rows, so there will be 72 weaves woven in the weave blanket. The size of one weave will be 400

warps (2400e6), and 270 wefts (2160e12). There will be 36 wefts used for flename titles. At the top, there will

be “Made by ArahWeave” title.

Figure 262: Weave blanket conversion

 

Then you need to select the weave in the Browse window, which will be the frst weave in the weave blanket

fabric (in the bottom left corner). 
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Figure 263: Weave browser - color view mode

 

Then just  click  OK in the Jacquard conversion  window, and the program will  generate the Jacquard weave

according to your specifcations. Figure 264 shows the weave blanket simulation. All that remains to be done is

to make a Jacquard fle for the loom and actually weave it.

Figure 264: Weave blanket simulation
 

9.11 IMAGES MENU

The  Jacquard  conversion window has several  tools  for handling images.  They are  accessible  through the

Images menu in the Jacquard conversion window.
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9.11.1 GET IMAGE FROM WEAVE (BLACK AND WHITE)

In  ArahWeave it is possible to make the image from the current weave. Draw or load a weave in the Weave

editor, treat it as an image, and put it in the Jacquard conversion window by using function Get image from

weave from the Images menu. Then insert the weaves as in the normal two color image. This is very handy to

make damask fabrics or napkins without drawing picture in ArahPaint.

9.11.2 FREE IMAGE

If you do not want to save image in the fabric fle release the image and weaves from the Jacquard conversion

window by choosing Free image.

9.11.3 PRINTING IMAGE WITH JACQUARD WEAVE SELECTION

You can print image with weaves and colors from Jacquard conversion window (usually  for documentation

purpose).  Choose  Images  > Print picture.  In the  print  picture  dialog box (Figure  265)  you have to set  the

borders and the size of printout.  If you choose the  One repeat option,  the program will  ft  the image into

determined space. Figure 265 shows the Print preview of image with color and weave selection.

Figure 265: Print preview from Jacquard conversion

 

9.12 TOOLS MENU

9.12.1 GETTING WARP/WEFT PATTERN FROM IMAGE

See chapter Errore Reference source not found.

9.12.2 MULTI IMAGE CONVERT

As the  name  suggests,  the  Multi  image  convert enables  conversion  of  several  images  into jacquard  fles

within one batch.

Load a template fabric, which has jacquard conversion (image and weaves) already saved in a fle. You can use

Multi image convert with a  Normal conversion or  Color shading conversion. If you do  Normal conversion

(palette images - 8-bits per pixel), we advise you to use same color palette (same colors) in all images, and you

should turn on the Reload jacquard weaves only to equal colors option in the Weaving tab of the Save setup

window. This option forces to program to load same weave into same color, so unwanted weave mapping to

similar  colors  will  be avoided. The number of  colors  in  the  palette  images  should  not  be bigger  then  the

number of colors in the image of initial fabric. Otherwise, the program doesn’t know, which weave to use for

the extra colors, so you receive the error message, and conversion is canceled.

You also need to load the loom layout in the Save cards for production window, for the loom on which you

plan  to  weave  the  jacquard  fles.  Then choose  Tools  > Multi  image  covert from the  Jacquard  conversion

window.



1 3 2    C h a p t e r  9  

 C o n v e r t i n g  i m a g e  i n t o  J a c q u a r d  we a v e
www.arahne.si   

Figure 266: Jacquard conversion with Multi image convert dialog box

 

There are four possibilities of fxing jacquard weave size with respect to image sizee

• Nonee program uses image size for jacquard weave size

• Densitye  program  sets  the  weave  width to  the  number  of the  hooks in  the  Warp feld of the  Jacquard

conversion window, and calculates the number of wefts based on the density of the initial fabric

• Keep  weave  sizee  program  resizes  images  to  match  both  Warp and  Weft number  in  the  Jacquard

conversion window.

• Multiplye program will  multiply image size with the  System parameter from the

jacquard  conversion.  This  will  enable  you  to  use  multiple  image  conversion  on

diferent image sizes, as long as they ft on the same loom layout.

The other options aree

• HTML reporte program creates HTML report with images and fabric simulations, so you can check the result

before real production. You can also use it to document your production schedule.

• Weaving programe if  you use Staubli  JC4, JC5, or JC6,  ArahWeave can create a weaving program, which

specifes the order of weaving, and how many repeats of each design should be woven.

• Fix foats  face  and back fxes  long foats  based  on  a  margins  set  in  the  initial  fabric  before  it  creates

Jacquard fles. If the option is on, but the foat margins are not set in the Float window, the program will cancel

the conversion. You can either to set the foat limits, or to turn of the Fix foats face and back option.

• Create  new directorye  ArahWeave creates  new directory  for storing Jacquard  card fles,  with  the name

specifed in the above feld. By default, the program flls this in with current date.

• Date will write today’s date in the upper right edge of HTML report

Use  Browse or  Load  image to  load  images  into

the Multi image convert window. You can load up

to  50  images.  Image  loader  prevents  loading  of

images, which are not suitable for currently chosen

type of conversion – if you use Normal conversion,

then you can load only indexed images (8-bits), if

you  use  Color  shading,  you  can  load  true  color

images. Image flenames are on the left side. The

middle text feld contains the Jacquard flename. It

is automatically flled in from the image name, but

you can change it, since sometimes looms do not

accept  long  flenames.  If  you  weave  one-piece

designs,  you  can  tell  the  program,  how  many

pieces you want to weave, and type this information on the right side of the window. If the image flename is of

the form xyz_4.jpg, then program will  automatically  fll  in weaving of 4 repeats.  To change the number of

Figure 268: Images loaded into Multi image convert dialog
box

Figure 267: Setting the
Multiply parameter
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pieces for weaving you can also point the mouse to the numeric feld, and use wheel mouse to change the

number. Then click OK, and conversion will start.

If everything is correct, the program writes OK after every flename, and closes the window. You can observe

the progress, as the program is processing the fles. The Jacquard fles are saved at the location defned in the

Save cards for production window.

If the HTML report option is on, the default browser opens and displays the report (Figure 269).

Figure 269: HTML report of multi image conversion in Firefox browser

9.12.3 GETTING IMAGE FROM WEAVE (REVERSE JACQUARD)

The Get image from weave function is an extension to Weave editor’s Replace selected weave (see chapter

4.9). It helps you to get the color image from the Jacquard weave (card image), if you want to use the image

for assigning diferent weaves,  or to resize  it  to diferent fabric quality.  In main  Arahweave’s window open

Weave editor, use middle mouse button to draw selection in the weave (or use parametric mode  Change >

Select/copy area), which you want to replace. Selection must include at least one complete weave repeat.

Then choose Jacquard > Replace selected weave . If your weave replacement mask is satisfactory, click on the

Get image from weave button in the Replace selected weave window. This opens the Jacquard conversion

window, and puts in the image with the same size as the Jacquard weave. The mask is replaced by a solid color,

while the other weaves remain in black and white.

If you wish, you can select another weave in weave editor, make a replacement mask by clicking the OK button

in the Replace selected weave window, and then use Get image from weave again. Each time you extract a

weave  into  color  in  this  way,  the  weave  is  also  copied  in  the  weave  selection  window  of  the  Jacquard

conversion window.

From the Jacquard conversion window, you can save the color image (Images > Save image as). To get rid of

the black and white points from areas, which could not be correctly attributed to one of the weaves (due to

complexity of the image, or long foat correction), edit the image in ArahPaint4, and then save it again. It is a

good practice to keep the same colors as the one which ArahWeave has created in generation of jacquard color

image,  so  you  can  reuse  the  original  color  to  weave  assignment.  You  are,  of  course,  free  to  change  the

jacquard image colors, but you will have to reassign the weave afterwards.
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Figure 270: Get image from weave

 

Note that this function must not be confused with Guess image from weave in the Images menu of the Jacquard

conversion. Guess image from weave is a function which tries to guess everything in one step - all the weaves,

even if they do not have the complete repeat. Probably it tries to accomplish too much, so it does not work well in

many  cases.  Using  the  combination  of  Replace selected  weave and  Get  image  from  weave,  you  help  the

computer identify the individual weave areas and number of weaves, so it gives more accurate results than Guess

image from weave, but it needs a repeat of all the weaves to work properly. Additional advantage of  Replace

selected  weave approach  is,  that  it  also  correctly  handles  diferent  weaves,  which  give  the  same  fabric

appearance, like S or Z twill or satins. Guess image from weave works back from the simulation, and is unable to

distinguish between those weaves.

9.13 WEAVE PEN IN JACQUARD CONVERSION

If you click with middle mouse button on the fabric in the main  ArahWeave window, then the warp (black)

point is changed into weft (white) point and vice versa. But if the Jacquard conversion window is open, then the

middle mouse button draws in the fabric with currently selected weave in the Jacquard conversion window.

The size of drawing area is 3 by 3 points. If you keep the Shift key pressed during drawing, the drawing area size

is 5 by 5 points. So you can sign the jacquard fabric, or do fne tuning on weave junctions. But remember that

those changes will be lost if you re-apply the jacquard conversion.

You can also use the weave pen to draw with selected weave color directly in the image. You can also do this

with middle mouse button. This is intended only for minor corrections, when you discover some stray spots at

the last moment, and do not want to go back in ArahPaint4 to correct them. So you can do this directly in

ArahWeave. These changes will be permanent, as they will be saved within the image in the fabric fle. So you

can re-apply jacquard conversion without losing data.

9.14 LOADING AND SAVING JACQUARD CONVERSION

This function from the Conversions menu in the Jacquard conversion window enables saving the parameters

of jacquard conversion – association of weave to color, and the type of conversion.

if you keep one color palette, you can draw many pictures and use same jacquard conversion on them. During

loading of jacquard conversion, the program loads the weaves into the places of the corresponding colors. It

can work in two diferent wayse

1. Default modee program loads the weaves into the equal colors, or if there are not exactly same colors, the

program maps the weaves to the similar colors.

2. Program  loads weaves  only  to  exactly  same  colors.  If you  load the  image,  which has  diferent  palette

(diferent colors) than the currently loaded Jacquard conversion, then the weave tabs will  remain empty
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(without weaves). To enable this mode, you have to switch on the Reload jacquard weaves only to equal

colors option (Save setup > Weaving).

The loading and saving of the parameters  of jacquard conversion lost  some  importance,  since  ArahWeave

saves the conversion data and image, from which the jacquard weave is created, in the ArahWeave fabric fle.

10 WEFT BLANKET

10.1 INTRODUCTION

The weft blanket is unique ArahWeave's tool, which enables combination of diferent fabrics into one weaving

fle. From input fabrics it creates a new fabric by generating variants from yarns and in the fabric length you

specify. You can use it as a tool fore

• Designing;  you  can  use  the  Weft  blanket tool  for  creation  new  designs,  since  you  can  fast  and  easy

combine parts of diferent fabrics into a new design.

• Sample production; joining more fabrics into one fabric (weaving) fle means, that you can produce them

all in one step, without stopping a loom to change a weaving fle.

Figure 271: Weft blanket from three diferent fabrics; seven
variants are generated and woven as a single fabric. Program

can add woven title between variants.  

10.2 EDITING WEFT BLANKET

To open the weft blanket editor, choose Blanket > Weft blanket.
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Figure 272: Weft blanket editor (no fabrics loaded yet; default settings)

10.2.1 GENERAL SETTINGS

General settings in the Weft blanket editor aree

• In the Fabrics feld, enter the number of fabrics, that you want to use for weft blanket creation. To load a

fabric into Weft blanket editor, choose Fabrics > Browse (or Load). Editor displays fabrics, which will form

the weft blanket, in the frst column of the icon display area; the f irst fabric is at the bottom of the window.

Figure Errore Reference source not found shows three fabrics in the Weft blanket editor.

• Weave Xe by default, the value is set to 0 (zero). It means, that the weft blanket's weave width will have the

same width as the wider fabrics in the selection. But if this width is not wide enough (usu sally if the title

writing is too long), you have the possibility to manually declare the width of the blanket weave by setting

the number of ends, used for weft blanket creation.

•  The Double option enables splitting of each weft in the weft pattern on two wefts during loading of

the fabric. In this way, you can create richer color variations without modifying the fabric you have load for

weft blanket creation. 

•  It enables the 90-degrees rotation of the fabric during loading in weft blanket. In this way, you can

exchange warp and weft in sampling, to avoid preparing complicated warps just for sampling.

•  If enabled, the selected fabric input feld jumps to the next one, as you load a fabric into currently

selected feld. By default it is on, but you can change it and save setup according to your desires.

•  To apply the changes without clicking the OK button, mark the Instant conversion box.

• In the Yarns feld, enter the number of yarns, that you will use in the blanket. We use 4 diferent weft yarns

in the blanket in Figure 273.

• In the Separating yarn feld, enter the yarn pattern (usually only one color) of the border between versions

(leave it empty, if you don’t want to have a border). Twill is the default weave for border, but you can change

it – choose Weaves > Browse from the menu bar, and load a new weave into the Separation feld.

• Name – mark the toggle button, if you want to have a woven title – fle name or custom text and used weft

yarns – in the border between sections.  For this, you would need at least  2 centimeters or 1 inch of the

separating area. You can also change the weave for fabric’s fle name letters; load it into the Title weave

area (double click opens the weave browser; you can also use ArahWeave keyboard shortcuts for entering

weaves).

•  You choose the position of the woven name with top/bottom button.

Figure 273: General settings and the fabric specifc settings in the Weft blanket editor
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10.2.2 FABRIC SPECIFIC SETTINGS

Fabric specifc settings aree

• In the Variants feld, enter the number of variants, that you will weave for specifc fabric. Each fabric may

have its  own number of variants.  In Figure  Errore  Reference source not found, the frst  fabric has three

versions,  the  second has  four  variants,  and  the  third  one  has  two  variants.  Variants  icons are  created

automatically. The frst variant of the frst fabric is marked 1A, next is 1B, and 1C. The starting weft of each

variant  is  written  next  to name (2C @3441 means the third variant  of the second fabric starts  at  weft

3461).

To change yarn, click the yarn tab with left mouse button, and copy it with the right mouse button to the

desired place.

Figure 274: Weft blanket editor with loaded fabrics and variants, which are generated from the input fabrics
and specifed weft yarns. The fabrics icons are displayed in the frst column and the variants icons are placed

next to them.

• In the Length feld set the woven length for each version. The length unit can bee inch, centimeter, meters,

number of picks, number of repeats. Variants of same fabric have same length.

• You can change the starting point of version by changing First warp, or  First weft. This is very handy for

shawls, if you have several shawls which you want to compose in a new one, where you pick diferent areas

of diferent designs to be put together in a new design.

• Switch on the Continue toggle button, if you would like to continue weaving of next color variant from the

last woven weft of the previous variant. In this way, if you have large jacquard motif, you can show both the

complete motif and all the color variations, all in one small sample.

• If you want to mirror the original fabric, click  to mirror horizontally, or  to mirror it vertically. It is

very useful for creation of symmetric shawls, using the previously saved partial fabrics.

• If you want to invert the fabric to weave it with a face down (usually fl coupe fabrics), there you have the

Invert button . Program remembers the state of invert and mirrors buttons, and it is saved in the blanket

fle.
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• If you enable the Custom text button, you can enter text in the text feld below the setting area. This text

will be woven in the separating area between two variants. There are few additional functions, which add

naming and numbering to the titlee

$Ge It adds the flename of main fabric (a fabric, which is used as a “template” on which the weft blanket is

created.

$Fe It adds the flename of a component fabric.

$Ne  Type  $N001  to  the  custom  text  to  have  the  auto-incremented  number  for  variants  inside  one

component fabric. For example, if you enter $N01, program will insert 01 for frst variant, 02 for second, and

so on.

$Me Type $M001 to the custom text to have the auto-incremented number for all variants.

Figure 275: Automatically generated text from the fabric flename, the component fabric flename, the
variant number, the general variant number and used yarns: $G $F $N01 $M01. In this way, the samples

passed to the customers do not need a written tag, which may detach or get mixed up. Customer can
read the woven header and you know exactly which design and color variant they have ordered.  

10.2.3 WEFT BLANKET AS A DESIGN TOOL

Weft blanket editor is also a unique and powerful design tool, and some of its settings makes combining more

designs into one new design fast and efective operation. Typical use of this tool is when you need to combine

several fabrics which are quite diferent by nature, for example terry border, terry top/bottom selvedge, and

terry ground design. The main power of of weft blanked is in the ease of changing the length of sections, after

the design has been made. Often you make a complex fabric, where fnal length cannot be fully predicted in

the design phase, due to complex weaves, yarns and fnishing. So you need to weave a sample, fnish it, and

only then you decide to prolong/shorten certain areas, based on customer's required length.

• You can change the starting point of version by changing First warp, or  First weft. This is very handy for

shawls, if you have several shawls which you want to compose in a new one, where you pick diferent areas

of diferent designs to be put together in a new design.
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• Switch on the Continue toggle button, if you would like to continue weaving of next color variant from the

last woven weft of the previous variant. In this way, if you have large jacquard motif, you can show both the

complete motif and all the color variations, all in one small sample.

• If you want to mirror the original fabric, click  to mirror horizontally, or  to mirror it vertically. It is

very useful for creation of symmetric shawls, using the previously saved partial fabrics.

• The Pattern option lets you write the weft blanket as a weft pattern, of two or more fabrics. It is useful,

when you have same fabric, repeated at diferent places in the weft blanket, and you would need to load it

into weft blanket editor as many times as fabric occurs in the weft blanket.

Figure 276 shows weft blanket, which is made of two fabrics. In the “normal” editing mode, you would need

to load two fabrics in the correct order, the violet fabric 5 times, and the green fabric 4 times, of course in

correct order. But if you switch to the Pattern mode, you need to load each fabric only once. In the Pattern

feld you have to write a weft blanket as a patterne 90a 102b 90a 102b 194a 102b 90a 102b 90a  ,

where a means frst fabric, and b means second fabric. Numbers beside letters mean the number of wefts

from each fabric. If you need to change the height of particular  fabric band, just  change the number of

wefts, click OK, and you have a new design.

Figure 276: The pattern option in the weft blanket editor: from two input fabrics we have created new design.

10.2.4 KEYBOARD NAVIGATION AND SHORTCUTS IN WEFT BLANKET EDITOR

• Alt + click in the weft blanket fabric opens the weft blanket editor (if it is not already opened), and selects

the icon of the version in the weft blanket editor, from which the clicked section was made. This feature is

very useful, when we want to modify an old weft blanket, composed from many fabrics, and we can't fnd

right variant in the weft blanket editor.

• Double mouse  click on the variant  icon changes the position  of scroll-bar in  the main  window,  so that

variant becomes the frst one at the bottom of the window, so you can easy fnd it.

• Alt + mouse wheel roll over blanket fabric in the main window adds or removes (depends on direction of

rolling) threads from that particular variation, where the mouse pointer is. It also works, if the weft blanket

editor is  not opened. Data  in the weft  blanket editor are updated, as you roll  the wheel.  If the Instant

conversion is enabled in the Weft blanket editor, the fabric is changing as you roll the mouse. If not, then

you have to click the OK button to apply the changes. 

• Pressing the Insert key adds a new fabric in the Weft blanket editor, if one of the fabrics (leftmost icon) is

selected (you can achieve the same with Tools > Fabrics > Add). If variant is selected (second, third, ... icon

in horizontal), then variant is duplicated and you can edit it as a new variant ( Tools > Variants > Add).

• Pressing the Delete key removes selected fabric or selected variant from the Weft blanket editor ( Tools >

Fabrics > Remove or Tools > Variants > Remove).

• You can navigate between variant icons, fabric icons or yarns using the arrow keys.
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• Instead of copying yarn from the yarn bar to the variant yarn, you can position to that particular variant

yarn, and change it by pressing a corresponding letter key on the keyboard. For instance, if you want to

replace the yarn a with yarn c, select the yarn a, and press the c key.

10.2.5 SAVING THE WEFT BLANKET FABRIC

When you click the  OK button, the program merges all  variants  into one fabric,  writes  new  weft pattern,

regulator, and other variables (weft density,  warp tension,  loom speed,  selvedges,  terry variables) if they

exist in the input fabric fles. You can save it as a new fabric. 

10.2.6 EXTRACTING A VARIANT FROM THE WEFT BLANKET FABRIC

If you need to get particular variant from the weft blanket fabric, select the variant in the weft blanket editor,

and choose Tools > Extract fabric. The program pulls out the weave, weft pattern and regulator of that fabric,

with proper weft color remapping. Save it with a new fle name.

11 VARIANTS

ArahWeave enables you to create variants of same fabric design, and save them into single fabric fle. Variants

difer from each other only by used yarns and colors. To open the Variants dialog window, choose  Blanket >

Variants…

Figure 277: The Variants dialog window

11.1 SETTING THE TYPE AND NUMBER OF VARIANTS

There are four diferent types of variantse 

   Weft – you edit just the weft yarns.

   Warp – you edit just warp yarns.

   Warp & Weft – you edit both warp and weft yarns independently.

   Warp = Weft – warp and weft yarns are same; as you edit warp yarns, same 

applies to weft yarns.

As you increase the number of variants, the last variant is copied to the new one. If you later (during editing)

decide that you need more (or less) variants, you can simply change the number.

Figure  279 shows the Variants dialog, where we have changed the number from 1 to 4. We got four equal

variants. Now we can edit them one by one.

Figure 279: Setting the number of variants in the fabric

Figure 278: Choosing
the type of variants
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11.2 EDITING VARIANTS

You can modify variants by pasting colors from color libraries, or by loading yarns from the yarn browser. The

ArahWeave's copy/paste method with mouse (left click to select, middle click to exchange, right click to paste)

also works inside the Variants dialog.

11.2.1 PASTING COLORS FROM COLORS DIALOG

If you want to modify only colors and not yarns in the

Variants,  use  the Colors  editor.  Set  the  number of

variants and type, and open the Color dialog (Fabric

> Colors). Click the  Variants tab, which displays all

colors  used  in  the  fabric  variants.  You  can  start

copying colors from currently opened color library to

variants.

As  you  click  (select)  color  in  the  variant,  that  variant  becomes  selected  and  displayed  in  the  main  window.

ArahWeave's title bar also shows the number of the selected variant. Please note that ArahWeave displays only

one variant (selected one) at the time in the main window. If you want to review all variants at ones, use the Print

preview (more about this latter in the Chapter 11.3).

Figure 281: Displaying selected variant  

Figure 280: Editing variants in the Color editor
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11.2.2 LOADING YARNS FROM THE YARN BROWSER

By double clicking on variant yarn, you can open yarn browser and load the yarn into variant. 

The window is split into two parts. The left part lists all yarns from the default yarn directory. On the right side,

there is a list of colors associated with currently selected yarn.

If you want to have displayed all colors from your library In the Browse yarns window, you need to export colors

to XML format (from the Edit colors window choose  File > Export colors in XML). The exported color fle is

available next time when you restart ArahWeave.

Figure 283: Exporting colors in XML 

 

11.2.3 PROTECTION - PREVENTING ACCIDENTAL MODIFICATION OF VARIANT

When you add new variants  to already designed variants  you  may want  to  prevent  them  from  accidental

modifcation. To do this, just enter the number of variants which should be protected in the Protection feld in

the Variants menu bar.

11.3 PRINTING VARIANTS

Choose File > Print fabric to printer…  to open the Print dialog. Mark the Variants check-button to access the

Print fabric  to printer:  Variants  window. Here  you decide the  form of printout  (number of rows (Fabrics

Y)and columns (Fabric X)) and position of titles (for details about titles and positioning of them, please see

Chapter 17.8 about multi-fabric printing).

If you want to print just some of the variants, select them by double-clicking the variant's number. The number

gets the asterisk mark *, which means that it is in a selection. We have selected for printing four out of six

variants in Figure 284.

Figure 282: Loading yarns from the yarn browser
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Figure 284: Printing variants

 

Check the print preview before printing. Or you can use the print preview just to display the variants side by

side and review them.

Figure 285: Preview of the variants printout

 

12 OVERPRINT, CHINÉ, IKAT, SEERSUCKER SIMULATION

12.1 OVERPRINT

You can simulate printing over a woven fabric in ArahWeave. Open ArahWeave and load (or create) a fabric, in

which you want to use the overprint function. Choose Fabric >Simulation. In the Simulation window click the

Overprint tab.

To load the image (usually the image, that is used for screen printing), click the Browse button, and load the

image into Simulation window. In most cases, you load just one image into the Warp feld. In very rare case of
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double or compound ikat fabrics (both warp and weft yarns are dyed prior weaving with diferent patterns) you

load also an image, which represents the used weft dye pattern, in the weft feld.

The image for overprint is usually in the indexed (8 bits per pixel) mode, so that you have option to control

which color is transparent (the background color of the image). 

Figure 286: Loading image into simulation window

The program draws the image over fabric, as if  it  was printed. With  Zoom you can control  the size  of the

overprint image.  Strength controls the color strength (transparency) of the overprint (at 100% it covers the

fabric completely). In the Transparency feld you specify the number of the color in the image (you can see the

color palette and color numbers if you load the image into ArahPaint), which is not printed. The transparent

color of sample in Figure 287 is white color (note that the counting is started with 0 and not 1 - the frst color in

the image is marked as 0).

Figure 287: Overprint simulation

Figure 288 demonstrates the same image printed at diferent Strength levels.

Figure 288: Overprint strength levels: 100%, 80%, 60% and 40%
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The  option  Overprint  fabric  transparency  is

useful for simulation of printing over transparent

fabrics,  like  curtains  for  example.  The  holes

between  the  threads  are  covered  or  left  empty

depending  on  the  type  of  dyes.  If  the  option  is

switched  on,  the  program  draws  the  overprint

image  on  the  space  between  yarns.  Figure  289

demonstrates the Overprint fabric transparency.

12.1.1 PRINTED WARP, IKAT, CHINÉ SIMULATION

The overprint simulation window has some other options, which allow you to simulate even more exotic stuf.

First of the three advanced functions in the overprint window gives you the possibility to specify which yarns in

the fabric are not printable.  This allows simulation of fabrics with printed warp, ikat  fabrics (warp, weft, or

both), and even fabrics, which are made from yarns with diferent fber composition and thus diferent dye

afnity. 

Figure 290 shows the input fabric, consisting of white and blue yarn, and the output fabric after printing. A dye

which is used for printing, has no afnity to fbers in blue yarn, so you have to state them as Unprintable in the

Simulation window (letter b in Warp and Weft). 

Figure 290: Unprinted yarns

The Ikat option for warp and weft allows you to simulate the overprint image distortion (feathered edges of

the pattern), which is characteristic of techniques, where the warp, weft or both are tie-dyed or printed with a

pattern before weaving, to create a design on the fnished fabric.

Figure 289: Overprint fabric transparency: of and on
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Figure 291: Chiné simulation

In  ArahWeave's simulation, the value of ikat efect is specifed as the number of pixels of the printed image.

The higher the value, the bigger the distortion.

A  closer  look  at  the  previous  simulation  shows  you  how  ArahWeave  makes  the  chiné  simulation.  On  the

sample the ikat value is set to 12 in the warp direction – it means that the borders of print will vary randomly

from 0 to 12 pixels.

Figure 292: Zoom in chiné simulation

The  Ikat  simulation  works  best  in  the  combination  with  the  Dye  absorption function.  It  determines  the

absorption of dye over the edges of the printed motifs. This depends on the yarn material (fber), type of dyes

and  printing  technique.  It  can  be  set  independently  for  warp  or  weft,  and  it  is  expressed  in  tenth  of  a

millimeter.
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Figure 293 shows a simulation with Dye absorption set to 0, while the simulation on the right was generated

with Dye absorption set to 35.

Figure 293: Dye absorption

12.1.2 SIMPLE WARP IKAT PLAID

The following image shows the setup for warp ikat, where only the warp yarn with letter d was printed (or dyed

/ painted) prior to weaving. So all the other yarns (abc, which form the border design on the left) are set to be

unprinted. 

Figure 294: Warp ikat

 

12.1.3 SIMPLE WEFT IKAT PLAID

Weft ikat is more difcult to make, since the start of each pick (weft yarn) must be aligned to the edge of the

fabric. Usually, this is impossible in industrial weaving, due to the nature of weft insertion. But a skilled hand-

weaver can do it.

Figure 295 shows a fabric and the settings for weft ikat. Only the weft letter d is left printable.
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Figure 295: Ikat weft plaid

12.1.4 CHANGING COLORS OF THE OVERPRINT PICTURE

To change colors in the overprint picture, open the Edit colors dialog (Fabric > Colors), and click the Overprint

tab. There is a color palette of the overprint image. From the ArahWeave palette select a color, and copy it

with the right mouse button over the overprint image color.

In same way you can copy or exchange color chips of the overprint image.

Figure 296: Changing the overprint colors

12.1.4.1 PRINTING COLOR CHIPS OF OVERPRINT IMAGE

If you enable the Overprint button  in the Print fabric to printer dialog, the colors from the overprint image

will be printed in the lower left corner of the simulation.
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Figure 297: Color chips of overprint image
 

12.2 SIMULATION OF WRINKLES

Wrinkle is another fabric fnishing feature, available in the Simulation window. It allows you to load any image

and use it as a gray wrinkle map. If the image is not gray-scale, it will be automatically converted to gray-scale.

As in overprint, you can also specify the zoom and intensity levels. Wrinkle works diferently from overprint, as

it takes the color from underlying fabric, and modifes its lightness according to the wrinkle picture/texture. To

load  the  texture,  click  the  browse  button,  and  from  the  image  browser  load  the  texture.  Program  will

automatically fgure out the base gray level of the loaded picture, and will  make the fabric both lighter and

darker. The program's fnishing simulation works in sequence, so you can have both overprint and wrinkles.

You can also specify the non wrinkable yarns, which allows you to make a realistic seersucker simulations.

Figure 298: Simulating the seersucker fabric

To make simulation even more realistic, you can set the Displacement function, which will curve the threads

according to the wrinkle texture and the value of displacement parameter. 
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Figure 299: Simulating the seersucker fabric with Displacement function

13 FABRIC PROPERTIES

The  Properties window  allows  you  to  enter  lots  of

diferent information for the fabric. You can access this

window from the ArahWeave menu bar through Fabric >

Properties or by using the keyboard shortcut Ctrl+I.

There  are  two  types  of  text  felds  in  the  Properties

windowe

• ordinary text felds—you enter the data

• drop-down  menu  text  felds—you  enter  the  data  or

choose  it  from  the  drop  down  list.  The  list  is

confgured  with  custom  codes  and  values,  using

external  XML  fles,  which  you  add  to  your  XML

directory. 

You can specify (among other things)e

• For  which  customer  the  design  was  made  (a  list  is

taken from ArahneCustomerImport.xml).

• which fnishing was applied (you can choose it  from

drop-down  menu;  a  list  in

ArahneFinishingImport.xml,  or  as  set  of  toggle

buttons) 

• type  of the  fabric  (as  free text  description or set  of

toggle buttons)

• which designer did it (ArahneDesigners).xml

• from which design was the actual design derived 

• status of the fabric (is it just a trial or real production) 

• division (when company is divided in diferent plants or market/product groups)

• name, quality, design, version, season—these entries are also used for automatic fabric name generation

for saving fabric data in HTML format and for title of printed fabric simulation.

•  the product availability—the scissor sign can be also printed on the fabric simulation to show, that

fabric is already in stock 

Figure 300: The Properties dialog
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14 FABRIC TECHNICAL DATA CALCULATION

The technical data and calculation of yarn consumption is accessible as the Consumption menu entry from the

Fabric menu. You should have previously set the yarn counts in the Yarns section.

The Calculation of thread consumption window is divided into two partse

• gray with entry felds for fabric technical data

• white, where the calculated and data from other windows (colors, thread pattern) are displayed

You must enter the requested parameters and click OK to see the results of calculation.

14.1 NUMBER OF THREADS, REED NUMBER, REED WIDTH

Number of threads in fabric width is the most important fabric production parameter, besides weft density.

You can enter the number of  Threads in fabric width by yourself,  or  better,  enable button  Density  from

technical data (you can also enable this button in the Density window), and the program calculates it for you

from Reed width and Reed number (and Denting - ends per dent), which you set in the Edit weave window).

The Number of threads feld changes from entry feld into grayed-out feld, so you know you can no longer

enter this number. The number is rounded to an integer number of dents, because it is nonsense to have dents

“half full”. If you have denting 3 threads per dent, then number of threads will be a multiple of 3.

Figure 301: Calculation of number of threads from reed number and reed width with
Density from technical data option on

 

If  you  disable  Density  from  technical  data you  can  use  another  way  to  calculate  the  Total  number  of

threads, Reed width and Reed number (as you know these values are interrelated). You can change any of

these  felds  (Threads  in  fabric  width feld  becomes  red  to  indicate,  that  one  of  the  values  should  be

recalculated – it is up to you which one).

Figure 302: Calculation of number of threads, reed number and reed width

 

Then click the bulb icon   next to the feld which you want to calculate. The value will  be calculated from

other two. In Figure 303 we calculated the Reed number. It is changed from 10 to 8,5. The Threads in fabric

width feld changes from red to default color which indicates, that all three values are correct.
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Figure 303: Pressing the Bulb icon at the right side of the Reed number feld
calculates the Reed number from the number of threads and the reed width  

14.1.1 CALCULATING THE NUMBER OF THREADS AND REED NUMBER FROM DENSITY

You can calculate Threads in fabric width and Reed number from the Set weaving density window. Finished

width and Reed width should be set to desired values. Then choose Fabric > Density. Set the warp density,

and click  icon. Required number of threads in fabric width and the reed number for requested density will

be calculated in the Calculation of thread consumption window.

Figure 304: Calculating the number of threads in fabric width and the reed number from the warp density

14.1.2 DENTS

Instead  of  Threads  in  fabric  width you  can  use

Number  of  dents  in  fabric  width.  You  have  to

change  the  program  setting  by  choosing  Help  >

Save  setup.  In  the  Save  setup window  click  the

Weaving tab  (Figure  305),  and change  the  option

button from Reed width -> Dents to Dents -> Reed

width.

14.2 FABRIC WIDTH

At the top right edge of the window, you enter the basic fabric widthse reed width (pattern only, no selvedges),

raw width and fnished width. This is necessary, if you want the program to calculate the fnished density for

you. If you do not have these data, you must enter the density by yourself in the Set weaving density window

(Fabric > Density and control).

14.3 FABRIC (OR WARP) LENGTH

Depends on your preference, enter the Fabric length, for which you want to calculate the consumption, and

program will calculate needed warp length. If you prefer to start with warp length, so the program calculates

the fabric length, change the setting in the Save setup window.

Figure 305: Choosing the input unit for  fabric width and
consumption calculation - number of threads in fabric

width or number of dents in the reed width
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With the  Fabric  length  -> Warp length  option

button  you  choose  either  the  Fabric  length or

Warp length is your input in the  Consumption

window.

Figure 307: From warp length to fnished fabric

The raw fabric length is warp length reduced by the take-up. The take-up is diference in length between the
warp length and the length of fabric just taken of the loom.

RawLength(m)=
WarpLength(m)∗(100−TakeUp (%))

100

The fnished fabric length is raw fabric length reduced by fnishing shrinkage.

FinishedLength(m)=
RawFabricLength(m)∗(100−FinishingShrinkage(%))

100

Figure 308: Calculating the warp length
 

Figure 306: Choosing either Fabric length or Warp length

Finishing shrinkage
Finished fabric length

Raw fabric length
Take-up

Warp length
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14.4 WEFT DENSITY

There are three kind of weft threads densitye

• Weft density on the loom (number of weft thread insertions per length unit) – you have to enter it

• Weft density of the raw (gray) fabric - calculated

• Weft density of the fnished fabric - calculated

14.4.1 WEFT DENSITY ON THE LOOM

Weft density is the density, set on a loom. It is the only one of three weft densities, which you have to enter in

the Calculation of the thread consumption window.

14.4.2 WEFT DENSITY OF THE RAW (GRAY) FABRIC

The  Weaving  shrinkage variable  determines  the  Density in  the  Raw  fabric.  It  depends  on  loom  setting

generally – – warp and fabric tension, used weaves, material, and causes the diference between the density

on the loom (weaving density) and density in the raw fabric. The weaving shrinkage is part of the  take-up,

and cannot be higher than take-up. The weaving shrinkage unit is percentage (%).

RawWeftDensity (wefts/ cm)=
LoomWeftDensity (wefts /cm)∗(100+WeavingShrinkage(%))

100

14.4.3 WEFT DENSITY OF THE FINISHED FABRIC

The  fnished  weft  density  is  calculated  based  on  Finishing shrinkage,  which  means  the  shrinkage  (or
elongation) of fabric (warp) during the fnishing process.  ArahWeave will  also take into account regulator or
variable weft density when calculating weft density of fnished fabric.

The fnishing shrinkage unit is percentage (%).

FinishedWeftDensity (wefts/ cm)=
RawWeftDensity (wefts /cm)∗(100+FinishingShrinkage (%))

100

Figure 309: Weft density calculation  

14.5 SELVEDGES

You can enter selvedges data in two wayse

• Enter  Selvedge pattern, which is the full

pattern describing left selvedge (right one

is  assumed  to  be  equal),  and  Selvedge

denting.  The  program  will  calculate  the

required number of dents and reed space

for selvedge.

Figure 310: Selvedge pattern and selvedge denting
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• If you want, that selvedges are taken from

the fabric ground, then enter the number

of Selvedge dents and Denting, and leave

the  Selvedge  pattern empty.  Figure  311

shows data of fabric, which has 12 threads

(Selvedge denting by number of selvedge

dents) from ground in each selvedge.

14.6 YARN CONSUMPTION

The  scrollable  window  below  the

technical  data  entry  felds  contains  the

complete consumption calculation. It is in

HTML format, and is equal to the printed

page  of  technical  data.  You  can  save  it

using  function  Save  technical  data  as

HTML  from  the  main  File  menu.  By

default,  it  will  save  it  in  the  data/html

directory.

The data contained in the consumption calculation should be pretty obvious to anyone, who has calculated it

“manually”  a  couple of times.  There are only a few points that  need further clarifcation. The formulas  for

calculation of consumption are as followse

TakeUp(%) of 2% is assumed to be 1.02

Loss(%) of 2% is assumed to be 0.98

Unit is reported in parenthesis.

ConsumptionWarp(kg )=
TotalNumberOfThreads∗Length (m)∗TakeUp ()

YarnCount(Nm)∗1000∗Loss ()

ConsumptionWeft (kg )=
ReedSpace (cm )∗DensityWeft (threads /cm)∗Length(m)

YarnCount (Nm)∗1000∗Loss ()

Weight (g /m)=
(ConsumptionWarp (kg )+ConsumptionWeft (kg ))∗1000∗Loss()

Length (m)

Figure 311: Selvedge from ground

Figure 312: Yarn consumption calculation
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Calculations of number of threads of each color, total consumption, weight per square meter, etc. are trivial,

and there is no need to go into obvious details.

In the table below the reed information, you have an overview of all the repeats in the fabric. In this way, you

can check if they divide each other as expected, or the total repeat size will be a very big number. Currently,

the repeat limit for the consumption calculation is 65520 threads.

The cover factor for warp and weft is calculated based on weave density and diameter of yarns. It is not an

absolute  value,  you will  learn  with  time  how dense will  the  fabric  be if  the total  cover factor  is  78%.  The

transparency gives you the percent of area with background color in the simulation. The heddles table shows

you the number of threads, which each shaft is lifting.

At the bottom of table, you will also fnd the weight in g/m for each shaft. We assume that each shaft is lifting 1

m of warp, and program reports the corresponding weight. This is useful, when you have yarns with diferent

yarn counts in warp, and in this case the number of threads for each shaft does not refect the true shaft load.

14.7 ADVANCED LOOM CONTROL FUNCTIONS

ArahWeave supports following weft variables (loom control) functionse

• Variable weft density

• Warp Tension

• Loom Speed

• Selvedges

• Terry

• Pile height

• Tension pile

• Tension ground

To enable desired weft control function, open the Set weaving density window, and check the button at the

left side of the option. You can enter data for variable function in two wayse by entering pattern in adequate

text feld, or by drawing the pattern on the right side in the weave editor in the adequate control column.

14.7.1 VARIABLE WEFT DENSITY

Variable weft density is set in the Density window (Fabric > Density and control). You need to mark the Weft

density check box in the Variable feld.

Then in the text feld we type the variable density

pattern. In Figure 313, the density pattern means,

that 400 picks have density a, which we set to 25

picks per centimeter, then 50 picks are woven at

density  b,  which  we  set  to  28  wefts  per

centimeter, then 112 wefts are woven at density

c, which we set  to 34 picks per centimeter,  and

then again 50 picks are woven at density b. The

program  also  calculates  the  total  number  of

wefts  in  the  variable  weft  density  repeat  (612),

and the average weft density (27 per centimeter).

Figure 313: Setting variable weaving density
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Figure 314 shows the

fabric with a variable

density.

Figure 314: Variable density in fabric simulation

Beside the numeric way of entering

variable  density,  you  can  draw  it

with a mouse in the weave editor.

The  variable  density  pattern  is

shown  on  the  right  side  of  the

regulator  column.  To draw  it,  you

have  to  (of  course,  it  should  be

enabled in the Variable feld in the

Set  weaving  density window)

select  desired  color  (letter)  in  the

top right corner of the  Edit weave

window.  As  you  draw  it,  the

parametric  density  pattern  is

updated  in  the  Set  weaving

density window.
Figure 315: Variable weft density in Weave editor

Many times the variable weft density is same

(or very similar) as weft pattern (weft a has one

density,  weft  b another  etc).  In this  case  you

can easy copy weft pattern to the variable weft

density feld by selecting weft pattern text with

left  mouse  button  (it  becomes  black),  and

copying  by  middle  mouse  click  into  variable

weft density feld. This type of copy / past works

among all text felds in ArahWeave. But you can

also  use  standard  keyboard  shortcuts  for

copy/paste: Ctrl+C, Ctrl+V.

14.7.2 GETTING A VARIABLE DENSITY PATTERN FROM A REGULATOR PATTERN

If you want to convert a design, which is made with regulator, to design with variable density, enable  Weft

density in the Variable feld, and click the Density from regulator button. The program calculates and writes

the variable density pattern.

Figure 316: Selecting text in the Edit warp and weft pattern
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Figure 317: Density from regulator

14.7.3 GETTING A VARIABLE DENSITY PATTERN FROM JACQUARD CONVERSIONS

If you uncheck the Regulator button in the Jacquard conversion dialog,

then the program will  calculate and write the variable density pattern

by itself. 

Figure 318: Variable weft density,
written by program

14.7.4 SIMULATE REGULATOR WITH VARIABLE DENSITY

This function transforms regulator pattern into variable density pattern You get only two diferent densities,

one for ground and one for “regulator”  wefts.  (and, in  case,  you have fringe enabled in the save cards for

production window, you have the third density for the fringe).

To use this function, enable the Variable weft density option in the Set weaving density window, and click

the  Simulate regulator  with variable density button.  ArahWeave writes the variable density pattern,  and

draws it in the variable weft density column in the weave editor.
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Figure 319: Simulate regulator with variable density

14.7.5 REGULATOR FROM DENSITY

If you click the Regulator from density button, you can specify the regulator pattern for each density section

in the Regulator from density window. ArahWeave calculates resulting regulator pattern.

Figure 320: Regulator from density
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14.8 SAVING AND PRINTING TECHNICAL DATA SHEET (HTML FORMAT)

Technical  data  can  be  saved  in  HTML  or

XML  format.  To save  technical  calculation

choose File > Save technical data as HTML

in  main  ArahWeave's window. You  will  get

window with many options, which help you

to  customize  your  technical  data  sheet.  If

you want only to save the fle, click on the

OK button, if you want both save and print,

press the Print button. The HTML fle will be

open  in  web browser,  from  which you  can

print.  File  will  have the same  name  as  the

fabric  fle,  the  program  will  add  html

extension.

Figure 321: Save (and print) technical data window

Technical data in HTML format consist of the following elementse

• Fabric quality data

• Warp pattern

• Weft pattern

• Weave

• Fabric simulations

If you uncheck the toggle button at the left side of the segment, than it will not be saved (and printed) in the

HTML fle. Warp and weft pattern have the Vertical option; it means that they can be written in vertical form.

If you like to have background colors of the letters, which mark warp and weft yarns, in the color of that yarn,

mark the Color letters option.

• Fabric  quality  data (number  of  threads,  density,  reed number,  width,  fber  composition  of  the  fabric,

denting, regulator, repeat, cover factor).
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Repeat
Weave

Fil Coupe
Design

Denting

Regulator

Weave

Design
Total

Warp
480

12 Shafts

1

0.02 cm

2

1 Dents

480

12 cm

480

12 cm

Weft 698
698

13.78 cm

698

551

advances

698

13.78 cm

698

13.78 cm

Reed number Reed width Denting Dents

19 / 1 cm 316.00 cm 2 6001

Selvedge 2 x 0.32 cm 1 2 x 6

Total 316.63 cm 6013

Warp length 6497 m

Fabric length 6400 m

Raw width 310 cm

Finished width 300 cm

Density Warp 40 / cm

Density Weft 40 / cm

Average Density Weft 50.67 / cm

Weft Total

Ground

Regulator

698

551

147

Take-up 1.5%

Waste warp 3%

Waste weft 2%

Consumption 1492 kg

Raw weight
227.2 g/m

73.3 g/m2

Finished weight

Fil coupe

210.0 g/m

70.0 g/m2

Composition 

86.92% PL Polyester

13.08% CO Cotton

Cover factor

Warp Weft Total Transparency

62.07% 76.19% 69.13% 12.60%

shaft 1 2 3 4 5 6 7 8 9 10 11 12 

Heddles 1251 1251 1250 1250 100 100 100 100 1650 1650 1650 1650 
g/m 9.8 9.8 9.8 9.8 0.8 0.8 0.8 0.8 12.9 12.9 12.9 12.9 

Drafting: 50(1 - 2 - 3 - 4) 2(5 - 6 - 7 - 8) 66(9 - 10 - 11 - 12) 2(5 - 6 - 7 - 8) 
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• Warp pattern (has also the Vertical option, and if you want to pass only this information to weaving mill,

there is option saving on New page).

Selvedge pattern: 36A

Warp pattern (66x): 1A 2B 3A 3C 3D 8C 3E 7C 3D 3C 3A 2B 1A 48B 

Leftover (36 threads): 1A 2B 3A 3C 3D 8C 3E 7C 3D 3C 

1 a 16-4019 Forever Blue 17/1 tex 470 Z 

2 b 14-0114 Celadon Green 17/1 tex 470 Z 

3 a 16-4019 Forever Blue 17/1 tex 470 Z 

3 c 14-0755 Sulphur 17/1 tex 470 Z 

3 d 12-0106 Meadow Mist 17/1 tex 470 Z 

8 c 14-0755 Sulphur 17/1 tex 470 Z 

3 e 18-1454 Red Clay 17/1 tex 470 Z 

7 c 14-0755 Sulphur 17/1 tex 470 Z 

3 d 12-0106 Meadow Mist 17/1 tex 470 Z 

3 c 14-0755 Sulphur 17/1 tex 470 Z 

3 a 16-4019 Forever Blue 17/1 tex 470 Z 

2 b 14-0114 Celadon Green 17/1 tex 470 Z 

1 a 16-4019 Forever Blue 17/1 tex 470 Z 

48 b 14-0114 Celadon Green 17/1 tex 470 Z
90

Warp
Repeat

threads

Design

threads

Selvedges

threads

Total

threads

Repeat

%

Design

kg

Selvedges

kg

Total

kg 

A 8 532 2*36 604 8.89 5.463 0.739 6.203 

B 52 3434 0 3434 57.78 35.265 0.000 35.265 

C 21 1407 0 1407 23.33 14.449 0.000 14.449 

D 6 402 0 402 6.67 4.128 0.000 4.128 

E 3 201 0 201 3.33 2.064 0.000 2.064 
Total 36+66*90 =5976 +72 =6048 61.369 +0.739 =62.109 

Warp A B C D E 
Count 17/1 tex 17/1 tex 17/1 tex 17/1 tex 17/1 tex 

Composition
60% CO Cotton

40% PL Polyester

60% CO Cotton

40% PL Polyester

60% CO Cotton

40% PL Polyester

60% CO Cotton

40% PL Polyester

60% CO Cotton

40% PL Polyester 
Twists(/m) 470 Z 470 Z 470 Z 470 Z 470 Z 

1
16-4019

Forever Blue

14-0114

Celadon Green

14-0755

Sulphur

12-0106

Meadow Mist

18-1454

Red Clay 

Program  writes  this  table  only  if

the Vertical option is on

Color letters enabled
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• Weft pattern (you can save it in the Vertical form, and on the New page; the letters of the pattern can be 

written in yarn colors)

Weft pattern : 8b 153d 9b 37a 9b 36a 8b 68a 106(1c 1a) 1c 67a 8b 36a 9b 37a

8 b 17-2120 Chateau Rose 

153 d 16-1143 Honey Yellow 

9 b 17-2120 Chateau Rose 

37 a 15-1309 Moonlight 

9 b 17-2120 Chateau Rose 

36 a 15-1309 Moonlight 

8 b 17-2120 Chateau Rose 

68 a 15-1309 Moonlight 

1 c 14-1318 Coral Pink

1 a 15-1309 Moonlight 

106 X

= 212

1 c 14-1318 Coral Pink 

67 a 15-1309 Moonlight 

8 b 17-2120 Chateau Rose 

36 a 15-1309 Moonlight 

9 b 17-2120 Chateau Rose 

37 a 15-1309 Moonlight

698

Weft
Repeat

threads

Repeat

%

Weight

%

Fil coupe

%
kg

a 387 55.44 52.40 0.00 453.130 

b 51 7.31 3.54 8.92 30.623 

c 107 15.33 33.43 37.88 289.117 

d 153 21.92 10.62 0.00 91.869 

Total 698 864.739 

Weft a b c d 

Count 78/1 dtex 4/1 tex 18/1 tex 4/1 tex 

Composition 100% PL Polyester 100% PL Polyester 100% CO Cotton 100% PL Polyester 

Twists(/m) 0 0 420 S 0 

1 15-1309 Moonlight
17-2120

Chateau Rose

14-1318

Coral Pink

16-1143

Honey Yellow 
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• Weave in GIF format

 

• Simulation in JPG formate you have three options heree simulation in actual (real) size, simulation of one 

repeat (if the repeat is too big, the program reduces the zoom so the repeat fts into set size), or both. For 

simplicity reasons, one fle is named fabric_name.jpg and the other is fabric_name.jpeg). You can set 

the resolution in dpi (default is 100 dpi) and both width and height of the simulation size (default is 150 

mm) 
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14.8.1 CHANGING THE DEFAULT WEB BROWSER

Default browser on Open SUSE Linux is Firefox. Firefox will correctly print out page breaks, while some other 

browsers do not support this feature. You can change the browser in ArahWeave's Save setup window (of 

course Firefox should be installed on your system). Choose Help > Save setup, in the Save setup window click 

the Expert tab. Type /usr/bin/firefox  in the WWW browser feld.

Figure 322: ArahWeave's HTML data in Mozilla Firefox
 

15 WARPING

The Warping feature calculatese

• yarn consumption for particular warp

• the number of required cones per yarn color

• the length (weight) of yarn per cone

• the yarn cones layout for  selected warper.

15.1 WARPER CONFIGURATION

First you need to edit or add .warper fle in the /home/capdam/data/warp/ directory. The fle is description of

your warpere

• number of creels

• number of creel blocks

• Order of yarn cones (directions - there are eight possibly directions. ArahWeave uses simple two letters

nomenclature  for thate  frst  letter  means  starting point  (L-left,  R-right,  U-up,  D-down),  and second letter

means direction).
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LD Left Down

RD Right Down

LU Left UP

RU Right Up

UR Up Right

UL Up Left

DL Down Left

DR Down Right

The  layout  of  warper(s),  used  in  the  warp  directory  is  read  at  program  startup  from  location

/home/capdam/data/warp/.warper

The location of the .warper fle can also be diferent, if the path to warp fles, as defned in your .arahne fle, is

diferent. Note that the path to warps must be absolute, not relative. So the line in .arahne fle which defnes

warp location must read

#PATH_WARP=/home/capdam/data/warp

and not simply

#PATH_WARP=../data/warp

You need to edit your .arahne fle manually, in order to fx this.

The structure of .warper confguration fle is very strict. If there are any errors in the fle, the program ignores it

and uses the default warper. The .warper fle must use Unix line endings, not MSDOS (CR/LF). You should use

a plain text editor on Linux (kwrite, kate...), or take care of the fle ending conversion, if you edit the fle on

Windows. The easiest way to edit the fle is to copy text below into editor's window, then edit it, and save it

as .warper (note the dot at the beginning of the name). Or you can contact Arahne ( arahne@arahne.si), and

we will create a fle based on warper's specifcations.

Here is one example of .warper fle contents, explanation follows belowe

#WARPER

#NUM_WARPERS=2

#WARPER_NAME=warper1

#NUM_DIRECTIONS=2

DR

UL

#NUM_CREELS=3

#CREEL_NAME=A

#NUM_CREEL_BLOCKS=6

6x7

6x7

5x7

5x7

5x7

5x7

#CREEL_NAME=B

#NUM_CREEL_BLOCKS=6

5x7

5x7

5x7

5x7

6x7

6x7

#CREEL_NAME=C

#NUM_CREEL_BLOCKS=1

5x7

#WARPER_NAME=warper2

#NUM_DIRECTIONS=1

mailto:arahne@arahne.si
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LU

#NUM_CREELS=2

#CREEL_NAME=A

#NUM_CREEL_BLOCKS=1

24x7

#CREEL_NAME=B

#NUM_CREEL_BLOCKS=1

24x7
The sample fle defnes 2 warpers. You can defne up to 5 warpers, as it is unlikely that a single company would

have more than 5 diferent warpers. Each warper should have a distinct name. Each warper can have up to 5

creels. Each creel can have up to 50 blocks. The dimension of a block can be up to 100. Let's follow the example

and comment ite

#WARPER --- fle signature, just to identify the fle type. Does not have any parameters.

#NUM_WARPERS=2 --- number of warpers defned in the fle

#WARPER_NAME=warper1 --- name of the frst warper

#NUM_DIRECTIONS=2 --- number of allowed directions of flling in the creel with cones

DR --- frst directione begin in upper left corner, and fll in the cones down, and to the right

UL --- second directione begin in lower right corner, and fll in the cones up, and to the left

#NUM_CREELS=3 --- number of creels for frst warper

#CREEL_NAME=A --- name of the frst creel

#NUM_CREEL_BLOCKS=6 --- number of creel blocks

6x7 --- size of creel block, horizontal x vertical

6x7 --- repeat until you defne all the blocks

...

#CREEL_NAME=B --- name of the second creel

#NUM_CREEL_BLOCKS=6 --- number of blocks in the second creel

5x7 --- size of creel block, horizontal x vertical

#CREEL_NAME=C --- name of the third creel

#NUM_CREEL_BLOCKS=1 --- last creel has just one block

5x7 --- the size of the creel block

#WARPER_NAME=warper2 --- the name of the second warper

#NUM_DIRECTIONS=1 --- number of directions on the second warper

LU --- begin in lower right corner, and fll in the cones left, and then up

#NUM_CREELS=2 --- we have just two creels on the second warper

#CREEL_NAME=A --- name of the frst creel of second warper

#NUM_CREEL_BLOCKS=1 --- number of blocks of the frst creel of second warper

24x7 --- horizontal x vertical number of cone positions

15.2 EDITING THE WARP

To edit the warp, choose Fabric > Warping.

You have to enter following datae

• Number  of  sections –  depends on  the  number  of  threads  in  the  width  and  the  warp  pattern  repeat.

Number of threads and the length of the warp are taken from the Calculation of thread consumption dialog.

• Threads – number of yarn cones in one section

• Times - number of section’s repeat

• Filling direction on the creel of warper. Program allows eight flling directions (the letters indicate direction

of frst and second move), which have to be declared in the warper confguration fle. To change the direction,

click on the icon.

The goal of ArahWeave is to allow you graphical specifcation of number of warping sections, relative length of

each section, with the number of repeats of each section. The output of the program is the exact count on

cones for each yarn color and for each length (number of warp repeats).
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Figure 323: The Warping dialog
 

Program  also gives you the graphical  map of cone placement on the creel.  The cone placement should be

taken with a grain of salt,  as intelligent workers may be able to better optimize each individual case. In the

warping window it will also indicate with red or green color, if the number of repeats of each section is correct.

15.3 HTML OUTPUT

There are three options in the warping section of the HTML outpute

• Warp simulatione it creates an image of one repeat of the warp pattern.

• Warp section image adds an image of current warp section, with the unused parts of the warper marked in

black and white check board pattern.

• Cone layout enables or disables cone section layout printout.

In the report of warping section, the program explicitly tells that one section is equal  or mirrors a previous

section, if one section repeats a previous one. If the section is a complete repeat or mirror of another section, it

is not reported in table form to save space in HTML report.



  www.arahne.si  A r a h W e a v e  

User Guide 

  1 6 9

Figure 324: HTML output of warping data

16 CALCULATING THE PRICE OF FABRIC

16.1 NECESSARY INPUTS FOR THE PRICE CALCULATION

You have to input following data in the Price window (Fabric > Price) in order to calculate the fabric pricee

• The price for each yarn used in the fabric (in the Yarns window)

• The cost of warping per length unit

• The cost of sizing per weight unit

• The cost of weaving per number of picks (default unit is 1.000 picks; you can change it in the Save setup >

Units)

• The cost of darning per length unit

• The cost of piece dying per weight unit

• The cost of transport per weight unit

To calculate the fnal price, you have to enter some fnancial ratiose

• the Operating margin (%)

• Financing (%)

• Provisions (%)

• the Commercial margin (%)

After entering the parameters, click OK to get the price calculation.
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Figure 325: The price calculation dialog  

If  you  don’t  use  some  of  the  production  phases,  just  set  them  to zero.  You  can  also  print  out  the  fabric

calculation, if you select it during HTML saving/printout. If you want to have on line price calculation, during

designing, you can enable it  in the  View menu, and program will  display the price in the program title  bar

based on current fabric parameters.

The processing costs which depend on fabric weight, use the raw fabric weight for calculation.

16.2 SETTING THE CURRENCY

To  set  the  currency,  in  which  you  want  to

display the price,  open the  Save setup,  and

enter the currency code in the Currency feld.

Figure 326: Setting the currencyx

17 PRINTING THE FABRIC SIMULATION

ArahWeave always prints a fabric in current View mode and Zoom level. Normally, it is the Simulation view at

100% Zoom. But any other combination is also possible. To print a fabric simulation, select the Print fabric to

printer function from the File menu.

17.1 PRINT SIZE

To control the size of printout and its position on the paper, enter the print

size  (Print width and  Print height),  and position (distance from top and

left border of the paper), in the felds in the  Print size area. To check the

maximum printable area, press the Full page button. If you insert an area

out of range (too big for the paper size),  it  will  be trimmed to particular

printer size and you will be warned with a beep.
Figure 327: The print size dialog
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17.2 SETTING PRINT AREA

The  print  area  starts  from  the  bottom  left  corner  of  the  fabric  in  the  main  ArahWeave window.  You  can

position to desired starting point of printout with program’s scroll bars. So if you want your fabric to be printed

from frst warp and frst weft, position the program scroll-bars in the main window to the leftmost and bottom

position.

Figure 328 shows a fabric with circle motif, the size of motif area is approximately 10x9 centimeters; the red

rectangular indicates the print area. If we want to print a motif, we need to move program's scroll bars to get

the desired print area in the lower left corner.

Figure 328: The red rectangular indicates the print area

In case,  that  you can’t  position desired starting point  of the printout  to the lower left  corner,  because the

current view of the fabric doesn’t require scroll bars, there is additional setting in the  Print fabric to printer

window – coordinates of starting point in fabric. You can set the numbers in two wayse Ctrl+left mouse click in

the fabric, where you want that printout starts, or you can set these numbers manually in the First Warp/Weft

text felds.

Figure 329: Ctrl+left mouse click in the fabric sets the starting point of printout

17.3 PRINTING OPTIONS

The printing option toggle buttons are below the  Print size text felds. Simply, by marking the check box in

front of the option, you include that in the printoute

• Title; you will get extended title with date, user name, customer name (your company) and version of the

program at the top of the page. The printed fabric name is the current fabric flename, but if you enter the

data into the Properties window (Fabric > Properties), then the fabric name is taken from there.



1 7 2    C h a p t e r  1 7  

 P r i n t i n g  t he  f a b r i c  s im u l a t i o n
www.arahne.si   

• ;  You  can  choose  the  type  of  scissors

cute  straight,  zigzag with white background,

zigzag with transparent background. 

• Density;  the  density  of  the  fabric  will  be

written in the title line.

• Yarns; the  yarn  color  tabs  will  be  printed

below fabric simulation.

• Color; you can enable  Code,  Name,  CIE Lab

and RGB values  to be printed in color tab.

• Warp/weft  pattern; you  will  get  warp  and

weft pattern at the bottom of the printout.

• One repeat, as name indicates, will print only

one repeat of the fabric, mostly useful for one

repeat designs (blankets, table linen).

• ;  the  text,  which  you  have  in  the

Registered  design text feld  in  the

Appearance tab of the Save setup window, will be printed (or saved) in the fabric simulation printout.

• ; if you enable it, the program prints a text, which you have entered in the Custom print text feld in the

Appearance tab of the Save setup window, over the fabric simulation.

Figure 331: Registered design text, custom print text and the right side part of the title in the printout
 

• ; if you enable the Overprint button, the colors

from the overprint image (Fabric > Simulation >

Overprint) will be printed in the lower left corner

of the simulation.

Figure 330: Printing the fabric simulation

Figure 332: Color chips of overprint image
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• ; The printout will be divided into halvese one for the face and other for the back of the fabric.

Figure 333: Face and back printout  

17.4 PRINT PREVIEW

When  the  settings  are  correct,  check  the  Print preview.  It

displays simulations exactly as it will be placed on a paper (left

and top ofset). If every thing is on proper place, close the print

preview, and click OK.

Figure 334: Print preview

17.5 PRINTER SETUP

If you want to print to diferent printer or fle, you should

select  Printer setup in the  Print fabric to printer dialog

to  change  printer  settings.  In  the  Printer  setup dialog

(Figure  335),  you  have  to  choose  the  desired  printer  or

graphics fle format, print mode and density (in dpi - dots

per inch). For higher quality printouts use 1440 dpi, but in

most cases 720 dpi is sufcient.

Figure 335: Printer set-up
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17.6 CUSTOMIZING PRINTOUT

17.6.1 LOGO

To change a logo, which is printed in the upper right corner of

the simulation,  you have to replace  logo.gif fle,  which is  in

default folder for saving fabric technical data in html format

(usually  /home/user_name/data/html folder), with your own

logo image fle. It can be in any common graphical format, but

fle name should remain logo.gif.

Figure 336: Logo and website in the printout

17.6.2 TOP IMAGE

Beside logo, you can add a second image on HTML data sheet. It will be displayed at the top of the page. The

fle name should be  logoHTML.gif and placed in the default  folder for saving fabric technical data (usually

/home/user_name/data/html  folder).

Figure 337: Additional image at the top of the technical data sheet.  

17.6.3 WEBSITE

You can have your website address printed near logo. Just type it in the Print www feld in Help > Save setup

> Appearance (please check chapter 20.4 about saving the setup).

17.6.4 TITLE OF THE FABRIC SIMULATION

You can use data from the Properties window (Fabric > Properties) to generate the title of the printed fabric

simulation.  The  HTML  fabric  name  format text  feld  of  the  Generate  flename section  in  Save  setup

(Help>Save  setup)  enables you to declare, which properties are used for auto-generated fabric simulation

title.

The format of fabric name formula has only one rulee the number of feld which will be used in the fabric name,

should stand after the dollar sign ($), which is there to indicate that the used number is the feld number and

not character which would be part of the text. After the feld number you can enter whatever character you

want, like space, slash, hyphen, and it will be used in generated flename.

The text felds in the Properties dialog have following numbering labelse
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Field Label

Division $8, $9  *

Name $1

Quality $2

Design $3

Version $4

Season $5, $6  *

Designer $7

Notes $N

Variants $V

* $8 takes only frst word (anything until the space character) from the division code (or name), while $9 takes

the whole name. Same applies to Seasone $5 takes only frst word, while $6 takes the whole code.

You can use four additional signs for automatic title generatione

Fabric filename $0

Jacquard image filename without suffix ** $I

Scissors *** $@

Directory, in which the fabric is saved $D

** It is a capital letter I.

*** Scissors sign can be print only on multi fabric print, not on single one.

Let’s see an examplee if you have written  $1  $2/ $3 - $4 as a rule in  HTML fabric name format, and have

entered following text in the Properties windowe Overcoat as a Name (Field 1), 117 as a Quality (Field 2), B as

a Design (Field 3), and 12 as a Version (Field 4), then the generated name would bee Overcoat  117/  B – 12.

Figure 338: The fabric properties, which can be used in automatic generated fabric
name, the fabric name rules in Save setup, and generated title on the printout
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17.7 PRINTING MORE SIMULATIONS ON ONE PAGE IN ONE STEP

To print  more  fabric  simulations  on  the  same  page,  without  error-

prone calculation of positioning of the printouts to the available space,

you have a possibility of selecting two more fabrics (to a total of three)

to be printed on the same  area.  Click on the  Fabric 2 button or the

Fabric 3 button in the  Print fabric to printer window. This will  open

the  fabric  browser,  from  which  you  load  additional  fabrics.s.  The

available area will be divided horizontally in two or three equal spaces.

Figure 339: Printing of two fabrics

17.8 MULTI-FABRIC PRINT

There is another possibility to print more fabric simulations at once. In

the  Print fabric window  (Figure  330),  mark  the  Multi-fabric toggle

button.  The  Multi-fabric  dialog  will  pop-up.  (Figure  341).  Set  the

number of fabrics in the Fabrics X and Fabrics Y feld. You can print up

to 8 by 8 fabrics. To load fabrics use Browse window, which you get by

double clicking in the window or by clicking the  Browse button in the

lower left corner of the window. You can set the alignment of fabric

title by changing the alignment option buttons.

To view the Print preview, click Preview in the Print fabric to printer window.

Figure 341: The Multi-fabric print dialog and the print preview

17.8.1 TITLE OF THE FABRIC SIMULATION IN THE MULTI-FABRIC PRINTOUT

Similar to “normal”  printout, the title  of the fabric simulation in the Multi-fabric printout can be generated

from the fabric’s preferences. You can have two titles at diferent position. The idea behind two titles is to

Figure 340: The alignment option
buttons for title positioning
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create something similar to “real” fabric samples, which are usually put on a black cardboard with main design

and few color variants, which can have diferent title than main design.

Figure 342: Multi fabric print with title one and title two

17.9 PRINTING TO FILE (SAVING FABRIC SIMULATION AS A DIGITAL IMAGE)
Instead of printing it, you can save fabric simulation as a digital

image. In the  Print fabric to printer  window click the  Printer

setup button. In the Printer setup window choose the graphical

format, in which you want to save the picture (PNG, GIF, JPEG,

TIFF), and dpi (dots per inch) of the image. Dpi can be selected

independently for width and height of the image. Click the OK

button, and close the window.

In the  Print  fabric  to printer window,  you  have  the

option to select where this fle should be writtene the

Desktop, USB fash drive or the tmp folder, or you can

choose  Browse  to  select  a  destination  from  the  fle

dialog. Then enter a fle name for the image (in Figure

346 it  is sample). The  program  adds  a  fle  name

extension (fle format) automatically. When you close

the Printer setup window, there is new information in

the Print fabric to printer windowe the printer name is

changed to a  chosen  fle  format,  then  there  are  the

pixel density and the size of image in pixels. When you

click the  OK button,  simulation  is  saved as  a  digital

image.

Figure 344: Printing to fle

Figure 343: Printer setup for saving simulation
as an image fle
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17.10 PRINTING TO AN UNSUPPORTED PRINTER

ArahWeave superb fabric simulation print quality is result of custom printer drivers and printer color profles.

Because there are many printers on the market, Arahne can’t support all of them. However, if your printer is

not supported directly in ArahWeave, you can still print from it (of course, it should be supported in the Linux

OS), but the printouts will not have same color accuracy as printed on native supported printers.

To print on printer, which is not listed in the Printer setup window, you should select  TIFF as a type of your

printer. The rest of the procedure is same as with “normal” printer. ArahWeave creates image fle in tif format,

and  your  Linux  print  system  is  properly  confgured,  the  TIFF image  will  be  automatically  recognized  and

converted into printer specifc code.

17.11 SUGGESTED PAPER TYPE

We calibrate EPSON Photo printers using Epson Photo Quality Ink Jet Paper S041061, so you will achieve color

matching results only printing to this type of paper. There is one exception though, Epson Stylus Photo R2400

uses Mate Paper Heavyweight S041256.

17.12 SAVING FABRIC TEXTURE

To save fabric simulation as a texture (image in repeat for use in ArahDrape, for web background etc.) choose

File > Save fabric texture  from the main Arahweave’s window.

Figure 345: Saving fabric texture
 

The fle name is set automatically based on the current fabric name (you can change it, if you want), plus the

sufx from the chosen image format. You can set image format (JPG, PNG, TIFF), dpi - dots per inch; probably

100 to 150 dpi will sufce for most cases, and the number of design repeats.

Program displays the actual texture size in pixels above the fle name, so you have the feel for the size of your

texture. If your fabric repeat is small, and the pixel size is 3000×3000, then your dpi is probably too high. If your

image repeat is very big, you can also lower the dpi to get a reasonably sized fabric texture. Also, if the fle size

is too big, you can choose PNG as a fle format, and mark the 8-bit button to save texture in the indexed (256)

color mode. This will  make much smaller  image, and  ArahDrape will  work much faster,  as it  will  need less

memory.

If you want to save only the warp image, tick the Warp check box next to warp icon .

18 SAVING LOOM (OR OTHER CAM) DATA (CARDS FOR PRODUCTION)

18.1 SAVE CARDS FOR PRODUCTION DIALOG

Arahweave’s  Save  cards  for  production  dialog enables  you  to  save  a  fabric  data  into  any  supported

machinery format (a machine readable fle), which you then transfer by data storage medium (foppy, USB

fash drive) or network to the loom controller, jacquard controller, or to the electronic card punch machine,

warper or drawing-in machine. 

The appearance of the Save cards for production window depends on the chosen machine and a fle format,

as some formats have more options than others. Saving to jacquard format (Staubli, Bonas, Grosse...) means
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the most complex window with hook layout and other settings. If you save a fle in one of the loom (dobby)

formats, a dialog window looks similar as for Jacquard, except it doesn’t contain a hook layout, while a dialog

for saving to drawing-in machine format or warper format basically consists just from flename feld and the

OK button.

Almost all necessary information for creating a CAM fle is taken from the fabric fle, like weave structure, weft

change  pattern,  regulator  and variable  weft  density.  Usually,  you  need just  to  enter  the  selvedge weave,

choose a format, a destination for saving, and a flename. 

Figure 346: Save cards for production window; Jacquard layout
 

Figure 347: The program hides the jacquard hooks layout, if you choose a loom format
 

When  you  fnish  with  editing  various  settings  in  the  Save  cards  for

production window, you can save the loom layout for future use (choose

File > Save loom layout from the menu bar in the  Jacquard conversion

window). To load a loom layout, choose File > Load loom layout, or click

Choose in same menu bar, which displays a list  of saved loom layouts in

the  currently  selected  loom  directory.  The  list  shows  more  information

(format, number of hooks, a fle name) than usual Load fle dialog, so it is

easier to fnd layout you want to use for saving the cards.

Figure 348: List of saved loom
layouts shows more information

than usual Load fle dialog

18.2 SETTING THE NUMBER OF HOOKS (JACQUARD)

The number of hooks is basic information, when you save jacquard card.

Enter it in the Number of hooks feld.

Figure 349: Number of hooks and
Weft bytes felds
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18.3 SETTING THE NUMBER OF ELECTRONIC FUNCTIONS (JACQUARD)
With the  mechanical  Jacquard,  additional  Jacquard  functions (weft  selection,  regulator,  weave  fringe,  pile

loops...)  could only  be controlled  by using  actual  hooks.  Instead  of  these  function  hooks,  most  electronic

Jacquard machines have electronic functions (virtual or electronic hooks), which don’t actually show up in the

head as physical hooks. Bonas controllers always include 32 of these in positions 1..32 (the frst real hook is

#33)  while  Grosse  controllers  optionally  include  64  to  the  right  of  the  last  real  hook.  Staubli  controllers

optionally include 32, positioned either to the right or the left depending on your preferences.

Enter the number of electronic functions in  the  Weft bytes feld next  to the Hooks feld (see Figure  349).

Usually it is four bytes (32 hooks). For exact position of each control bit (hook) refer to your loom and Jacquard

documentation.

18.4 SETTING HOOKS POSITION AND FUNCTION (LOOM LAYOUT)

Usually  we  use  some  of  the  hooks  in  the  jacquard  head  for  other

purposes  than  lifting  heddles  (warp  threads),  for  example,  weft

change,  regulator,  selvedge,  weft  density.  You  set  the  position  and

function of hooks in  the  Loom layout section of the  Save  cards for

production window.

To choose the type of the feld (hooks function), click the feld button (it is labeled

Empty hook by default), and select the function (type) from the drop down menu

(Figure  351). In the  Length feld, enter the determined number of hooks for that

function. Then pres the Enter key on the keyboard, which confrms the data and

opens the next feld. ArahWeave limits the number of felds in the loom layout to

40,  which should be more  than  enough in  most  cases.  When  you enter  all  the

felds, save your loom layout (File > Save loom layout), that you will have it ready

for next time.

Figure 350: The Position and element
type button and the Length feld

Figure 351: Menu for
selecting hooks function
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18.5 LOADING THE SELVEDGE WEAVE

To load a selvedge weave into the Save cards for production window, do one of the

followinge

Double click on the Selvedge area on the right of the window. It opens Weave editor’s

fle dialog, from which you load the weave to be used for selvedge.

• Select  the  area,  labeled  Selvedge,  and  load  any  of  default  weave  by  pressing

weave’s shortcut on a keyboard (see Chapter 5.2).

• Click the Weave to editor icon ( ) which replace the current weave with selvedge

weave in the weave editor. Apply desired changes on the selvedge weave, and click

the Weave from editor icon ( ). This action puts the selvedge weave back to the

Save cards for production window, and restores the previous (jacquard) weave in

the weave editor.

To remove selvedge from feld, just select it and press Delete on keyboard.

If the repeat of selvedge weave divides the number of wefts in design, then the dimension of the weave is

shown in black, otherwise it is displayed in red.

18.6 WEFT CHANGE, CUSTOM WEFT CHANGE

The normal weft change is when one hook activates one weft. In the Save cards for production window it is

simply indicated as  Weft change. It is default  setting in  ArahWeave, and program automatically  takes one

hook for one weft – frst hook for weft  a, second for weft  b etc. But some Jacquard settings have so called

Custom weft change. In this case you should choose Custom weft change in your Loom layout and load a

weave, which indicates the position of weft selector hooks, in Custom weft change  feld in the right column of

Save cards for production window. To load a weave into feld (you have to prepare and save a weave before)

double click on  Custom weft change feld. The fle dialog will  pop up, and you have to double click desired

weave fle.

Figure  353 shows the position of eight  weft  selectorse  normal,  and two examples  of custom weft  changese

binary and doubled weft change.

Figure 353: Normal weft change, binary, and custom weft change

 

Figure 354 shows the weft change of pattern 1a1b2c1b1d in

Jacquard  cards  with  normal  weft  change,  binary  weft

change, and custom weft change (note, that last one is just

an example of custom weft change; your may be diferent).

Last column is just color indication of weft selection.

No matter which type of weft selection you use, the weft

pattern  is  always  taken  from  the  Edit  warp  and  weft

pattern window.

If the weave size in weft direction is  not divisible by weft

pattern repeat, the program will make Jacquard card in the

size  of  lowest  common  multiplier.  Examplee  if  your  weft

pattern  repeat  is  6,  and weave  size  is  100,  the  height  of

Jacquard card will be 300.

18.6.1 WEFT REPEAT LIMIT (65520 THREADS)

Sometimes  users  combine  a  weave  with  a  weft  pattern  which does not  divide.  In that  case,  the  program

automatically prolongs the weft size of the simulation until it divides, or it stops at 65520 wefts. This is always

displayed in the window title. Now this can create problems, when you try to save jacquard cards, which then

do not ft  on one foppy or it  makes extremely  big fles,  because the fle will  have 65520 wefts (picks).  To

prevent this kind of problem, ArahWeave issues an error if the fnal repeat is cut of at 65520 threads, but weave

Figure 354: Weft change 1a1b2c1d1b

Figure 352: The
selvedge weave entry
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or weft pattern do not have a repeat of 65520 wefts. So you can

save  a  design  with 65520 wefts,  if  at  least  one of the  design

parameters really had this size. But program will not allow you

to do this, if it happens by accident, since sizes are not divisible.

18.7 ENTERING A FILENAME

Enter a flename of the CAM fle, or you can click the arrow  at the left of the Filename text feld to copy

a fabric’s flename into the Filename feld. The necessary prefx or sufx will be added automatically according

to specifcations of the selected jacquard  format.  Some  jacquard  formats  may not be able  to handle long

flename; use only 8 characters for flename if you run into trouble. ArahWeave distinguishes capital and small

letters. If you are still using foppies, insert an empty MS-DOS formatted foppy, click OK, wait a little and your

design is ready for weaving, or choose location on a hard disk, or send a fle by network to the loom.

18.8 SELECTING THE FORMAT

Select the desired electronic jacquard format from the

drop  down  menu.  The  frst  group  contains  the  true

electronic  jacquard  formats,  the  second  contains

graphic  fle  formats  (you  might  want  to  use  it  to

transfer  data  to  another  CAD  system),  the  third

contains  electronic  dobby  formats,  and  fourth  the

drawing-in machines.

Figure 356: Choosing CAM format

18.8.1 SAVING BONAS FORMAT EXCLUDING WEFT BYTES

There is special case with Bonas format implementation in some Jacquard machines, mainly in China, when

electronic functions should not be written in the fle (technically speaking they are written, but the 32 bits are

taken from the number of hooks),  otherwise  a loom controller  can't  read a fle.  So, to write a  fle  without

electronic bytes, set the number of weft bytes to 0 (zero), and mark the Weft bytes frst check-box. Program

will write a jacquard fle, which width will exactly match the number of hooks set in the loom layout.

Figure 355: Error message tells you to check
the weave and weft pattern repeat

Warper formats

Drawing-in machines

Dobby formats

Graphic fle formats

Jacquard formats
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Figure 357: Saving a fle in Bonas format without weft bytes

 

18.9 CHOOSING A LOCATION FOR SAVING CAM (MACHINE) FILE:
Prior saving the fle, choose a location for saving a fle. You have following optionse

• A: (a foppy disk).

• Desktop (it is easy to copy or attache from here).

• /tmp/ (to put in on temporary directory of Linux).

• Browse to select directory.

• Send to send it via network to the loom.

• USB. When selected, the program saves a fle to USB fash memory.

• Emulator. When selected, the program saves a fle to USB fash memory, which should

be formatted as a foppy disk to use with the Floppy emulator drive (please note, that

user should be in the disk group in Linux system. This allows formatting of USB memory

drive to regular user.)

18.9.1 WRITING A FILE TO MULTIPLE FLOPPY DISKS

You can save up to 1.44 MB of data on a foppy disk. If you choose a

foppy disk as a destination for saving and a jacquard fle does not ft

on  a  single  foppy  disk,  ArahWeave splits  a  fle  into  as  many  as

needed foppy disk fles. For instance, if a fle size is 3 MB, it will be

split into three flese 1.44 MB + 1.44 MB + 0.28 MB. The Save cards

for production dialog will pop-up, displaying buttons labeled with fle

names.  To copy a  fle,  insert  a  foppy disk,  and click the  frst  fle

name  button.  Wait  until  it  fnishes  copying  the  frst  fle.  Eject  a

foppy  disk,  insert  another  one,  and  click  the  second  fle  name

button. And so on till the last one.

Figure 359: Saving a fle to multiple
foppy disks

The dialog  also ofers  the  possibility  to  copy all  the  fles  to  the  desktop (click  the  Copy  fles  to desktop

button). This is useful for customers, who do not have a foppy drive (for example Mac users) and only want to

e-mail the fles to the weaving mill, which will later copy them to foppy disks. This operation will only work for

jacquard foppy disk formats in DOS format. So Stabuli JC3 and JC4 are not supported.

18.9.2 USING USB FLOPPY DISK DRIVE EMULATOR

A USB foppy drive emulator is a small box with USB port, a plug-in replacement for a foppy disk drive. It has

the same size and connector as an old regular foppy disk drive, so it is quite easy to replace a foppy disk drive

Figure 358:
Choosing location

for saving a fle
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with a USB foppy drive emulator. After you have installed an emulator into a jacquard controller, it will think it

still works with an ordinary foppy disk drive.

Figure  360 shows  a  USB  foppy  emulator

installed  on  Stäubli  JC5  controller.  There  are

three  features  on the  front  sidee  a  USB  port,

where  we  plug  a  USB  fash  memory  drive,  a

two-digit display, which shows a number of the

selected foppy, and two push buttons,  which

enable  us  to  set  a  number  of  a  foppy,  from

which we want to access designs. You can store

up to 100 virtual foppy disk drives on the fash

memory drive (from 00 to 99).  For instance, if

you have saved a fle to foppy no. 5, you have to

set the number on  the display to 05, and then

insert the fash memory drive. 

Before installation of the USB foppy emulator, you should check the position

of a jumper on jumper pins on the backside of the emulator. For instance, JC4

controller requires diferent position of the jumper than JC5 controller. The JC4

jumper must be on S0 position (frst pair of pins), while the JC5 jumper must be

on S1 position (second pair of pins). 

18.9.3 SAVING DESIGNS TO A USB FLOPPY EMULATOR WITH ARAHWEAVE

Prior  saving  a  design  to  USB  foppy  emulator,  you  have  to  format  a  USB  Stick  in  a  way,  that  it  will  be

recognized on Jacquard controller as a “virtual foppies” carrier. To do this, set the Emulator as a destination

for saving in the Save cards for production window, and choose File > Format USB for foppy emulator. The

Format USB for foppy emulator dialog will open. Enter the foppy range, determined by From and To number.

Figure 362 shows formatting of 21 virtual foppy disk drives – from 0 to 20.

Figure 360: USB foppy emulator installed on Stäubli JC5
controller

Figure 361: Jumper pins,
connector pins, and power

connector are located on the
backside of an emulator.



  www.arahne.si  A r a h W e a v e  

User Guide 

  1 8 5

Figure 362: Formatting a USB stick for use as a foppy disk drive emulator

When  you  save  a  design  to  Emulator,  you  have  to

specify the number of the virtual foppy that you want

to save a design to. 

If  a  design  requires  more  foppy  disks,  it  will  start  writing  from  selected

foppy onwards.  For  instance,  a  design  from  Figure  363 will  be written  on

three foppiese No 5, No 6 and No 7. When you load a design on a Jacquard

controller, you will need to set the emulator number to 05, load frst foppy,

disconnect  the  memory  key,  then  change  the  number  to  06,  connect  the

memory key, load a second foppy, again disconnect the memory key, set the

number to 07, connect the memory key, and load the design's last part.

18.9.4 CONFIGURING AN EXTERNAL (USB) FLOPPY DRIVE ON OPENSUSE LINUX 

If you need to write only DOS fles, like Bonas, Grosse, JC5, JC6 and most of newer dobby formats, you can

save fle to a hard drive, and then copy it to a mounted USB foppy in Dolphin fle manager. Or mount a foppy

frst, and then use the Save to USB option in the Save cards for production window in ArahWeave.

But this way of writing fle to USB foppy has one serious shortcoming. If the fle is bigger than 1.4 MB, you

can’t save it. Multi-foppy fle writing works only, if the ArahWeave thinks that you have “real old” foppy drive.

USB foppy drive is recognized by the system as a regular USB memory device, like a USB memory key, except

that is, by today’s standards, extremely small.

So, if you want to write non-DOS fle formats (JC3, JC4), or multi foppy JC5, or some older dobby formats, you

have to fool the system that your USB foppy drive is actually the old ae drive. To do this, you need to edit one

of the Linux confguration fles, like it is described below.

• Connect a USB foppy drive to PC; no foppy inside. There shouldn’t be any other USB memory devices

connected.

• First, you need to fnd, which device name is used in your system for the USB foppy drive. Open a terminal

window (System > Terminal > Konsole (Terminal).

Figure 364: Multi-foppy design

Figure 363: Selecting a foppy number in the From feld



1 8 6    C h a p t e r  1 8  

 S a v i n g  l o o m  ( o r  o t h e r  C A M )  d a t a  ( c a r d s  f o r  p r o d u c t i o n )
www.arahne.si   

Figure 365: Opening the terminal window
 

• In the terminal type following command (press the Enter key after it)e ls /dev/sd*

The output  of the  command is  the device list.  You can distinguish the USB foppy drive from the hard

drive(s)  quite  easilye  the  USB  foppy  drive  is  usually  listed  as  a  last  device,  and  it  does  not  contains

partitions, which are represented as numbers on the end of the names. On the image below, the foppy

drive is labeled as /dev/sdb

Figure 366: The terminal window
 

• Then go to Suse menu (green icon) > System > File manager > File manager -Super user mode . After

opening, you will need to enter the administrator (root) password.

Figure 367: Opening the fle manager - super user mode
 

• In the fle manager, navigate to  /etc/init.d, and click with right mouse button on the  boot.local fle icon.

Choose Open with > Kwrite.
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Figure 368: Opening the boot.local fle in KWrite
 

• Add the following lines at the end of a fle (we use /dev/sdb as a device name in the commands below. You

should use the device name according to the output of ls /dev/sd* command on your system.)e

rm /dev/fd0

chmod 777 /dev/sdb

ln -s /dev/sdb /dev/fd0

ln  -s   /dev/fd0 /dev/fd0h1440

chmod 777 /dev/fd0*

Figure 369: Editing the boot.local fle
 

• Save the fle (File > Save), and close KWrite editor.

Figure 370: Saving a fle
 

Restart computer. If you will  leave the USB foppy drive plugged in all the time, it will  always use the same

device label, so you won’t need to modify the boot.local fle again.

With these settings, you need to choose a: as a destination for saving in ArahWeave. Also for formatting, you

need to choose either Format foppy or Format foppy JC4.
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To save to Dornier Dialog Panel II amv format you need to install program dosemu in Yast.

18.10 CARD PREVIEW

The Card preview enables checking the data prior writing them in the Jacquard format. We want to be sure

that weave design parts are at the correct locations, so on the top middle of the window, you have one button

for Verdol cards preview, and another for linear card preview.

Figure 371: Verdol type of card preview

 

Figure 372: Linear type of cards preview

 

As you move the mouse in the preview, it shows you the current / hook / weft position. Zoom in/zoom out 

works same as in main ArahWeave window, Ctrl + mouse wheel, or you can press  or  icons.

18.11 OTHER OPTIONS OF THE SAVE CARDS FOR PRODUCTION DIALOG

• Instruct  the  program  to  Repeat  the  frst  weft,  which makes  easier  to  attach  the  paper  cards  into  an

endless loop. You should not use this option, if you have an electronic jacquard.

• By selecting toggle button  Raise unused, the unused hooks will  be raised. On some electronic jacquard

machines,  the energy consumption is  lower if  hooks are raised,  so it  is  preferred to have  them in that

position.

• Weft bytes frste weft bytes are written at the right part of the cards (after “real” hooks section). Some fle

formats require weft bytes at the beginning (left side of the cards). If this is your case, mark the Weft bytes

frst toggle button.

• Function Regulator in ground can be used to diminish the error in weaving, when the loom switches from

weaving with regulator to normal weaving. On some very dense upholstery fabrics, and sometimes also on

curtains, this can be seen as a line of irregularity in weaving. If you set regulator in ground to one, then the

program will add one regulator to every second ground weft. This will efectively double the density, so you

need to halve the loom density, in order to keep the proper density of weaving. The loom will then weave

with regulator on all areas, so the transition from weaving with regulator and without regulator will be less

visible. This is the only parameter of the loom layout which gets saved in the fabric, and not in the loom
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layout. The reason is, that problematic regulator handling is more a property of a particular fabric than of a

loom.

• Elongate selvedge on regulator  does just that—make space for the extra wefts in the selvedge. Some

users don’t like it, so you can also switch it of.

• Fil  coupe  selvedge enables  a  special  function  for  handling  selvedges  in  fl  coupe.  Some  customers

complain that  cutting of fl  coupe threads tears  of the selvedges,  if  fl  coupe threads are woven in the

selvedge. But we can also not leave them unattached on the edges, since they will randomly fall back in the

fabric and create defects. By enabling Fil coupe selvedges, the program will put a weave for fl coupe weft

only on the frst six ends of the selvedge. That is enough to make them stay at their place during weaving,

but they will also gracefully fall out during fl coupe shearing. Again, some people don’t like this, and you

can disable it.

• Invert  regulatore  default  sign  for  regulator  on  is  a  black  point  (up).  Some  looms  use  white  point  for

regulator on, and black point for regulator of. If this is your case, switch on the  Invert regulator toggle

button.

The loom layout follows some implicit rules, that should be OK for the majority of cases, but it does not hurt if

you know what they aree

• If the specifcation of layout is shorter than the number of hooks, it will be automatically repeated to fll in

the unused hooks. If you want the hooks to remain unused, add an empty feld at the end.

• The Selvedge mirror entry serves for mirroring left selvedge to the right one, if you use such layout.

• ArahWeave permits creation of a design with a selvedge weave, which does not divide the jacquard weave,

or a weft pattern which does not divide the jacquard weave.

18.12 ONE PIECE DESIGNS

Some designs like blankets, shawls, napkins, or table cloths are woven as a “one piece designs”, so they require

at least cut mark between two pieces. Instead of drawing it in an image or in a weave, you can add wefts for

Top edge, Bottom edge, Fringe and Cut mark iinesent n the Save cards for production window. You get these

options after marking the One piece check box. For every option you can enter the number of weft threads. If

you select Top edge or Bottom edge, then you need to load the weave for each one. To load a weave, double

click on the Top edge area in the column on the right. It opens Weave editor’s fle dialog, from which you load

the weave to be used for  Top edge. Repeat procedure for  Bottom edge. Between two pieces you can have

fringe. Specify the length of the fringe (number of weft threads) in the Fringe feld. If you mark the Cut mark,

then program puts two threads in a plain weave in the middle of fringes, so you can separate two fabric pieces

exactly in the middle. If you want to have fringe at the beginning and at the end of repeat, turn on the Center

button. Program splits the number of fringes, and puts half of them at the beginning, and half of them at the

end of one piece design.

Figure 373: Settings for One piece design in the Save cards for production window

 

18.13 CREATING FABRIC HEADER AND FOOTER

ArahWeave enables the user to create a production label, which can be woven as initial  and fnal part of the

jacquard fabric.



1 9 0    C h a p t e r  1 8  

 S a v i n g  l o o m  ( o r  o t h e r  C A M )  d a t a  ( c a r d s  f o r  p r o d u c t i o n )
www.arahne.si   

Figure 374: Fabric with a woven label

 

18.13.1 STEPS IN CREATING HEADER AND FOOTER

To open the  Make fabric header/footer dialog choose  Change > Make fabric header/footer  from the Save

cards for production window menu bar.

Figure 375: The Make fabric header/footer dialog

 

• Defning weaves

ArahWeave takes the main weave for the label directly from the weave of jacquard design. This guaranties

that  the  quality  of  label  is  same  as  quality  of  main  fabric,  thus  not  causing  any  problems  later  in  the

fnishing. So, as concerned basic label weave, you don’t need to set anything. But you can defne (load from

library) weaves for three diferent parts of header/footere

Title – weave for characters in the text (if you don’t set it, the program simply takes the inverted jacquard

weave for the character weave).

Background – weave of the letters background.

Border – weave for the Top edge, which is woven after fabric’s header, preventing header to be damaged,

when you put fabric of the loom.

• Choosing a starting weft 

By default, fabric’s header starts with a design’s frst weft (pick), so it just continues (repeats) from design. If

for some reason you want to use diferent  part  of the design for the label  weave, you can set  diferent

starting point of the label weave.

• By default,  header  has  same  content  as  a  footer.  If  you want  to  have  them  diferent,  just  uncheck the

Header  = Footer button, and a new editing space for footer is  added to the Make fabric header/footer

window.

• Setting number of picks for label and label text

In the Picks feld enter the number of picks used for whole label, the number of picks, which will be used for

the text enter in the Label feld. Apparently, the Label number cannot exceed the Picks number. Then, you

can also defne the number of border picks. Border is usually added at the end of header to prevent label

damage, when you remove fabric from the loom.

• Setting the text layout (orientation, alignment, position)
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You have full freedom to position the label text any way you want. First

set  the  orientation  (mirroring),  then  the  alignment,  and  then  the

vertical position.

To align  text  within  the  left  and  right  edges,  use  the  Align  left  ,

Center  ,  Align  right  ,  and  Justify  (repeat  across  whole  design

width)  icons.

To align text vertically within the top and bottom edges of the label, use

the Align top , Center , and Align bottom  icons.

The text mirror feature enables you to create readable text on reversed

fabric. 

Figure 377:  Four examples of same text created with diferent mirroring options

• Entering the text you want to have in the label.

The text entry feld for the label is next to the number of wefts for

label text 

• Setting the weft thread pattern for label

By default, ArahWeave takes a weft color pattern from the main design. If you want that label difers in color

from  main  fabric  or  you  want  just  to  use  a  diferent  pattern,  set  it  in  the  Weft  pattern text  feld.

Additionally, you can defne the pattern for Top edge.

• Setting the number of design repeats (weaving program)

In the Weave repeats feld set the number of weave repeats to be woven before the header. For example, if

the repeat size is half of meter, and the length of piece on the loom should be 70 meters, then you set the

Weave repeats to 140.

Picks – similar to weave repeats – here you set the number of picks to be woven before header. Obviously,

ArahWeave can take into account only one parameter, either number of weave repeats or number of picks.

• Saving header/footer card fles for production:

Last section of the Make fabric header/footer window consist of three optionse

Modify fabric is mainly used as a header/footer preview.  ArahWeave adds header and footer to the initial

fabric and generates a new fabric. If you want to save cards of the header and footer, you have to load initial

fabric again and use the Make cards function.

Make cards saves three jacquard card fles (the fle of initial fabric, and both header and footer card fle) to

the  location,  which  is  set  in  the  Save  cards  for  production  window.  ArahWeave will  also  write  Staübli

program fle, which starts  with footer, continues with confgured number of repeats of main design and

fnishes with header.

Make fabrics saves only header and footer fabric fles for latter use.

Figure 378: Text entry feld for the label

Figure 376: Orientation, alignment
and vertical justifcation options
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Figure 379: The initial fabric, and the modifed fabric with header and footer

18.14 WEAVE SHUFFLE

Weave shufe function enables you to mix the pattern hooks in the desired order. If you leave it empty, pattern

will be unchanged and will repeat in the normal way. If you enter 1 2 3 0 The pattern will be interpreted as 1 2 3

0 4 5 6 0 7 8 9 0 10 11 12 0 .... where 0 means skipped (unused) hook. This can be useful for lowering the warp

density without changing loom tie-up.

You can also mix groups of hooks like this 1 3 2 4 The interpretation will be 1 3 2 4 5 7 6 8 9 11 10 12 13 15 14 16

17 19 18 20 ... This can be useful for terry or velor fabrics, when you want your hooks to be rearranged in a

special way due to the way your loom is operating. And last, but not least, you can write your complete layout

from the frst to the last pattern hook. This gives you complete freedom to shufe it any way you want. The

feld to enter weave shufe is visually short, but can contain large quantities of data, up to 60000 characters,

which is enough for specifying 20000 hooks. This information can then be saved to a loom layout fle for future

reuse.  If  you have  support  from Arahne,  and you do not  change loom  layout  every  day,  then  Arahne  will

prepare the layout according to your wishes.

You can also specify ranges of numbers in the weave shufe. This is useful, if you have numerous hooks, which

should be just mirrored or mixed by large consecutive blocks. Now you can specify hook shufe range simply by

writing 5-10, which means the same as 5 6 7 8 9 10, or 10-5, which means the same as 10 9 8 7 6 5. The ranges

are always consecutive and inclusive frst and last hook. If the frst number is lower than the second, then the

range is raising, otherwise it is falling. You should not have any spaces between the minus (-) and the range

numbers.

When you use weave shufe, it is important to know the total number of hooks in the shufe. Program will

calculate that for you in the Weave shufe label as for example Weave Shufe [4800]. This is especially useful

if you have skipped hooks (shufe with zeros), since program will calculate both the total number of hooks in

the shufe, as the efective number of hooks (the number of hooks which are actually working). This will be

displayed as Weave shufe [1320->1200].

Usually,  the shufe is applied only to the design hooks. But in some special  cases,  you also want it  on the

selvedge hooks, so you can click on Selvedge toggle button within Weave shufe to enable it.

18.14.1 CHANGING STARTING POINT OF JACQUARD CARD WITH WEAVE SHUFFLE

Sometimes you don’t want to start a Jacquard card with a frst thread in the weave, but with some other. You

can shift the weave, but it  is faster, if you “tell”  the program, what the starting point should be. Just  enter

desired number in the weave shufe feld, for example 1201 – and the frst pattern hook will be taken from the

weave position 1201. 
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18.14.2 MAKE SHUFFLE: DOUBLE REPEAT HALVE DENSITY

A loom equipped with Jacquard ofers great design fexibility with respect to dobby loom. Any kind of weave

can be woven without changes the loom. But this fexibility comes at a price of one big infexibilitye you can't

easily change warp density, or total number of warp threads. On dobby, you can simply use diferent reed, you

insert the threads in the shaft’s heddles the way you want, and you have any density you wish. In jacquard the

hooks are tied up to the loom in a certain way, and there is no simple way to change it.  Tying a hooks on

jacquard can take one or two weeks, and costs a considerable amount of money.

So a weaver must resort to advanced tricks to weave at a lower density. We will try to weave with two times

lower density, but without losing any of the working hooks. Our pattern will not have less resolution. This trick

is only applicable, when you have a smaller jacquard which needs to repeat the hooks two or more times, to

weave all the warp threads. On a full width (jumbo) jacquard, you can simply use weave shufe “1 0”, every

second hook will  be skipped, and this is  it.  On a repeated layout,  the shufe of “1  0”  would cut down the

number of useful hooks from, for example 1200 to 600. We do not want this. We wish to lower the density two

times, we don’t want to change hook arrangement to the loom, and still use the full 1200 hooks for the design.

Can it be done? Smart people can do it.

This function automatically writes a shufe, which enables you to make design with double sized width of the

repeat. The design will halve density of the current setup, because you use odd hooks (1,3,5,...) in the frst half

of the repeat (even hooks are unused in this part), and even hooks in the second part of the repeat (odd hooks

are  unused  in  this  part).  For  instance,  if  you have  2400  design  hooks,  ArahWeave will  write  the  following

shufee 1, 1201, 2, 1202, 3, 1203, 4, 1204...

Figure 380 shows two fabrics woven on the same loom, but fabric on the right was made with halve density of

the frst fabric, so the repeat is twice bigger. The jJcquard card was modifed by using the Double repeat- halve

density function.

Figure 380: Double repeat halve density

18.14.3 SKIPPED HOOKS MAP

Instead of entering skipped hooks with zeros, you can draw an image in  ArahPaint (or weave in the weave

editor);  the size  of the image  in  horizontal  direction  should be equal  to number of hooks.  Size  in  vertical
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direction is not important, it can be simply 2. Then draw the skipped hooks by black points. It is easy in weave

editor with copy tool. So you get the  Skipped hooks map image, where black points represent the skipped

hooks  on  the  loom.  Save  this  “hooks  weave”,  because  you  will  need  to  load  it  into  the  Save  cards  for

production window.

Figure 381: Draw the skipped hooks image (weave)

 

Open  Save cards for production. The last section on the left is  Skipped hooks map. Load the “Skip hooks

map” weave into that feld. The numbers on the weave shufe tells you, how many hooks are skipped out of all

hooks, and out of design hooks. In Figure  385 the number of hooks is 2688. The number of skipped hooks is

168. Out of 2400 design hooks there are 2250 working hooks.

Figure 382: Save cards for production with skipped hooks map



  www.arahne.si  A r a h W e a v e  

User Guide 

  1 9 5

The cards preview shows the position of skipped hooks.

Figure 383: Cards preview; notice the skipped hooks

If you have mirroring, or pointed hooks, you have to write them in the weave shufe feld without skipped

hooks. Only working design hooks should be written.

18.14.4 EXTRACTING WEAVE SHUFFLE WITH SKIPPED HOOKS FROM OLD FILES

Sometimes  you  have  a  very  complicated  loom  layout  (cast-out)  where  hooks are  dropped in  an  irregular

manner,  for example  in  frst  100  hooks designs skips  every  9 th hook, on hooks 101-1100  every  8th hook is

skipped, and on hooks 1101-1200 again every 9th hook is skipped.

Sometimes you are lucky and you already have a design with such a cast-out. If only you could import this cast-

out in an automatic way! Fortunately, you can. First you load this card image and remove the empty space and

weft change, so that you are left with only the weave (with skipped hooks) in the weave editor. Then, in the

window Save cards for production, call function Change > Guess skipped hooks. Program will check which

hooks are skipped and which are not, and write you the weave shufe in an automatic way. This can serve as

the base for your new loom layout.

18.15 STÄUBLI JC5 ZONES

If  your  selected  jacquard  format  is  Stäubli  JC5,  you  have  an  additional  feld  at  the  end  of  your  hook

specifcatione Zones. The feld Zones allows you to divide your hooks areas into distinct sections (zones), each

with its own name. Normally, you have the hooks on zone one, and weft bytes are on zone two. You can use

the Weft bytes frst toggle button to put them before or after the jacquard hooks zone. If you want something

more complicated, you must use the Zones feld. This is an example of a zone entrye

48(left selvedge)2400(design)48(right selvedge)32(control)

This specifes the total of 2528 hooks and gives proper names to the zones (in parenthesis). If the number of

hooks does not match the sum of zones, then zones are not used. The use of zones can simplify changing of

the selvedges on the loom controller, since it is easy to change the weave in the whole zone. Sometimes, a

specifc zone layout is required to load the design onto the Stäubli  JC5 controller,  if the user is not able to

confgure the input flters on the controller. So we must write the design with the exact same layout of zones

as the controller is confgured to.

18.16 STÄUBLI JC6
The new Stäubli JC6 controllers can display images and some additional information, which are stored in the

JC5 card fle.  ArahWeave  stores  fabric  simulation,  the  name  of the weave,  number of warp threads,  weft

density, names of weft colors, and amount of each weft color. These are saved automatically, if you select JC6

jacquard format. The fle extension of the saved fle will still  be JC5, and the resulting fle is compatible with

JC5 controllers. The JC6 fle size is slightly bigger, since it also stores the image icon.
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Figure 384: Stäubli JC6 controller

 

Figure 385: Full screen simulation preview on Stäubli JC6 controller  

18.17 SUPPORT FOR DOBBY CAM INTERFACES

You can save the weave card in following loom formatse

• CCI Tech (write)

• Dornier AMV (write)

• Dornier DoTech (write)

• Dornier DoStyle (read and write)

• Dornier DoWeave (read and write)

• JiangYin TongYuan SGA598 (write)

• Nuovo Pignone FAST (write)

• Panter (read and write)

• Picanol Des (write)

• SmitTextile G6300 (read and write)

• Somet DOP / COP (read and write)

• Stäubli 1858III (read and write)
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• Toyota JAT710 (write)

• Vamatex PID / PIW (read and write)

18.18 SUPPORT FOR DRAWING-IN MACHINES

The support for these machines is available as the last group of entries in the selection of jacquard formats.

When you select VEGA format, almost all the loom layout entries are unmapped, since they are not used. But

a new feld appears – Drop wire rows, where we can select the number of rows of drop wires. Almost all other

parameters for creation of drawing-in data are present in the weave window (drawing-in) and in consumption

window  (denting  for selvedge,  denting  for pattern,  number  of  threads  for  selvedge,  etc.).  The  only  other

parameter  which you can enter is  selvedge weave – you can load it  in the same way as for jacquard. The

selvedge shafts will always be extra to the normal pattern shafts.

ArahWeave, due to its dual dobby / jacquard nature, also supports complex setups, where you have dobby and

jacquard on the same loom. The ground is usually woven using the dobby, while some labels or writings are

inserted using jacquard in a certain portion of the fabric. This raises the complexity of warp preparation to a

higher level,  since we  need to distinguish jacquard threads from the dobby threads.  The jacquard  threads

should not be drafted into shafts.  We are using a special  notation for this  purpose – positive and negative

denting  values.  Positive  denting  values  indicate  dobby part  of  the  pattern,  while  negative  denting  values

indicate jacquard part  of the pattern. This distinction has no infuence in other part  of the program, these

threads  are  treated  diferently  only  in  output  to  drawing-in  machines.  The  negative  denting  values  are

interpreted as skip shaft but insert reed and drop wires as normal. Empty dents are also properly supported ase

skip reed, no skip on shafts no drop wires. The repeat blocks in writing VEGA format are supported, so fles are

not too long.

18.19 NETWORK DATA TRANSFER

ArahWeave supports  directly  transfer  to the jacquard controller  via  FTP protocol.  In these instructions,  we

assume a basic knowledge of TCP/IP and networking administration. To make it  work, you must have your

jacquard controllers connected to the same network as the Arahweave’s computer. Each controller must have

a unique IP address and you must know it. Before setting the ftp transfer in ArahWeave, you should check if it

works manually. In these instructions, we will use 129.0.0.19 as the IP address of the Jacquard controller, you

should use the actual address of your jacquard controller. Open a terminal window and typee

ping 129.0.0.19

and CTRL+C to stop. If it transmits packets without errors, it means that you are correctly connected to the

loom via TCP/IP. Now we want to check if we can talk to the FTP server on the controller. Typee

ftp 129.0.0.19

You will be prompted for a user name, enter “anon” and press the Enter key for the password. This will work on

JC5 controllers (JC4 controller  does not support the ping command, you should try connection with the

ftp command),  but you may need to use specifc usernames and passwords for other jacquard controllers.

Please refer to the documentation of your jacquard controller regarding the usernames and passwords of the

FTP server. While you are connected to the ftp server via ftp command, you should try to send a fle. We will

set the binary transfer, send the fle test.jc5 and logout.

bin

put test.jc5

bye

If this all worked without errors, we can integrate FTP into ArahWeave. You need to set up the loom network

confguration fle (.looms fle) in the default directory of your loom confgurations.  To open it in ArahWeave,

choose Help > Save setup, click on the Expert tab, and click the Loom network confguration button. 
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Figure 386: Starting Loom network confguration editor

 

If you start editor for the frst time and there is no .loom fle, the editor is opened with blank data. First set the

number of looms (rows), that you have in network.

Figure 387: The loom network confguration editor

To enter data in the cell, click in with left mouse button, and type in the data. If there is something already in, it

will be overwritten. To edit data, which are already in, click in cell with left mouse button, and press F2 on the

keyboard. You can copy the data from one cell into another with middle mouse button.

You must enter the loom (or location) name which will be visible to the user of the program (so users do not

need to remember IP addresses). Then you must also enter the IP address (or an ftp server name or a path of a

directory),  then username,  password, path (if  you want  the fles  to be placed in  a  diferent path from the

default directory into which ftp users log in), jacquard format, and the number of hooks of particular loom. If

you do not know the number of hooks, or if it does not matter, just enter 0, the Hooks feld cannot be empty. If

any of the other parameters is not necessary, just leave it blank.

Note that jacquard format must be written in the same way as it appears in the menu, but instead of correct

“Stäubli JC5” (with umlaut), you can enter “Staubli JC5”. You can have up to 300 looms confgured in this way.

Once you have fnished with editing, click the Save setup button. Program will create the .loom fle, where all

these settings are saved. ArahWeave requires a restart before you can use newly created or changed .loom fle.

Figure 388: Loom network confguration editor with data
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18.19.1 SENDING FILE TO THE LOOM

There are two ways of sending fle to the loome

• First waye sending a fle from the Save cards for production windowe

Choose  Send (Figure  389) as the fle destination in the Save cards for production

window, and click OK. After system created a fle and wrote it to /tmp directory, it

opens the Send fle production dialog.

The  displayed  list  of  looms  is  created  dynamically,  based  on  two

criteriae  number of hooks and fle format to prevent sending a fle to

the wrong loom. For instance, if you create 2688 hooks fle in Staubli

JC4 format, the list will display only looms, which have 2688 hooks and

have JC4 loom controller. To send a fle, click on the looms to which you

want  to  send  the  fle,  and  click  the  OK button.  Figure  390 shows

example, where the Jacquard fle will be sent to three selected looms.

You will be informed of the success or failure of each fle transfer.

• Second waye sending a fle directly from the Send fle to the production windowe

Choose  Weave > Send fle to production from the main window. The Send fle to production window

displays all looms, which you have in the .looms confguration fle. Click Browse to choose the Jacquard

card, which you will send to the selected loom. With OK you confrm sending the fle.

18.20 EXTRACTING DATA FROM CARD USING LOOM LAYOUT

This is the opposite operation of Save cards for production. Use it, when you have only the card fle, but not

the fabric or weave fle, and you need to create simulation or save the weave in diferent Jacquard format.

Load the card into weave editor. Load a corresponding loom layout into Save cards for production window.

Then choose Change > Extract data using loom layout from the Save cards for production window. If the

settings are correct, you get the jacquard weave and the regulator pattern in the weave editor and the weft

pattern in the Edit warp and weft pattern window.

18.20.1 GETTING SELVEDGE WEAVE FROM CARD FILE

If you want to get selvedges from the card fle into Save cards for production window using the Extract data

using loom layout function, these two option must be set as described belowe

• The Elongate selvedge on regulator option should be set to zero (0).

• The  Save/load selvedge  weave  in fabric  in the Weaving part  of

the Save setup should be on (the number 1 in the text feld means

selvedge 1 in the Save cards for production window).

18.21 CONVERTING THE JACQUARD CARD FROM ONE LOOM LAYOUT INTO ANOTHER

Nowadays, most mills buy jacquard machines in incremental manner. They do not buy 100 jacquards of equal

brand, model and size, but start with a small number and add new ones as their needs are growing. Often, this

also means that they choose a diferent brand or model, or that the new jacquard will have a diferent loom

Figure 389: Selecting
fle destination

Figure 390: Send fle to
production
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layout, for some technical reason. ArahWeave has a simple system for converting fle ready for weaving from

one jacquard format and layout to a diferent one. Obviously, this only works for jacquards with equal number

of design hooks. You cannot simply convert a 2400 hook design into a 1200 hook design. But you can easily

convert a Grosse 1200 hook card fle into a Stäubli JC5 card fle. The selvedges, hook positions and weft change

or regulator can be diferent between the two fles.

This operation is mainly intended for repetitive operations, when you are often converting designs from one

particular  layout  to  a  diferent  layout.  First,  you  need  to understand  and  save  loom  layouts  of  both (all)

jacquard  looms  you  want  to  convert  among.  Then  use  command  Weave  > Load  jacquard  cards,  if  your

jacquard fle is already on the hard disk. As a second step, choose  Weave > Save cards for production, and

load the loom layout, which corresponds to that fle. Once the correct layout has been loaded, apply function

Change > Extract data using loom layout . This will use the information in your current loom layout to throw

away the empty space on the hooks, retaining just the weave. It will also extract weft change and regulator, if

present. If you would now save the design, it would be saved in the same way as you already have it. So you

need to go in  File > Load loom layout and load the layout of the jacquard to which you want to save the

design. You can save it as it is, or modify weft change, selvedges, or whatever is necessary.

The main advantage of this approach is,  that  you can do it  even for old designs, which were developed by

external design studios, or other design systems. If the design was developed in ArahWeave, there is no reason

to work in this manner, since you can simply load the fabric and the loom layout you want to use, and save the

jacquard card design once again, for each jacquard layout.

19 DATABASE CONNECTIVITY BY XML

19.1 INTRODUCTION

ArahWeave enables you to integrate its design data with the company’s production management system (ERP

- Enterprise Resource Planning). 

Arahne  has  developed  several  tools  to  import  and  export  data  to  and  from  ArahWeave.  It  may  look

complicated, but don't be scared. It is possible to make this kind of connection, and you will not be the frst one

to implement it.

19.2 DATA IMPORT

All the import and export data formats are based on XML. XML is a simple standard which allows vendors to

describe the format of data exchange fles. We are using a very basic version of XML - one XML fle, and one

DTD fle which describes the valid structure of the XML fle. You can use the DTD fle to verify your imported or

exported fles. The DTD fle is not actually used in import or export; it just defnes the structure of the XML fle,

so you know which felds are obligatory and which are optional. If you place the DTD fle in the same location

as  the  corresponding XML  fle,  then  some  browsers  will  be able  to  verify  the  correctness  of  the  XML  fle

structure, and display a tree structure of the XML fle.

Figure 391: XML fle in a text editor
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Even before describing the data formats, we must know where do they come from. In the simplest situation,

you just copy the XML import fle to the standard location ( data/xml) for Arahweave’s XML fles (or to other

location defned in .arahne confguration fle). You can change the default XML location by exporting an XML

fle to a diferent location, and then saving the setup.

In a more complex setup, you can use the FTP protocol to get the import fle from a diferent computer. The 

FTP specifcation and the actual import/export is executed in Help > Save setup, the Data export tab. To use 

the FTP, fll in the box labeled Send XML data by FTP. You must specify the IP address (as numbers or as 

domain name), the username, the password, and whether to use the passive mode FTP.

The FTP location is the same for export and for import. To use FTP in XML import, you must enable FTP in the

Import data box, and optionally, you can specify a directory for XML import fles. This can be useful, so the

export and import fles are not mixed in the same directory. Another option during import is to delete old fles.

Use with caution! It is most useful during testing phase of import, since the program will automatically delete

all the previously imported fles. Once the system will  run normally, you should not need to use this kind of

destructive import, since all the data should have a clear creation path and be inserted only once, without fear

of duplication.

Figure 392: Data export in Save setup

 

Now let’s start with the specifcation of the actual import fles. If you have any experience with databases, you

will wonder what is a unique key in our defnitions. All the entries containing a word Code should be unique. 

19.2.1 WARP PATTERNS

They are specifed by the following simple DTD fle named ArahneWarpPatternImport.dtd

<?xml version="1.0" encoding="UTF-8"?>

<!ELEMENT ArahneWarpPatternImport (Pattern*)>

<!ELEMENT Pattern (Code, Value)>

 <!ELEMENT Code (#PCDATA)>

 <!ELEMENT Value (#PCDATA)>

The XML  fle  for warp import  must  have  the name  ArahneWarpPatternImport.xml  and this  is  a  small

example of such a flee

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE ArahneWarpPatternImport SYSTEM "ArahneWarpPatternImport.dtd">

<ArahneWarpPatternImport>

<Pattern><Code>00001</Code><Value>2a 1b</Value></Pattern>

<Pattern><Code>00002</Code><Value>1a 20(1c 1d)</Value></Pattern>

<Pattern><Code>00003</Code><Value>5a 70[1d 2c2b]</Value></Pattern>

</ArahneWarpPatternImport>
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The value of Code is equal to the code of your warp pattern in the database. Avoid using "/ " or "\" in the codes,

since the code is then used as a flename to store the warp pattern. The value of the warp pattern is any regular

warp pattern which you can write  in  ArahWeave.  Capital  and small  letters  are not important,  you can use

spaces or not, you can have several levels of parenthesis. If you use the parenthesis, use only () or [], not both

within the same pattern. Allowed yarn letters go from A-Y, and the longest permitted warp pattern has 65520

threads. As each pattern is imported, it is also interpreted and checked for correctness. At the end of import,

the program notifes you of the number of correctly imported fles and the number of failed ones, if any. In the

testing phase, when you want to see on which pattern is the import failing, you can run the program from the

console by typing

/home/capdam/aw/aweave

and the patterns which fail to import will be written to the text console.

You can start the warp pattern import by pressing on the Warp pattern button in the Import data box of the

Save  setup  window,  Data  export tab.  During  import,  the  current  fabric  is  redrawn  as  each  pattern  is

interpreted. This is normal, and serves you as a feedback of the program's activity. On a normal Pentium 4 or

newer computer, it should not take more than a minute to import a couple of thousands of patterns. Once

they are imported, you can browse them in a graphical way, as described in section 7.3.

19.2.2 WEFT PATTERNS

They are handled in exactly the same way as warp patterns, and everything written above still holds.

Only the flenames of the DTD and XML fles are slightly diferent.

This is the fle ArahneWeftPatternImport.dtd

<?xml version="1.0" encoding="UTF-8"?>

<!ELEMENT ArahneWeftPatternImport (Pattern*)>

<!ELEMENT Pattern (Code, Value)>

<!ELEMENT Code (#PCDATA)>

<!ELEMENT Value (#PCDATA)>
And this is the corresponding XML fle ArahneWeftPatternImport.xml 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE ArahneWeftPatternImport SYSTEM "ArahneWeftPatternImport.dtd">

<ArahneWeftPatternImport>

<Pattern><Code>00001</Code><Value>2a 1b</Value></Pattern>

<Pattern><Code>00002</Code><Value>1a 20(1c 1d)</Value></Pattern>

<Pattern><Code>00003</Code><Value>5a 70[1d 2c2b]</Value></Pattern>

</ArahneWeftPatternImport>

19.2.3 YARN COLOR NAMES

In databases, everything needs to be coded. So every color name needs to have a code. This import fle allows 

you to specify color names. First, here is the DTD fle ArahneYarnColorImport.dtd

<?xml version="1.0" encoding="UTF-8"?>

<!ELEMENT ArahneYarnColorImport (YarnColor*)>

<!ELEMENT YarnColor (YCode?, YColorCode, YColorName, YNumValues?, Value?)>

<!ELEMENT YCode (#PCDATA)>

<!ELEMENT YColorCode (#PCDATA)>

<!ELEMENT YColorName (#PCDATA)>

<!ELEMENT YNumValues (#PCDATA)>

<!ELEMENT Value (CIE_Lab, RGB, Percent?)>

<!ELEMENT CIE_Lab (#PCDATA)>

<!ELEMENT RGB (#PCDATA)>

<!ELEMENT Percent (#PCDATA)>

And now a small sample XML file ArahneYarnColorImport.xml

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE ArahneYarnColorImport SYSTEM "ArahneYarnColorImport.dtd">

<ArahneYarnColorImport>

<YarnColor><YColorCode>332323</YColorCode><YColorName>Rossignol</YColorName><YNumValues>1<Y

NumValues><Value><CIE_Lab>75.23 65.23 15.23</CIE_Lab><RGB>255 10 12</RGB></Value></YarnColor>
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<YarnColor><YColorCode>333523</YColorCode><YColorName>Girasole</YColorName><YNumValues>1<YN

umValues><Value><CIE_L>85.23 12.03 75.23</CIE_Lab><RGB>2550210 17</RGB></Value></YarnColor>

<YarnColor><YColorCode>234523</YColorCode><YColorName>Printed 5 colors</YColorName></YarnColor>

<YarnColor><YColorCode>434543</YColorCode><YColorName>melange 50</YColorName>

<YNumValues>2<YNumValues><Value><CIE_Lab>83.23 1.03 -1.23</CIE_Lab><RGB>0 0 

0</RGB><Percent>50</Percent></Value><Value><CIE_Lab>23.23 -1.03 -4.23</CIE_Lab><RGB>0 0 

0</RGB><Percent>50</Percent></Value></YarnColor>

</ArahneYarnColorImport>
As you can see, this XML fle allows you to specify a name for every yarn code, and also the optional CIE Lab

values of the colors. Most ERP systems do not contain actual yarn colors specifed in a colorimetric way, so

they omit the Lab values. But if you had all the colors measured by photo spectrometer, and inserted in this

XML fle, you could load them in. Some yarn colors can be multicolor, for example in melange.

Although the ArahneYarnColorImport.xml  fle can be imported on request, it is actually read every time

you run the program, if it is stored at the standard XML location. The importing of this fle does not generate

new color fles in Arahweave’s data fles. It only helps the program to display correct yarn color names during

yarn browsing.

19.2.4 YARNS

The database view of the yarn is somewhat diferent from the CAD view of the yarn. ArahWeave worries about

the right color, shape, luster, hairiness, diameter, everything to make a nice fabric image. Database, on the

other hand, only cares about numbers and codes. There is some intersection of interests, and this is what we

try to import from the database to ArahWeave.

The ArahneYarnImport.dtd is shown belowe

<?xml version="1.0" encoding="UTF-8"?>

<!ENTITY % cUnit "count Unit (tex|Nm|NeC|NeW|Np|Ny|NeL|NeS|Td|Run|dtex) #REQUIRED">

<!ENTITY % lUnit "lengthUnit (mm|cm|m|in|ft|yd) #REQUIRED">

<!ELEMENT ArahneYarnImport (YarnImport*)>

<!ELEMENT Yarn (YCode, YName, YCount, Ply, Twists, TwistContraction, Model?, DimensionFactor?, 

HairLength?, HairProbability?, Fibre*)>

<!ELEMENT YCode (#PCDATA)>

<!ELEMENT YName (#PCDATA)>

<!ELEMENT YCount (#PCDATA)>

<!ATTLIST YCount  %cUnit; >

<!ELEMENT Ply (#PCDATA)>

<!ELEMENT Twists (#PCDATA)>

<!ATTLIST Twists %lUnit; >

<!ELEMENT TwistContraction (#PCDATA)>

<!ELEMENT Model (#PCDATA)>

<!ELEMENT DimensionFactor (#PCDATA)>

<!ELEMENT HairLength (#PCDATA)>

<!ELEMENT HairProbability (#PCDATA)>

<!ELEMENT Fibre (#PCDATA)>

<!ATTLIST Fibre percentage CDATA #REQUIRED >
A sample of ArahneYarnImport.xml

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE ArahneYarnImport SYSTEM "ArahneYarnImport.dtd">

<ArahneYarnImport>

<Yarn><YCode>202245</YCode><YName>Lana 40</YName>

<YCount countUnit="Nm">40</YCount>

<Ply>2</Ply><Twists lengthUnit="m">600</Twists><TwistContraction>0</TwistContraction>

<Fibre percentage="100">WO</Fibre></Yarn>

<Yarn><YCode>202234</YCode><YName>Lana 48</YName>

<YCount countUnit="Nm">48</YCount>

<Ply>2</Ply><Twists lengthUnit="m">700</Twists><TwistContraction>2</TwistContraction>

<Fibre percentage="100">MD</Fibre></Yarn>
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<Yarn><YCode>302231</YCode><YName>Misto 12</YName>

<YCount countUnit="Tex">12</YCount>

<Ply>1</Ply><Twists lengthUnit="m">400</Twists><TwistContraction>0</TwistContraction>

<Fibre percentage="60">CO</Fibre><Fibre percentage="30">MD</Fibre>

<Fibre percentage="10">PL</Fibre></Yarn>

</ArahneYarnImport>
Yarn code and yarn name felds need no explanation. Some customers use "/" in the yarn codes, and program

allows that, using some tricks. When it is saving the imported yarn in yarn directory, it fips the "/" character

into "\", since flenames in Unix cannot contain "/". When it loads such yarn, it fips the yarn code back to the

original. So your yarn codes will be correct in all the cases.

Yarn count is entered with the unit of the count. You can use any unit supported by ArahWeave.

Number of plies is also obvious, and the number of twists are again entered with its own length unit.

Twist contraction tells us by how much does the yarn count shrink due to twisting. Just leave it at zero, if you

do not need it.

And fnally you can enter up to 6 fber components, each with its own relative percentage. The fber codes

must be composed of two letters.  It is better if they are written according to the standard which is used in

ArahWeave. Once you load the yarn with fber composition, the program will  be able to calculate the fber

composition of fnal fabric 

Note that yarn is colorless - the same yarn can exist in many diferent colors. Also, we do not expect to import

any of the yarn visual properties, since ERP systems do not store this kind of information.

19.2.5 YARN TO COLOR ASSOCIATION WITH PRICES AND AVAILABILITY

Finally we have all the components to specify which yarns do we actually have. We need to associate the yarn

code to yarn color code, and tell how many kilos of yarn do we have, and how much does it cost. The DTD fle

to specify the format is ArahneYarnToColor.dtd

<?xml version="1.0" encoding="UTF-8"?>

<!ELEMENT ArahneYarnToColor (Yarn*)>

<!ELEMENT Yarn (YCode, YColorCode, YStockKG, YPriceKG, Season*)>

<!ELEMENT YCode (#PCDATA)>

<!ELEMENT YColorCode (#PCDATA)>

<!ELEMENT YStockKG (#PCDATA)>

<!ELEMENT YPriceKG (#PCDATA)>

<!ELEMENT Season (#PCDATA)>
And this is an example of a valid XML fle ArahneYarnToColor.xml

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE ArahneYarnToColor SYSTEM "ArahneYarnToColor.dtd">

<ArahneYarnToColor>

<Yarn><YCode>202245</YCode><YcolorCode>0555</YColorCode>

<YStockKG>47.6</YStockKG><YPriceKG>2.4</YPriceKG></Yarn>

<Yarn><YCode>852345</YCode><YColorCode>0002</YColorCode>

<YStockKG>2.3</YStockKG><YPriceKG>2.8</YPriceKG><Season>0205</Season></Yarn>

<Yarn><YCode>435453</YCode><YColorCode>0435</YColorCode>

<YstockKG>77.9</YStockKG> <YPriceKG>1.3</YPriceKG><Season>0206</Season></Yarn>

<Yarn><YCode>234534</YCode><YColorCode>0667</YColorCode>

<YStockKG>240.3</YStockKG>

<YPriceKG>0.9</YPriceKG><Season>0205</Season><Season>0105</Season></Yarn>

</ArahneYarnToColor>
The elements of this XML fle are obviouse yarn code, yarn color code, yarn stock quantity in kilos, and yarn

price in whatever currency you like to use. Season is an optional yarn property. A normal weaving mill will try

to reduce the number or yarns in contemporary use, to minimize fragmentation of yarn stock. So for only a

smaller set of yarns will be used in a particular season. A yarn in certain color can have up to six seasons. In the

yarn browser, this allows us to show only yarns of a particular season, instead of all the yarns, which were ever

used in the mill’s history.
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19.3 EXPORT OF DATA – USER’S VIEW

Why is export of data difcult? Because artists do not understand accountants.

In  ArahWeave, we try to give the designer total freedom. Want to change the weave? Click, and you have a

new fabric. Want this stripe larger? Click on the yarn, draw into the fabric, done. Want a darker red on that

yarn? Click, drag, done.

In ERP systems, it doesn’t work like that. Everything needs to be coded and tagged, you need to have your

building blocks ready, and then you assemble your skyscraper. If you need to change the yarn color in fabric

into darker red, you frst  need to create that  color,  give it  a code, apply that  code to the yarn,  then if  you

change the width of the stripe, this makes a new warp pattern, so it needs to be saved with a new code, and in

turn this needs to be associated with the new warp, which needs to be associated with a new fabric, and only

then you can move on to weaving this piece.

Not that one is better than another - they just serve two diferent purposese creativity and production. How do

we marry the two approaches? By allowing the freedom to the artist, and when the sale of the masterpiece is

confrmed,  we  pass  it  to  the  accounting  department.  That  means,  that  after  the  fabric  simulations  were

confrmed by the buyer, we need to fll in the codes, so that the fabric can be exported. Fabrics without proper

codes are useless in the ERP, so ArahWeave must ensure that you have all the codes, prior to exporting.

That means that before exporting a fabric, you will need to load a fabric and fll in some details which you did

not care about in the creative phase. First, choose Fabric > Information, and fll in the Name, Quality, Design

and Version. Second, all the yarns must have associated the yarn code and color code. The easiest way to do it

is to use the yarn browser in the Yarns window. Using the yarn browser, you can simply click yarn by yarn, and

fll in all the yarn technical data. By default, toggle button Load only codes will be enabled. This means that

program will  only load the values relevant to XML export, without the actual yarn color or yarn image, and

other yarn simulation parameters.

If  you  have  set  all  the  values,  you  can  proceed  to  File  >  Save  technical  data  as  XML.  Program  will

automatically set the XML flename equal to the name of your fabric, and it will add the .xml at the end.

If the FTP sending is confgured, then XML fabric fle will be sent to the specifed location. Otherwise the XML

fle will just be saved to the XML directory.

In the Data export section of save setup, we have some other options we did not mention earlier.

If  you  enable  Save  codes  with XML,  then  the  program  will  also save  the  warp and weft  patterns  before

exporting XML. It will do it in a smart waye frst it will check if an equal warp or weft pattern already exists. If it

does, then it will apply its code to the fabric. If not, then warp or weft pattern will be saved with a new name.

We have another option, which controls how the new name is generated. If the Use frst free code option is

active, then program will fnd “holes” in your coding and use the frst free code. If not, then it will increment the

last code if fnds, leaving the empty areas of codes.

The checking of existing warp and weft patterns is very smart, since it does not compare the way the pattern is

written, but its meaning. So program will know that 1a 1b 1a 1b 1c is the same as 2(1a 1b) 1c, and it

will use the same warp or weft pattern code.

Finally, it is very useful to enable the Check fabric codes with XML option , since then the program will verify

if all  the required felds have been flled in. If not, it  will  warn you about it  and inform you exactly what is

missing on which yarn.

Maybe you will be surprised that we do not deal a lot with coding weaves in the export. Our view is that ERP

system does not need to know too much about them. Weaves are big, so they cannot be stored in ERP. In the

past, some companies spent a lot of time coding the dobby cards and reusing them. Now, this is all nonsense.

Any decent mill will have electronic transfer of dobby card and of jacquard cards. So there is no time saving by

trying to reuse the old ones, making all the codes and stuf. The weave should be born and die with the fabric

article. The ERP system only needs to know enough to understand which warps are compatible. The actual

weave is irrelevant to ERP, as this is handled by the ArahWeave CAD.

19.4 EXPORT OF DATA - EXPERT’S VIEW

In order to import the XML fabric, you will need to write a program which will read Arahne fabric XML fle and

fll in the appropriate tables in your database. There will be many felds you probably won’t need, so you can

skip them. And there will be other felds, which it will not contain, for example custom code. Here, you need to

work with the weaving mill and fll in the missing felds with proper defaults. Alternatively, you can implement

a second phase  of import,  where  the  operator  will  fll  in  some  felds  in  a  manual  way.  Even with manual
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checking of some felds, the time savings achieved by automatic transfer will be very big. Anyone who spent

her life retyping warp patterns, will confrm you this.

The current versions of ArahneFabric XML and DTD fle is available for download from Arahne's web sitee

httpe//www.arahne.si/xml/ArahneFabric.dtd

httpe//www.arahne.si/xml/SampleFabric.xml

We will not repeat the actual XML fles here, to save the rain forest.

All the entry felds have logical names, so you can understand what do they mean. Try to use use ArahWeave

and export a couple of fabric XML fles, and you will see how they look. If you have a valid support contract, we

will also gladly help you in the implementation and explain you all the details.

19.5 CASE STUDY: PROTEX - COMPUTER HOUSE DI PRATO

The implementation of the connectivity is sometimes done by weaving mill internal IT staf. But more often it

is done by an external company, which supports the weaving mill ERP system. In Italy, we have done this with

our partner Computer House di Prato (CHP), with which we share many customers.

CHP's ERP is  called Protex, and it  is  using a database running on Oracle in Linux or Unix, with a Windows

graphical interface on new versions, or text based terminal interface on older versions. Programmers of CHP

have  written  two  modules  for  Protex,  one  called  PROCAD,  which  periodically  writes  the  import  fles  for

ArahWeave, with all the yarns, names and yarn availability.  ArahWeave then reads these data by FTP, when

the user request data import or yarn availability. 

The other program is called CAD-LINK and it is periodically checking if ArahWeave has sent it any fabric XML

fle by FTP. If it fnds any fles, it imports them and deletes them. If there are errors in the imported XML fabric

fle, it sends an e-mail to the Protex administrator, so failed imports get noticed.

Figure 393: PROCAD and CAD-LINK

20 SAVING SETUP (PREFERENCES)

20.1 SETTING DEFAULT FABRIC

When you open ArahWeave, it displays the default fabric. If you want to change it,

load a fabric, that you want to be the default one, and choose Help > Set current

fabric as default from the main menu bar. 

Figure 394: Setting current
fabric as default

http://www.arahne.si/xml/SampleFabric.xml
http://www.arahne.si/xml/ArahneFabric.dtd
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20.2 CHANGING DEFAULT DIRECTORIES (FILES)
To  change  the  default  fle  or  directory,

where  the  fles  are  saved,  you  have  to

load  the  desired  fle  from  a  specifc

location into ArahWeave (fabric fle in the

main  ArahWeave window,  weave  fle  in

the Weave editor, yarn fle in the  Edit yarns window, image fle in the  Jacquard conversion window, loom

layout fle in the Save cards from production window, etc...). Then choose Help > Save setup. Check the Set

default directories button, and click the OK button in the Save setup window. 

20.3 WEAVING SECTION

The Save setup dialog has special weaving part for all weaving related settings. To access them, choose Help

> Save setup, and click the Weaving tab.

Figure 396: Save setup - weaving
 

• You can change the option button from Reed width -> Dents to Dents -> Reed width to use Number of

dents in fabric width instead of Threads in fabric width in the Consumption window.

• With the Fabric length -> Warp length  option button you choose either the Fabric length or Warp length

is your input in the Consumption window.

• Report  yarn  consumption as  length—if  it  is  on,  then  the consumption  is  calculated  in  length of yarn

instead of weight of yarn

• The default Reed unit is 1 centimeter, but you can change to whatever your reed unit might be.

• Save/load selvedges in weave—if it is on, then the selvedge, which is currently loaded in the Save cards

from production window, is  saved with a weave. When you load such a  weave, then it  overwrites  the

selvedge which is currently loaded in the Save cards from production window.

• Save/load selvedge weave in fabric—if it is set to 0, then the selvedge weave is not saved in the fabric. If it

is set to one of the three possible numbers 1,2, or 3 (Selvedge or Selvedge 2 or Selvedge 3 respectively),

then the selvedge, which is currently loaded in the  Save cards from production window, is saved with a

fabric. When you load such a fabric, then it overwrites the selvedge which is currently loaded in the Save

cards from production window.

• Use fnal yarn count—if it is on, then program takes the yarn count number for calculating the simulation

(diameter  of the yarn)  or yarn consumption as the absolute  yarn count regardless  if  it  is  single yarn or

multiply yarn. The display of yarn count is also diferent, if you use fnal yarn count.

• Mirror numeric drafting—choose either the frst shaft is the nearest or the farthest to the weaver.

Figure 395: Setting the default directories
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• Print  dobby  rectangle  in  light  red—default  color  for  dobby  rectangle  is  red—but  if  you  photocopy

(black&white) the print, then you can’t distinguish between rectangle and weave. Solution? Print it in light

red.

• Black grid gray points—if it is on, the program prints warp points in gray color and weave grid in black

color, which is just opposite to the defaults.

• Report weft density per yarn—in some textile areas in Italy they use density per each yarn color to help

them to calculate the consumption, so we included this as an option in ArahWeave.

• Sort  Jacquard  image  colors  by popularity—does just  as  it  sounds;  it  sorts  colors  of the  image  in  the

Jacquard conversion window by colors popularity. If the option is of, then ArahWeave sorts colors like

they are written (saved) in the image fle.

• Always fx foats on saving jacquard cards—if you have set the foat limits (see chapter 5.8) in the fabric,

and the option is on, then ArahWeave automatically checks and corrects long foat errors.

• Reload jacquard weaves only to equal colors—if you load a diferent image, weaves will be retained only

if colors are exactly the same, and program will not try to map the weave to the most similar color.

• Capital letters in CAM sufx—some users still have a lot of loom fles written in old DOS systems, which

don’t distinguish between capital and lowercase letters—thus this option allows you to save CAM fle in the

same way.

• Warning on card overwrite—if the option is on, then ArahWeave warns you, when you use already existing

fle name for CAM fle.

• Save unused warp/weft in fabric—by default,  ArahWeave saves only yarns, which are used in fabric, in

fabric fle. Next time, when you load that fle, only saved (used) yarns are loaded, the other yarns in the Edit

warp and weft pattern dialog (25 yarns for each) are default  yarns. But if you enable the  Save unused

warp/weft in fabric option, then all currently yarns from the Edit warp and weft pattern  dialog are saved

in fabric fle, and thus loaded when you open the fabric fle next time.

Then there is the Properties section. You can control which text felds and option are present in the Properties

window (Fabric > Properties).

• Division

• Fabrics

• Name

• Derived from

• Cut

• Stock

The Warning on saving wrong section consists of two optionse

• Threads  in fabric  width—if  the number of threads is  not “compatible”  with denting and reed number,

ArahWeave warns you before saving a fabric.

• Weave—if the weave of the fabric, which you want to save, has unfnished (or no existing) drafting into

shafts, ArahWeave warns you before saving a fabric.

20.3.1 GENERATING FILENAME, FABRIC SIMULATION TITLE OR HTML FABRIC NAME FORMAT

The  Generate flename section of Save setup enables you to declare, which data from the fabric properties

(Fabric > Properties) is used for generatinge

• Fabric flename

• Fabric name in HTML technical data fle (this is also used as a Fabric name on printout)

• Fabric name on multi-fabric printout

The format of fabric name formula has only one rulee the number of feld which will be used in the fabric name,

should stand after the dollar sign ($), which is there to indicate that the used number is the feld number and

not character which would be part of the text. After the feld number you can enter whatever character you

want, like space, slash, hyphen, and it will be used in generated flename.

The text felds in the Properties dialog have following numbering labelse

Field Label

Division $8, $9  *

Name $1

Quality $2

Design $3
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Version $4

Season $5, $6  *

Designer $7

Notes $N

* $8 takes only frst word (anything till frst space character) from the division code (or name), while $9 takes

the whole name. Same applies to Seasone $5 takes only frst word and $6 takes the whole code.

Beside Properties, four additional signs were introduced for automatic title generatione

Fabric filename $0

Jacquard image filename without suffix $I **

Scissors $@ ***

Directory name $D

** It is capital letter I.

*** Scissors sign can be print only on multi fabric print, not on single one.

Let’s see an examplee if you have written  $1 - $2 $3-$4 as a rule in the  Automatic fabric name format

feld fabric name format,  and have entered following text  in the Properties  windowe Pale Blue as a  Name

(Field 1),  B as a  Quality (Field 2), 14 as a  Design (Field 3), and 08 as a  Version (Field 4), then the generated

name would bee .Pale Blue - B 14-06. To generate flename, click  icon in the Save fabric dialog.

Figure 397: The fabric properties, which can be used in automatic generated fabric name, the fabric name rules, and
generated fle name

20.4 PERSONALIZING ARAHWEAVE

The Appearance section of the Save setup window contains most of the program’s look-and-feel settings.

Figure 398: The Appearance section of Save setup
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20.4.1 SETTING USER INTERFACE FONT

You can choose your preferred font style  for user interface  from the

drop-down  menu.  The  font  menu  shows  only  font  styles,  which are

available  for current  selected language. If you are using Latin  script,

then the default font (Sans) is normally a good choice. Choose Garuda

or Tahoma for Thai language, you can use  FZKaiTi or similar font for

Chinese; Chinese language package should be installed in Linux.

ArahWeave uses  two  font  sizese  Normal (most  of  the  program  text)  and  Small  (flenames  in  the  browse

window, color names). You can adjust the size by changing the number of points in adequate feld. 

The Calculation of thread consumption window, the Price calculation window, and the Yarn windows use a

web browser engine to display HTML code in tables in their windows. To set the font size in these tables, edit

the font size numbers in the Size list HTML (points,...) feld. The Bold HTML titles button serves to disable

the default  bold titles  in the HTML code, because sometimes (especially  when you use Chinese language)

characters in bold style are difcult to read.

20.4.2 USER INTERFACE COLORS

Click the Colors tab in the Save setup window to set the user interface colors. You

can change following user interface colorse

• Background color of the program

• Mouse pointer color

• Background color of the Weave editor (on some LCD monitors the default color

is too light, so it is difcult to distinguish the background from the editing area)

• First level grid color in the Weave editor (Grid 1)

• Second level grid color in the Weave editor (Grid 2)

To change color, click the Edit button. Use the Color editor to specify or defne a

color  for  the  selected  portion  of  the  user  interface.  Color  feld  displays  the

spectrum  of  available  colors.  The  cross  hairs  indicate  the  current  color.  Click

anywhere  or  drag  in  the  color  feld  to  select  a  color.  Enter  a  value  for  the

luminosity,  or drag the pointer on the slider to set  the luminosity.  Changes you

make using the color editor are stored, when you click the OK button.

Figure 401: Color editor used to select user interface colors
 

Figure 400: Colors section
of the Save setup

Figure 399: Choosing font
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20.4.3 MISCELLANEOUS SETTINGS

20.4.3.1 OPEN WITH BROWSE

If you select it, then ArahWeave opens fabric browser automatically on a start-up.

20.4.3.2 BROWSE WITH FILTER

The browse windows starts with flter enabled, so you can immediately start using it.

20.4.3.3 HIDE SAVE MENU

Some customers work really fast, and sometimes hit  Save instead  Save as. And there is no way back, when

fle is overwritten. But, if you enable Hide save menu, then this will never happen to you again.

20.4.3.4 HIDE LOAD MENU, USE BROWSE

As the option name indicates, the Load fle dialog is hidden, you can use Browse instead of it.

20.4.3.5 MOUSE WHEEL DOWN – ZOOM IN

You can change default direction of the mouse wheel zooming.

20.4.3.6 OPEN NEW FABRIC IN DEFAULT VIEW

When you load a new fabric, it will use the default view setting, regardless of current view.

20.4.3.7 HTML LOGO SIZE %

It is quite difcult to predict the size of the logo in the HTML printout. So you can adjust HTML logo size% to

your liking.

The logo fle is same as it is used on printout – it is stored in  /home/capdam/data/html  directory and the

flename should be logo.gif but it can be in any graphical format.

20.4.3.8 REGISTERED DESIGN TEXT

The text, which you have in the Registered design text feld, will be printed (or saved) in the fabric simulation

printout (if you enable it in the Print fabric to printer dialog).

20.4.3.9 CUSTOM PRINT TEXT

The text, which you have in the  Custom print text feld, will  be printed (or saved) in the fabric simulation

printout (if you enable it in the Print fabric to printer dialog).

20.4.3.10 TITLE

In the Title section, you can declare what data is used for right-side part of the title. You can include Owner

(the Owner’s name from Save setup), User ( name of the user’s account), Date, and the fabric Filename.

Here you can also enter the web site address, you want to be printed in the title.

Figure 402: Registered design text, custom print text and the title in the printout
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21 SUPPORTED FORMATS

21.1 WEAVING CAM FORMATS

You can write these formats from  Save cards for production window, and read from the  Browse Jacquard

cards window,  or  the  Browse  weaves or  Load  weave window.  ArahWeave recognizes  fle  format

automatically, and displays fle icon in the browse window. All CAM formats are treated as binary, black and

white images.

Name
Read

Write

Filename

extension
Type Notes

JC3
rw .JC3 jacquard

• non-DOS foppy, one design per foppy

• multiple foppy support for large designs

• can be written as a DOS fle, for sending by e-mail

JC4

JC4B

rw .JC4 jacquard

• non-DOS foppy, several designs per foppy possible

• multiple foppy support for large designs

• can be written as a DOS fle, for sending by e-mail

JC5
rw

.JC5

.ZC5
jacquard

• optional compression (good)

• multiple foppy support for large designs

JC6
rw

.JC5

.ZC5
jacquard

• same as JC5, but with fabric simulation for the fle icon on the

loom, weft yarn count and color information in the text feld

rw .EP jacquard
• optional compression (poor)

• multiple foppies

rw .WEA jacquard

• multiple foppies support (flenames on all foppies are same; if

you send fles by email  you have to rename them, and when

you  copy them  back to  foppies,  you  have  to  rename  them

back to original flename

rw .S01 jacquard

Copu-Jacq

rw .JP1 jacquard
• handloom electronic jacquard format

• includes support for display of weft colors

rw .DAT jacquard

Actrom
rw

.P

.S01
jacquard

• including support for multiple foppies

• two fles for one design!

Varitex rw .PAT jacquard • for narrow weaving

Arahne

weave
rw native

• textile CAD manufacturer

• compressed format

• ideal for browsing of weaves, will load fastest

• unifed format for jacquard and dobby weaves

• contains shaft information

• contains weave system information

• optional separate weaves for left and right selvedges

Sophis card
rw punch • textile CAD manufacturer (reverse engineering)

Sophis weave
r import

• textile CAD manufacturer (reverse engineering)

• only normal weaves are supported, not compound weaves

card
rw punch • textile CAD manufacturer (reverse engineering)

weave
r .BBI import • textile CAD manufacturer (reverse engineering)
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Name
Read

Write

Filename

extension
Type Notes

r .PUN punch • textile CAD manufacturer (reverse engineering)

QTE r .QTE import • textile CAD manufacturer (reverse engineering)

PNG rw .PNG image

• Arahne's default format

• compressed format

• supported in browsers and mailing programs

GIF rw .GIF image
• compressed format

• supported in browsers and mailing programs

TIFF rw
.TIF

.TIFF
image • optional compression

BMP rw .BMP image
• optional compression

• For use with Digital Weaving TC-1

Weaving

Information

File

rw .WIF dobby

• for interchange of weaving fles among hobbyist programs

• up to 99 shafts

• up to 24 weft selectors

• warp/weft pattern

• warp/weft colors

• warp/weft density

Tech
w .SF2 dobby

• up to 24 shafts

• variable weft density

• fringe

• regulator

w .AMV dobby • writing to foppy

DoStyle
rw dobby

• up to 28 shafts

• variable weft density

• variable warp tension

• variable weft speed

DoTech
w .PAT dobby

DoWeave
rw .DES dobby

JiangYin

TongYuan

SGA598 rw .DY dobby

• up to 20 shafts

• up to 8 weft selectors

• up to 4 variable densities, regulator interpreted as second weft

density

FAST
rw .ARM dobby

• flename limit 6 characters

• up to 20 shafts

• up to 8 weft selectors

• variable weft density

• regulator

• pile height

w .D dobby
• up to 28 shafts

• variable weft density

w .des dobby

• up to 24 shafts

• up to 8 weft selectors

• fringe

• loom speed

• up to 8 variable densities
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Name
Read

Write

Filename

extension
Type Notes

G6300
rw .ARM dobby

• up to 24 shafts

• up to 16 weft selectors

• fringe

• double weft insertion

• up to 16 variable weft densities

rw .DOP dobby • dobby information (can also contain weft change)

rw .COP dobby • weft change information

1858 III
rw .DB1 dobby

• up to 28 shafts (26, if used with variable density)

• up to 8 weft selectors

• regulator

• up to 4 variable weft densities

rw .UWF dobby

rw .PID dobby

• up to 27 shafts

• up to 12 weft selectors

• fringe

• regulator

• variable weft density

rw .PIW dobby

• up to 12 weft selectors

• fringe

• regulator

• variable weft density

AT710
w dobby

• up to 20 shafts

• weft change information

• variable weft density, with absolute density values

• fringe

• regulator

• double weft insertion

21.2 IMAGE FORMATS

All image formats are automatically detected, no user intervention is necessary. The weaving CAM formats

are also read as black and white images, but we will not repeat them here.

For saving in selected format, just add the flename extension. Without extension, the program will save the

image as PNG fle.

File format Read

Write

Filename

extension

1-bit 8-bit

colormap

24-bit

true

color

Notes

PNG rw .PNG ✔ ✔ ✔ • Arahne's default format

• very good compression

• Alpha  channel  transparency  is  not

supported

GIF rw .GIF ✔ ✔ • good compression

• interlaced GIF is not supported

• transparent  colors  in  GIF  are  not

supported

JPEG rw .JPG

.JPEG

✔

grayscale

only

✔ • lossy compression – saving image several

times will lose details;

• not  appropriate  for  saving  cleaned  up

jacquard images

TIFF rw .TIF

.TIFF

✔ ✔ ✔ • optional compression
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File format Read

Write

Filename

extension

1-bit 8-bit

colormap

24-bit

true

color

Notes

BMP rw .BMP ✔ ✔ ✗ • optional compression, but very bad

• 24-bit  is  not  supported  in  Arahne's

programs

PBM r .PBM

.PGM

✔ ✔ ✔ • not compressed

Sophis

image

r ✔ • textile CAD manufacturer

• (reverse engineering)

• not compressed

CSS JacquArt r .APF ✔ • textile CAD manufacturer

• optional compression

EAT image

r ✔ • textile CAD manufacturer

• reverse engineering

• not compressed

• .eatpc not supported

IAM image

r .PAT ✔ • textile CAD manufacturer

• reverse engineering

• not compressed

Colorado

image

r ✔ • textile CAD manufacturer

• reverse engineering

• compressed

r .PAT ✔ • textile CAD manufacturer

• not compressed

Text w .TXT ✔ • for manual card punching

21.3 OTHER CAM FORMATS

ArahWeave also supports drawing-in machines, and Suzuki warper.

Name Read Write Filename extension Type Notes

CCI Tech w .SF2 warper

Vega

w .VIF drawing-in • shafts

• reed

• empty dents

• drop wires

SuperVega w .SVI drawing-in • shafts

• reed

• empty dents

• drop wires

Delta 110

drawing-in • not yet implemented

• documentation available

Suzuki

w .MZ warper

JiangYin TongYuan w .CEL warper
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21.4 XML FORMATS

All XML fles should be placed in the default xml location, specifed in the .arahne confguration fle. If the fles

are only shared by NFS, then this location is usually /home/capdam/data/xml

If the fles are shared by web server, then this location is usually /srv/www/htdocs/xml

For simulation/weave orders/replies we place the XML fles in subdirectories, to avoid confusion.  ArahWeave

imports also XML fles by ftp from the specifed host, this is confgured in the  Data export section of  Save

setup, and saved in .arahne confguration fle.

Name Read

Write

Format DTD

(document type defnition)

Notes

xyz.xml w ArahneFabric.dtd • xyz corresponds to fabric 

name

• contains all fabric related 

data, which EDP software 

would need

ArahneWarpPatternImport.xml r ArahneWarpPatternImport.dtd • warp patterns and codes, 

no colors

• all patterns in one fle

ArahneWeftPatternImport.xml r ArahneWeftPatternImport.dtd • weft patterns and codes, 

no color

• all patterns in one fle

ArahneYarnColorImport.xml r ArahneYarnColorImport.dtd • list of yarn colors

• all colors in one fle

ArahneYarnImport.xml rw ArahneYarnImport.dtd • yarn defnitions from 

database point of view

• all yarns in one fle

ArahneYarnToColor.xml r ArahneYarnToColor.dtd • association of yarn color 

code to yarn code, with 

price and availability

• all yarns in one fle

ArahneFabricStatus.xml r ArahneFabricStatus.dtd • list of diferent statuses, 

like Sample, Production, 

Test...

ArahneFabricTypeBits.xml r ArahneFabricTypeBits.dtd • list of fabric types, 

fnishing processes

ArahneFinishingBits.xml r ArahneFinishingBits.dtd • list of fnishing processes

ArahneDesigners.xml r ArahneDesigners.dtd • list of designers

ArahneFinishingImport.dtd r ArahneFinishingImport.dtd • list of diferent fnishing 

processes with code for 

each process

ArahneCustomerImport.dtd r ArahneCustomerImport.dtd • list of customers

ArahneSeasonImport.dtd r ArahneSeasonImport.dtd • List of seasons, like Spring 

2018, ...

http://www.arahne.si/xml/ArahneSeasonImport.dtd
http://www.arahne.si/xml/ArahneCustomerImport.dtd
http://www.arahne.si/xml/ArahneFinishingImport.dtd
http://www.arahne.si/xml/ArahneDesigners.dtd
http://www.arahne.si/xml/ArahneFinishingBits.dtd
http://www.arahne.si/xml/ArahneFabricTypeBits.dtd
http://www.arahne.si/xml/ArahneFabricStatus.dtd
http://www.arahne.si/xml/ArahneYarnToColor.dtd
http://www.arahne.si/xml/ArahneYarnImport.dtd
http://www.arahne.si/xml/ArahneYarnColorImport.dtd
http://www.arahne.si/xml/ArahneWeftPatternImport.dtd
http://www.arahne.si/xml/ArahneWarpPatternImport.dtd
http://www.arahne.si/xml/ArahneFabric.dtd
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21.4.1 ARAHWEAVE SERVER MODE XML FILES

Name Read

Write

Format DTD

(document type defnition)

Notes

xyz.xml

...xml/simulationOrder/in

r ArahneSimulationOrder.dtd • xyz  corresponds  to

simulation order

• specifes  request  for

generation  of  fabric

simulation  based  on

warp, jacquard card, weft

density and weft yarns

xyz.xml

...xml/simulationOrder/out

r ArahneSimulationOrderReply.dtd • xyz  corresponds  to

simulation order reply

• reports success or reason 

for failure

xyz.xml

...xml/weaveOrder/in

r ArahneWeaveOrder.dtd • xyz corresponds to weave

order

• specifes request for 

creating card fles and 

sending them to the loom

xyz.xml

...xml/weaveOrder/out

w ArahneWeaveOrderReply.dtd • xyz corresponds to weave

order reply

• reports success or reason 

for failure

xyz.xml

...xml/deleteOrder/in

r ArahneDeleteOrder.dtd • xyz corresponds to delete

cards from loom order 

• specifes request for 

deleting jacquard card fle

from the loom

xyz.xml

...xml/deleteOrder/out

w ArahneDeleteOrderReply.dtd • xyz corresponds to delete

order reply

• reports success or reason 

for failure

xyz.xml

...xml/reloadCardOrder/in

r ArahneReloadCardOrder.dtd • xyz corresponds to reload

card from loom order

• specifes request for 

reloading jacquard card 

fle from the loom

xyz.xml

...xml/reloadCardOrder/out

w ArahneReloadCardOrderReply.dtd • xyz corresponds to delete

order reply

• reports success or reason 

for failure

xyz.xml

...xml/headerFooterOrder/in

r ArahneHeaderFooterOrder.dtd • xyz corresponds to 

header/footer order

• specifes request for 

generation of header and 

footer fabrics with 

weaving program and 

optional text.

xyz.xml

..xml/headerFooterOrder/out

w ArahneHeaderFooterOrderReply.dtd • xyz corresponds to 

header/footer reply

• reports success or reason 

for failure

http://www.arahne.si/xml/ArahneHeaderFooterOrderReply.dtd
http://www.arahne.si/xml/ArahneHeaderFooterOrder.dtd
http://www.arahne.si/xml/ArahneReloadCardOrderReply.dtd
http://www.arahne.si/xml/ArahneReloadCardOrder.dtd
http://www.arahne.si/xml/ArahneDeleteOrderReply.dtd
http://www.arahne.si/xml/ArahneDeleteOrder.dtd
http://www.arahne.si/xml/ArahneWeaveOrderReply.dtd
http://www.arahne.si/xml/ArahneWeaveOrder.dtd
http://www.arahne.si/xml/ArahneSimulationOrderReply.dtd
http://www.arahne.si/xml/ArahneSimulationOrder.dtd
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Name Read

Write

Format DTD

(document type defnition)

Notes

xyz.xml

..xml/statusOrder/in

r ArahneStatusOrder.dtd • xyz corresponds to staus 

order

• it serves only to test if 

ArahWeave server is 

running, it does not 

perform any operation

xyz.xml

..xml/statusOrder/out

w ArahneStatusOrderReply.dtd • xyz corresponds to status 

order reply

22 GLOSSARY

This is not a true glossary, only some tips to help you out of confusion in textile terms. It lists the synonyms for

a given term. Some of these terms do not really mean exactly the same thing, but are often interchanged in

the industry. We only use one term, so that reader will not assume we are talking about two diferent things.

• warp thread = end

• weft thread = pick

• weft density = pick gear

• weave = weave structure = binding

• pattern draft = dobby weave with all the elementse weave, drafting, tie-up, dobby card

• regulator = warp let-of = stop-motion = dead pick = cramming

• shaft = heald

• fabric = cloth

• drafting = draw-in = heddling = threading

• dobby card = peg plan = chain

• yarn = thread

• warp yarn = end

• weft yarn = pick = flling = fll

• multi-layer weave = compound weave = double weave

• weft change = weft selector = box motion

• extra weft = lancee = supplemental weft = fguring weft = tissue pick

• blanket = colorway

• cone = bobbin

• fll coupe, antique cut

23 KEYBOARD ACCELERATORS

Keyboard accelerators (also called hot-keys) should enable an experienced user to work faster, by being able to

select some commonly used functions directly from the keyboard instead of the menu. We have decided not to

translate  accelerators  –  that  means  that  we  have  the  same  key accelerator  layout  for  all  the  languages.

Mostly, they are mnemonic in English (frst letter resembles the function in English). Accelerators work only if

the appropriate window is active; normally the active window is indicated in a diferent window frame color.

We have tried to link one key to one program function, but in some cases it was also logical to make the same

key activate diferent functions, depending on the active window (part of the program we are working on at

the moment).

http://www.arahne.si/xml/ArahneStatusOrderReply.dtd
http://www.arahne.si/xml/ArahneStatusOrder.dtd
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24 LIMITS

ArahWeave is a very powerful program, but it has its limits. Mainly, these limits were imposed so that we could

perform more efcient range checking on user entry, faster fles loading, to improve reliability.  Sometimes

they are also motivated by deeper technical reasons. In any case, you have the right to know what they are, so

you do not buy the program, and later discover you cannot do your job. Obviously, we can also raise some of

these limitations, should it prove to be necessary.

• Maximum  weave sizee  ArahWeave Pro 65520 by 65520 threads; ArahWeave Pro XL 262 080 by 262080

threads

• Maximum number of shaftse 99

• Maximum size of image for jacquard conversione 65520 by 65520

• Maximum number of hooks in jacquard loom layoute 65520

• Maximum number of entries in the description of loom layoute 50

• Maximum number of warp threads in consumption calculatione 65520

• Maximum number of threads in one dente 125

• Empty dents (0 threads per dent) are supported, but fabric cannot start with an empty dent, and cannot

have only empty dents

• Maximum number of consecutive wefts with active regulatore 125

• Fabric cannot start with active regulator.

• Accurate fabric simulation, where top layer yarns completely cover bottom layerse 3 warp systems, 3 weft

system. It is possible to make simulations of fabrics with more layers, but they will appear more open, not

completely closed.

• Maximum weave systeme 16 warps and 16 wefts.

• Number of diferent yarns in warp or in wefte 25 (A-Y)

• Maximum number of diferent color components within one yarn (for mélange, moulinè, space dyed)e 6 (all

of them can be calibrated colors); internally ArahWeave generates two darker and two lighter variations of

each color, so the actual maximum number of colors in simulation of one yarn is 30.

• Maximum  number of fabrics /  images /  weaves /  yarns /  warp patterns /  weft patterns in the browserse

unlimited. We have tested the system with over 150.000 fles loaded contemporary and it worked without

problems.

• Maximum number of sections in blanket in warp and in wefte 30

• Maximum number of threads in one blanket sectione 3000

• Maximum number of threads in one weft blanket sectione 20000

• Maximum number of fabrics / weaves, which can be assembled together in a weft blankete 80

• Maximum number of color / yarn variations of a single fabric / weave in weft blankete 15

• Maximum number of colors in a color databasee 65520

• Limits for entry of CIE Lab valuese 0<=L<=100, -120<=a<=120.0, -120<=b<=120;

• Two decimal points Fabric densitye minimum 1 thread per cm; maximum 50000 threads/cm

• Reed numbere minimum 1 (dent/cm); maximum 1000 (dents/cm); 2 decimal points

• Reed space, raw width, fnished widthe minimum 5 cm; maximum 10000 cm; 2 decimal points

• Fabric zoom levele minimum 5% (twenty times smaller); maximum 1600% (sixteen times bigger)

• You can only work on one fabric at a time, but you can contemporary run as many copies of ArahWeave as

you like.
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